Previous 1 2 3 4 5 Next 169 Replies Latest reply: Mar 30, 2015 3:14 PM by ejn Go to original post
  • allan258 Level 1 Level 1 (0 points)

    Had the same problem. I deleted all the voice memos on the iphone (4S) and it worked immediately.

  • ernestfromchavannes-de-bogis Level 1 Level 1 (0 points)

    I have the same issue. PC, iTunes 10.5, iOS 5 with iPad 1. Sync stays at Waiting for changes to be applied and then a dialog box says that the sync could not be completed. It seems to be linked to the number of Photos. If I try a sync with more than 8000 pictures it hangs, with less it works fine. There must be some sort of time out or buffer overflow...

  • allan258 Level 1 Level 1 (0 points)

    I did not need to do anything so radical as Restore. In my case I deleted a number of small voice recording files on my iphone and it all worked perfectly.

  • grzes_l Level 1 Level 1 (0 points)

    Yes I think I found the reasons.

    1. Do you have an iPad?

    2. Do you synchronize it via WiFi?

    3. Do you have e-books both on iPad and iPhone?

     

    Generally when you do the syncing click click the iphone drop down on your left side of iTunes, there you have a list of iPhones libraries. You will see what is grey in which library. If these are not voice memos. Then yoy will see probably grey books, which are somehow not properly synchronized also with iPad.

     

    Connect simultaneously your iPad and your iPhone using cables. Disable the WiFi synchro (this is messing also).

    First sync iPad then iPhone.

     

    If it is not the case look for the said grey positions in iPhone library. The ones which are problematic, either delete from library for a moment. Or send them by email to your iPhone.

     

    Somehow, although my suggestion with voicememos worked for some of you I dont have any points

    If this one works I hope for some

  • cagey8828 Level 1 Level 1 (0 points)

    I had the same problem with my ipad. By removing sync photos, I was able to sync music. Now I will try

    to sync photos by removing sync music. Seems to be an overload issue

  • chat2ian Level 1 Level 1 (5 points)

    Deleting voice notes worked for me, thanks grzes_l

  • Daniel Brown Level 2 Level 2 (430 points)

    I was having the same issue. I had "Manually manage music and videos" checked. But under the Photos section, I had "Sync Photos from" selected with a folder chosen. I would hit sync under that and get the freeze at step 6 like everyone here.

     

    I wondered, if iTunes is confused because I have it set for me to do things manually but then with photos I was asking it to sync whatever was new in my particular pictures folder automatically.

     

    After unchecking the "manually manage music and videos" box in the main Summery window, everything worked.

  • labhustle Level 1 Level 1 (0 points)

    also went out and bought the new iphone 4s and came home it was fine for a while but then when i plugged it into itunes it first said waiting for changes to be applied and then it said waiting for something else. after i plugged my phone in and did a full reset everything is blazzingly fast. i am guessing that an app i downloaded and tried to push music from to my itunes may have been the problem because i tunes was trying to figure out what it was i was trying to accomplish. WARNING apple is very strick in what information it gives out and what information there products takes in. this is one of the reason why an aple product hardly ever catches a virus. if you down load a music app for exsample download free music app and you go to mp3 skull and download alot of crap and then go to itunes and then try and push it to your itunes then it is going to try and constantly pull information for each song witch will in time cause problems with your device. it is better to keep the songs you download off of one of those apps rite there in that app!!! and just listen to it there. after i took all the music off that i added and reset it no more problems. BEWARE make sure you are not in a roaming location after restoring the device because it will not activate unless you are on you own carriers network.

  • mac4jose Level 1 Level 1 (0 points)

    This totally worked for me, saved me a buttload of time. Thanks grzes!! 

  • J Williams Level 1 Level 1 (10 points)

    What worked for me was unchecking voice memos and also deleteing all voice voice memos from your phone and the resyncing.. i tried everything else, this worked.. thanks

  • RadioDr Level 1 Level 1 (0 points)

    Nothing that's been suggested in this forum has worked for me.  iPhone 4 with iOS 5.0.  No matter which of the suggestions I try, and I tried them all one at a time, "Waiting for changes to be applied" remains posted on my iTunes screen.  It would probably stay all week if I didn't simply eject my iPhone and stop the process.

     

    On the other hand, I can't see (at least so far) that any of my content has failed to sync to the iPhone or to be backed up.

  • Daniel Brown Level 2 Level 2 (430 points)

    I was able to get it to work WITHOUT doing a restore.

     

    I deleted the Voice Memo recordings on the phone (first I emailed them to myself though so I wouldn't loose them forever.)

     

    That solved it for me.

     

     

    (PS: I noticed the problem only happened after I made my first audio memo recordings)

  • samschroder22 Level 1 Level 1 (0 points)

    Same issue with my new iPhone 4

    macbook pro, new install of snow leopard, freshly updated iPhone

     

    Wont finish syncing! Although it seams to sync everything properly. still an annoying bug.

     

    I also cant get my contacts from iCloud to my computer.

  • Saionjik Level 1 Level 1 (0 points)

    I had the same problem and got it to work by DELETING ALL MY VOICE MEMOS.

     

    I have an Iphone 4s and iTunes 10.5.0.142 .

     

    No restore needed

  • yff Level 1 Level 1 (0 points)

    thanks togrzes_l

     

    deleted voicememos and worked!

Previous 1 2 3 4 5 Next