Previous 1 6 7 8 9 10 Next 181 Replies Latest reply: May 8, 2014 10:00 AM by Developer Ryan Go to original post
  • epicnguyen13 Level 1 (0 points)

    after reading some of everyone's posts, i finally had an easy solution that worked for my phone.


    i found that some of my voice memos were greyed out, very similar to a screenshot someone posted on this thread. i ended up having to delete all my voice memos, and when i synced my phone, the memos were still on my phone. so i manually deleted all the ones from my phone as well. i synced it again, and it now it works perfectly.


    my guess is to look around in your library and see if you see any weird files that might be greyed out. those files could be screwing up the syncing process. hope it works for everyone else.

  • MadyVodka Level 1 (0 points)

    Just delete all your voice memos

  • johnny wishbone Level 1 (0 points)

    i have a similar issue with my iphone 4, waiting for items to copy. i dont use icloud,the voice memos, ibooks, photo apps etc, as soon as i plug the phone into the laptop & the phone automatically syncs, the sync gets to step 7 & then ,waiting for changes to b applied, then clicks over to waiting for items to copy & is still doing so as i type. this syncing issue happens whether im connected via usb or wi-fi. this has been happening for the past 3 days now, outta the blue.

  • srinivas486 Level 1 (0 points)

    I faced the same problem but following the below steps seem to solve the issue..


    1) Disconnected my Iphone from PC

    2) Restarted Itunes

    3) Deleted all Voice Memos from my Phone

    4) Connected the phone to Pc, started Itunes

    4) Transferred all my purchases to itunes by right clicking on my device from itunes

    5) Did a backup of the phone  by right clicking on my device from itunes

    6) Now when I tried to sync.. It completed without a hang at "waiting for changes to b applied" step..


  • nellgreen2 Level 1 (0 points)

    I was able to have it finish syncing by not having it sync my photos... which is a bummer.  I don't know if there is another solution but for me removing all pics (or just not having them sync) solved the problem. 

  • Richard Liu Level 1 (45 points)



    Did you by any chance receive one or more messages about a certain kind of photo not being playable on your iOS device, and hence, that such photos would not be synced, when you were syncing photos?



  • Alf Megson Level 1 (100 points)

    I just found a similar situation with four identical orphan Voice Memos but it isn't necessary to take such drastic steps to delete them.


    If you select the device then click Summary at the top.


    Scroll down to Options.


    Then select Manually manage music and videos.


    Go back to the device and click the discliosure triangle.


    Click on Music and you can now select and delete anything you want to remove, including Voice Memos.


    If you want your music and videos to be synced automatically, you should now go back and deselct Manually manage music and video.


    This has been driving me daft but thanks to the Voice Memo tip I read on another site and your tip, I sorted the problem out - though without having to Restore.

  • bgunsberger Level 1 (0 points)

    After trying many solutions suggested here I fixed the problem by deleting all the synced apps from my Mac's harddrive (<itunes library>/Mobile Applications). Synced first time, no problems.

  • adewey Level 1 (0 points)

    I have had this problem  with my iPod, and I found the solution was to use only the USB cord to connect it to my PC - for some reason my stereo dock was not allowing stuff to copy (or the iPod to update). It frequently caused it to freeze up and the only solution was to restore


    I have had this problem as long as I've owned my iPod and it has never been fixed with any of the updates. FYI my stereo dock is the Audyssey South of Market.

  • cubanico Level 1 (0 points)

    i used a suggestion from the beginning of this thread. I went to each category in iTunes and if "apply" button was visible and active, I pressed it. also in that post it said to uncheck "include videos" in the photos tab. so i checked "sync photos" unchecked "include videos" and the unchecked sync photos again. and of course clicked on the "apply" buttoh. immediately after all that, itunes finally said "finishing sync"

  • greengeek Level 1 (0 points)

    I deleted the ipod photo cache directory in the directory I was syncing photos from on my PC (windows7 sorry folks) and then resync'd and it worked - twice! With two different iOS devices having same issue.  My issue was the same as mentioned here, but I am sync'ing iPhones

  • Iynque Level 4 (1,140 points)

    Voice memos worked for me. I deleted all of them from my iPhone and copied them out of iTunes before deleting them there too. I changed something in my devices sync settings so the apply button would be available, and then clicked apply. Sync finished just fine.


    I'm not sure, but I bet it would have worked if I just changed something and hit apply without messing with any voice memos. I guess I'll never know...

  • elvis4prez Level 1 (0 points)

    I got the "waiting for items to copy" error then the "waiting for changes to be applied" with the big "other" all in yellow.  I could not uncheck each subitem (contacts, music, podcasts,...) without it restarting the sync then going nowhere and hanging.  I deleted voice memos including the ones under Music, still nothing.  I retried syncing several times after restarting iPhone but still the same endless loop.  If I didn't restart iPhone4, it would be still syncing endlessly (icon in upper left of phone).  Despite all this, info seemed to go back and forth like a regular sync.  I think it somehow got a corrupted file that ended up being the last thing to try and sync; I had a duplicate copy of a ringtone in my phone not seen on the iTunes Library that I think may have been the problem (it had the ! before it when I clicked on it like on the screenshot on page 1 of this string).


    With my phone connected, I made another backup (right click on the connected device i.e. iPhone).  Then in Settings / General / Reset option hit Erase All Content and Settings.  I called this the "Nuclear Option" and prayed it would not take too long to recover.  I then started phone and restored from backup and most everything came up right except a few setting changes (default ringtone, no passcode lock) that didn't take too long.  Big hurrah: it went through the normal sync cycle okay without hanging on either message.


    Hope that helps.  I wasted a lot of time like a lot of the rest of you including a trip to the Apple Store Genius that was limited by the rarity of this (his words) though he did find the Voice Memo "fix" that helped a lot of people (not me!) and suggested the above pathway.  It may be related to the phone coming off midsync with a in-process writing of a file that left it corrupted (per the Genius).

  • cmooney1 Level 1 (0 points)

    Same problem for me.  I have tried everything - full restore, deleting iPod photo cache and pointing the iPad in a south-easternly direction whilst hopping around it four and a half times...ridiculous that so many people are having the same 'waiting for items to copy' issue and Apple are doing nothing.


    iPad 2 wifi



  • HelmutDan Level 1 (0 points)

    I was having the same issue where none of these alternatives were working for me.  Therefore, I decided to monitor the syncing process and spot when the issue arises during the sync process.  For me the process got stuck after copying my ringtones as it would get stuck on the "waiting to copy" message.  I then selected to sync only the selected tones and kept all of the tones unchecked.  I resynched my phone and it went through completely.  Then, I checked the ringtones I wanted to include and it, again, synched completely.   Issue resolved.  Maybe this will work for you or anyone else facing this issue.

Previous 1 6 7 8 9 10 Next