Previous 1 2 3 4 5 Next 73 Replies Latest reply: Oct 16, 2014 1:26 PM by TSJames118 Go to original post
  • Chedges Level 1 (0 points)

    I am still confused and I am not sure if the answers my question or not. My husband has and iphone 4, I have a 3GS. We both share the same itunes account to update our phones, download app, etc. Starting yesterday when I sent an imessage from my phone it came through with the e-mail address on our itunes account and it also showed up on his phone. How do I fix this?

  • Chris CA Level 9 (78,240 points)

    Settings > Messages.

    Set Receive at to your phone number and remove the email address.


    "We both share the same itunes account to update our phones,"

    The same iTunes account (used to make purchases) or the same iTunes library (iTunes you sync with on your computer).

    You should each have your own iTunes account but can share the same library.

  • Chedges Level 1 (0 points)

    I am sorry if I sound stupid, but how? Do I do this on my phone or my itunes account?

  • Chris CA Level 9 (78,240 points)

    iTunes has nothing to do with iMessage.

    On the iPhone go to Settings > Messages.

  • Chedges Level 1 (0 points)

    What if they Recieve at option is already set with my phone number and not the e-mail but it still comes through with his e-mail address and send it to his phone also?

  • Chris CA Level 9 (78,240 points)

    Chedges wrote:


    What if they Recieve at option is already set with my phone number

    Then you need to create an iTunes account (not iTunes library) for you and register the iPhone with that iTunes account.

  • Shelly826 Level 1 (0 points)

    Thank you for the helpful information! I scanned most of the other questions, but I still have one that I'm not sure was touched on.


    How do I stop imessages (conversations) from showing up on my macbook pro that were sent and received from my Ipad?  After messaging others on my Ipad, I'll later, much later log onto my macbook and all the messages will pop up on the macbook even after I've closed the conversation and deleted the messages off my Ipad the original source of the conversation.


    Thanks so much!

  • Azar888 Level 1 (0 points)

    Wow.  Thank you for taking the time to explain this!


  • droddo Level 1 (0 points)

    I am trying to link my wife's imessage to her phone number rather than our shared account.  Sadly when i go into her recieve at setting her phone number isnt visible and there is knowhere to add this.  She hasnt yet upgraded to ios 5.1, not sure if this is relevant?  If anyone knows how to direct her phone to her phone number it would be great to hear.  If not im hoping that by changing the email address to her own yahoo email i should be able to ensure that our phones are independent of each other as far as imessage is concerned.  Thanks in advance...

  • jillbd Level 1 (0 points)

    Hi mate i was facing the same problem and i tried and followed your steps. at the moment my settings are like my iphone 4S. The caller ID option in my iohone is set to "meail adress which is the apple ID and the imessge receiver in both my devices. in my iphone imessage is on and in the option "receive at" it says 2 addresses which is both at my telephone number and in my email address and in my ipad "receive at" is set as with my email address and both the devices it logged in with my apple ID and the email address in imessge for both the devices is my apple ID as well.


    then i tried verifying it...but my friend she did sent me an imessage but i only received it on my iphone 4S not in my Ipad.


    any suggestion....?

  • Jerry Fornal Level 1 (5 points)

    I've found that you actually have to initiate a message through the iPad before it'll start receiving them.  For example - instead of replying from your iPhone - start a new message on your iPad to the same person.  Then, when they reply, it should come to both your iPhone and iPad.


    I've also found that if you restore your iPad - you'll have to repeat this process.  I finally got everything working correctly on my iPad - but then I exchanged it for a Verizon model.  Once I restored - I was having the same issue - I was only receiving messages on my iPhone.  UNTIL I initiated the message on my iPad.  Once I did that, I started getting messages on both devices.


    This can be a pain as you have to do it with EVERY single contact you wish to have messages come through from.

  • jillbd Level 1 (0 points)

    thanks mate it did work for me once i initiated the first message exchange...but is it for real that for all every other contacts from whom i receive i message i do have to do the same? as in initiate for the forst time from my end? isnt there any other way so that from now on both the devices receives the imessages automatically?



  • Jerry Fornal Level 1 (5 points)

    Unfortunately, this is the only way I have ever gotten it to work.  In my situation - there are really only a few people who I message that I care to receive messages on all devices - but I'd imagine it would become very tedious to do this with a lot of contacts...


    Perhaps someone else has found a better way - but for the life of me - I can't figure out any other way.

  • Stema001 Level 1 (110 points)

    Thx for this explanation, but it's clearly a bug. The iPhone/iPad should be able to recognize yourself on an other iOS device as one person. F.ex. I can iMessage with my girlfriend via our iPhones without any problems. If I send her an iMessage via the iPad, she get's a second discussion with my name. This even if she has saved my email adress and iPhone number under one contact.


    This *****. Apple fix it.

  • JohnLMills Level 1 (0 points)

    No, it's not a bug. Once you set up your devices to use the Apple id instead of your phone number, all your messages will synchronise. Then, if you initiate a message and the recipient replies to that message, then they are replying to your apple id and both your phone and ipad will see the message. Than later if that person sends you anothe message by replying in the message thread to the one sent using your apple id, it'll appear on both. However, if that person, or anyone else on your contact list, later sends you a message, and they use your old id, (in other words your phone number), and not the apple id, that message won't appear on both your devices.A message sent using your phone number will break the chain and appear as a separate message thread, and only appear on your phone, it won't appear on your ipad. So, you either have to ask everyone to change your id in their phones, so they only send to your email address, or you ask them to delete all messages and only reply to the one you send using your apple id. As I said, it's not a bug, the ipad is not a phone, it can't recognise and synchronise messages sent to phone numbers.