7 Replies Latest reply: Oct 17, 2011 5:13 PM by ascanio
marksart Level 1 Level 1 (5 points)

I keep getting a 507 message everytime I try to enter a new event in ical. This happened since I started icloud. What's the solution?


iMac, iOS 5
  • marksart Level 1 Level 1 (5 points)

    Anyone out there havin the same problem?

  • marksart Level 1 Level 1 (5 points)

    Actually, this is what it says:

     

    The request for “New Event” in “Home” in account “iCloud” failed.

     

     

    The server responded with

    “507”

    to operation CalDAVWriteEntityQueueableOperation.

  • ascanio Level 1 Level 1 (0 points)

    I do.

    I tried deleting the "Calendars" folder in ~/Library, recreating the calendars and syncing them to iCloud again. No chance. I can't create an event even on iCloud.

     

    Error 507 should be quota exceeded, but I have 4.5 GB on my account. I submitted the error to Apple. Let's hope somebody finds a solution.

     

    If I create an event on my iPhone, it doesn't appear both in iCal and iCloud, even though my iPhone is regularly linked to the iCloud account. Same happens if I move an event. No sync.

     

    @

  • marksart Level 1 Level 1 (5 points)

    I figured it out. Calendars weren't syncing improperly causing the 507 error. You have to make sure the default calendar on your iphone is the same as on your computer/s. So I did the following. 1. exported my Home calendar to the desktop. 2. Signed out which deleted the calendar from my computer 3. Imported the saved calendar from my desktop to the empty ical on my computer 4. Made the Home calendar my default calendar on my iphone 5. Signed in to icloud on the computer. 6. Calendars now synced

  • ascanio Level 1 Level 1 (0 points)

    Uhm... sorry, but I don't understand what you've done. Therefore I'll ask you a few questions

     

    1) I have more than one calendar (actually 10). Therefore, the procedure doesn't seem to work.

     

    2) Did you sign out from icloud just in ical prefs? If so, it doesn't delete the calendars, it just hides them from the iCal window (but the stay in the Calendars folder in the user Library)

     

    3) I've tried it anyway, with one calendar only, it didn't work.

     

    Although, let me tell you that at least the default calendar is the same now... even if I don't know how much that is important, since it sends the calendar name while syncing.

     

    I found out I can modify the existing events, but I still can't create new ones, regardless which one of the 10 calendars I choose.

     

    Is anyone in Apple aware of this??

  • marksart Level 1 Level 1 (5 points)

    It doesn't matter how many calendars you have. You sign out of icloud from System Preferences/icloud. Click on icloud and sign out form there. But before you do that make sure you export your calendars to your desktop. You shouldn't have touch your Library to accomplish this. I will try to make the steps clearer. I assume that you have only tried to do this between an iphone and one computer. If not you will have to repeat the steps for each device unless you haven't signed in to icloud one them yet. If you haven't signed onto icloud from your other devices before you do make sure you go into iCal preferences first and change the Default Calendar as instructed below. All the Default Calendars must be the same.

     

    1. Export your calendars to your desktop from your computer.

    2. Sign out of icloud from System Preferences/iCloud.

    3. This should delete all your calendars in iCal on your computer.

    4. Go to iCal preferences and choose your default calendar.

    5. Go to your iphone and go to Settings/Mail,Contacts,Calendars

    6. Scroll till you find you get to Default Calendar

    7. Make the Default Calendar the same one that you chose for your computer

    8. Import your calendars that you saved on your destop back into iCal on your computer

    9. Once that is complete sign into iCloud

    10. Again, you should repeat the process for each device if you already signed on. If not you just have to go to iCal preferences on those devices and make sure that all of them have the same default calendar.

     

    I hope this works for you....Good luck!

  • ascanio Level 1 Level 1 (0 points)