Previous 1 2 3 Next 86 Replies Latest reply: Jul 21, 2014 8:11 PM by Armando Vidal
Craig Bevan Level 1 (5 points)

I have just bought a Nikon 3100 camera and when I try to import photo's into Iphoto, IPhoto unexpectedly quits. All software is upto date and running iPhoto 11 9.2.

I have imported the photos into Image capture and they are stored in the pictures folder. But then when I try to import into iphoto from the pictures folder IPhoto crashes again.


Any ideas?

iMac, Mac OS X (10.7.2), iPhoto
  • Harryvv Level 1 (0 points)

    I believe Apple has a bug in their newest update to iPhoto, until they come up with a fix you and I and everyone else may as well go find something else to do.  Congradulations on your new Nikon, at least some things work.  It's good that you have your photos in a file on your computer, make sure to back them up to another external hard drive and never rely on iPhoto to be your main storage.  Let's hope they come up with a solution fast!

  • Terence Devlin Level 10 (136,710 points)

    Are you importing Raws or Jpeg?


    Can you post the first 50 lines of the Crash log.


    There is no bug in the newest update to iPhoto. Some folks have had issues with crashes caused 3rd party plug-ins and codecs.


    Iphoto is prefectly safe as your "main storage" but you must always have a back up for all important data on your Mac.






  • Craig Bevan Level 1 (5 points)

    Can not seem to see the replies to my initial question, don't know why? Only on emails received! Any way TD asked for some lines of the crash log. Also tried to import a photo from another camera that has always worked and the same has happened again, so now I know it's not a problem with the camera. Photo's are being imported as Jpegs not Raw.


    Process:         iPhoto [691]

    Path:            /Applications/


    Version:         9.2 (9.2)

    Build Info:      iPhotoProject-626000000000000~2

    Code Type:       X86 (Native)

    Parent Process:  launchd [552]



    Date/Time:       2011-10-16 20:21:42.272 +0100

    OS Version:      Mac OS X 10.7.2 (11C74)

    Report Version:  9



    Interval Since Last Report:          113522 sec

    Crashes Since Last Report:           6

    Per-App Interval Since Last Report:  750 sec

    Per-App Crashes Since Last Report:   1

    Anonymous UUID:                      1043559A-CD8B-42BD-91B6-CF44C7F4D67F



    Crashed Thread:  36  Import thread 0



    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000016957140



    VM Regions Near 0x16957140:

        __TEXT                 000000001687f000-0000000016950000 [  836K] r-x/rwx SM=COW  /Library/Application Support/3ivx/*.dylib

    --> __DATA                 0000000016950000-000000001698b000 [  236K] rw-/rwx SM=COW  /Library/Application Support/3ivx/*.dylib

        __DATA                 000000001698b000-00000000169ab000 [  128K] rw-/rwx SM=PRV  /Library/Application Support/3ivx/*.dylib



    Application Specific Information:

    objc[691]: garbage collection is OFF

  • bhenry Level 1 (0 points)

    I am having the same problem. I cannot import any photos from my iphone after I updated to 9.2

  • Harryvv Level 1 (0 points)

    It most certainly is a bug in the new iPhoto update.  I import only RAW and iPhoto crashes.  I have no plug-ins.  When Apple first put out iPhoto 11  many people lost their entire catalog of photos in iPhoto and Apple rapidly came out with an update, too bad for the people who lost photos.  There are never any bugs in Apple's updates until they report a bug when they come out with a new update.  Well I guess this is a good time to start using Adobe Lightroom.

  • Terence Devlin Level 10 (136,710 points)

    This crash  is caused by a 3rd party plug-in


    /Library/Application Support/3ivx/*.dylib


    Remove it from


    /Library/Application Support






  • Terence Devlin Level 10 (136,710 points)

    Plese explain how this 3rd party plug-in is a "bug in iphoto".


    Oh, and it's a QuickTime Plug-in, not an iPhoto one. The fact that you import Raw is no matter. And I'm not sure I agree with your version of history either. Enjoy Lightroom.

  • caro9 Level 1 (0 points)

    My 3ivx folder was not in the Application Support folder, but there was a nifty little uninstall file in the 3ivx folder. I uninstalled, restarted iPhoto & boom, my photos are importing! Thanks so much.

  • Harryvv Level 1 (0 points)

    Thanks for the input on this.  Sorry for being so negative but this must  be an Apple plug-in seeing it's related to Quick Time.  I think Apple is moving too fast with this iCloud thing.  I am always secure that Apple does correct things but just think about the poor souls out there that are having this problem, can't figure it out, and don't know where to go to find help.  Apple will have to come out with a fix for this!  For the everday Photographer iPhoto is hands down the best for simple editing.  For more serious editing Lightroom3 seems to be increasingly most popular for more complicated edits.

  • danrostron Level 1 (0 points)

    I had the same issue, and the suggestion Terence makes about removing 3ivx worked for me. Thanks very much!

  • Javier D Level 1 (0 points)

    had the same issue then read a part of this post and noticed one similarity is that 3ivx player shows up on all the errors and errors you guys are getting so i went to spotlight and searched  3ivx and the uninstaller comes i then went ahead and uninstalled it and now my iphoto is working like a charm... good luck

  • Terence Devlin Level 10 (136,710 points)
    Sorry for being so negative but this must  be an Apple plug-in seeing it's related to Quick Time


    Must it?



    3ivx Technologies Pty. Ltd. is a dynamic Australian Company that has a creative team of MPEG-4 specialists...
  • JFulf Level 1 (0 points)

    I had the same exact experience (3ivx folder was not to be found in Library).  I DID also find the uninstall app through a spotlight search and, so far, iPhoto 9.2 seems to have stabilized.  Haven't tried imports yet, but before taking 3ivx out of the picture, I couldn't even get it to open.  Here's the question: how does 3ivx ever get installed?  I don't remember ever putting it on my machine?

  • Terence Devlin Level 10 (136,710 points)

    It's installed by third party apps and devices -  the Flip camera being one, for instance.






Previous 1 2 3 Next