Previous 1 2 Next 22 Replies Latest reply: Aug 17, 2012 1:20 PM by Sharkbait574
rehabrajab Level 1 Level 1

I'm getting an error -49 when I try to export an iMovie project into HD or QuickTime .MOV format. I've just got my new MAC with Lion O/S. I didn't have any problems in the past with my Snow Leopard.

iMovie '11, Mac OS X (10.7.2)
  • cmauk86 Level 1 Level 1

    I'm having the same issue but the error appears when I'm trying to use the share to youtube option. I somehow got one of my videos up by restarting my mac but the problem persists and I'm unable to solve the issue. This started happening after upgrading to Lion 10.7.2 .

  • elikness Level 4 Level 4

    Looked up the error and found this:


    -49opWrErrFile already open with with write permission


    Try doing a Repair Disk Permissions using Disk Utility. Reboot the Mac and when you hear the chimes hold down the Option key to start off of the Recovery Volume. Use the arrow keys to select the Recovery Volume and hit Enter. Then when you see the desktop, choose Disk Utility > Repair Disk Permissions. Restart the Mac then open iMovie and see if you can export.

  • cmauk86 Level 1 Level 1

    I've tried that for my issue and hasn't solved it unfortunately.

  • elikness Level 4 Level 4

    Did you use the Migration Assistant to move your old files and applications to the new Macintosh? It may be that the old iMovie preference file got migrated as well. So one thing to try is delet the iMovie Preferences file. Try this:


    Go to the Desktop, then choose the Go Menu (hold down the Option key) and choose Library from the pull-down menu


    Go to Preferences > and drag that file to the trash.


    Restart iMovie and try doing another export by going to the Share Menu > Export Movie... and choose the Large Size instead of HD. Save it to the desktop and see if you get the same error message.

  • tethybaboo Level 1 Level 1

    Perfect. It works! But what if I need to export in HD format? Trying to export in HD returns the same error message....

  • elikness Level 4 Level 4

    There's so many people on this thread, all I can ask is have you attempted to perform a Repair Disk Permissions on your hard drive yet?

  • tethybaboo Level 1 Level 1

    Yes. Done. And after deleting the imovie preferences (, as suggested), exporting in large format works fine, but trying to export in HD format gives always the same -49 error...

  • cmauk86 Level 1 Level 1

    Have you tried to re-import the footage? that sorted my issue with the same error number.

  • tethybaboo Level 1 Level 1

    Re-imported footage, deleted imovie preferences, repaired disk permissions, restarted imovie and restarted the Mac . But still the same problem trying to export in HD format (but works exporting in "large" format)... very annoying...

  • elikness Level 4 Level 4

    Next question, How long is the run time for the video you're trying to export. I've been noticing other complaints with error -49 in them and there seemed to be a relationship between the 'size' of the project and whether or not the error popped up. The longer the project the more likely the error. Shorter length seemed to allow HD output. I don't know where the cut-off point is though. One person claimed it was 500MBytes, but that's a file size not a length of time that the video would run while being played.

  • roberson antequera Level 1 Level 1


    I found a way to turn around.

    1- download Houdini

    2- start imovie and let the project ready

    3- start movie encode

    4- start Houdini and erase all quicktime hidden files on desktop, documents and movie folders. There were big files bigger than 6 GB, I erased all.


    Tried this way two times and everything goes ok. I could export my movies complete in HD 720p !!!

    I hope it works for you to.


    Lets wait apple launch a definitive solution.

  • HamishC Level 1 Level 1

    I am also having the same problem.  I have tried all previous fixes but so far no luck.  I want to try the houdini suggestion from roberson antequera.


    Can you be more specific which quicktime files you are deleting, is there a file extension I can search for and then delete all files.

  • roberson antequera Level 1 Level 1

    It only worked one time.  didn't take note the name of the files but there were 3 QT hidden files with 5,6 GB each. When I erased them i could export a project in HD two time and them teh problem started again. I believe thas because the space in HD became bigger for a short time...

    Now I am stuck again with error -49.

  • BBeu Level 1 Level 1

    If you are using Lion try to disable Mobile Backup with


    sudo tmutil disablelocal


    This will remove the local backup in /.MobileBackups.

Previous 1 2 Next