Previous 1 9 10 11 12 13 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • iccaprar Level 1 (0 points)

    I had the same problem: Win7 x64, PhotoStream working fine for months, but for a few days, it stopped downloading new photos.


    I uninstalled it, rebooted, downloaded the installer from Apple's site and reinstalled. All working perfectly.


    Just a mention: I selected a new folder (still under My Pictures in Home) for PhotoStream. But I checked the file and folder permissions in the new folder (working) and the old one (not working) and they are identical, and inherited from My Pictures, the parent folder, so it does not seem to be a permission issue.

  • vee528 Level 1 (0 points)
    1. Here's my solution and it is rather simple. I had the same photostream.exe  app crash after the recent icloud upgrade using Vista 32 bit.

    I opened the icloud control panel and clicked on icloud help( just above the close button).  (If you don't have the icon in the system tray you can go to START>CONTROL PANEL>ICLOUD.)  The help brings you to apples icloud help site. On the left click on photostream. In the sublist click on RESET YOUR PHOTOSTREAM. It will give you simple instructions on doing so. Here it is:

    1. click on
    2. sign in using your apple id.(the one you use for icloud)
    3. once signed in click on your account name at the top of the page
    4. click advanced
    5. click reset photo stream and reset
    6. click your apple id in the upper left corner to return to the previous screen
    7. then click done(upper right)

    Take note of the possible loss of sync'd photo's at the top. Read it and go for it. It worked for me. Let me know if it does for you.

  • Joe Siegler Level 1 (10 points)

    Reset your photostream did not work for me.  The only thing that worked was an uninstall of the control panel, and a reinstall.  I didn't lose any pictures.  In fact, the sync picked up stuff I missed.

  • EffEPi Level 1 (0 points)

    I tried everything, and I kept having the same issue.  What finally solved was uninstalling and reinstalling it

  • Joe Siegler Level 1 (10 points)

    To make this all fun..  I uninstalled and reinstalled, and it got things going again.


    However, it stopped working again after a couple of days.  Gotta LOVE THAT. 

  • mr-nik Level 1 (0 points)

    so, i've read this whole thread, torn most of my hair out, and concluded I must uninstall/re-install.


    (I have the problem where it's been working fine, then just stopped.. seem to co-incide with me almost running out of space on my "backup" part of icloud)


    Annoyingly I did a reset on photostream and it didn't fix anything.. so now I have pics I can't get down onto my PC via photostream...

    hhhhanyway, i noticed in windows control panel uninstaller, there is an option for "change" - I clicked that and for icloud panel there is an uninstall and a repair option.


    I chose repair. Some stuff happened. Then I noticed that ApplePhotoStreams.exe was running where previously it wasn't (and was crashing if I ran it). lo and behold, did a screen shot on the ipad as a test, appeared on PC..


      not sure upload is working, not sure i care...


  • zak_pl Level 1 (0 points)

    I turned off google chrome (strangely, one google chrome window took multiple "tasks" in task manager). And it started to sync immediately!



    Maybe photostram is very, let's say, modest, and is waiting till every other program ends using the communication protocols?


    Hope this will help anybody:)

  • Joe Siegler Level 1 (10 points)

    Tried the "Don't run Chrome" and "Use Repair" options listed above.  Neither worked.


    So far, the only thing that works for me is an uninstall, a reboot, and a re-install.  Even then, it only seems to work for a few days. 

  • lowiss66 Level 1 (0 points)

    Help have tried everthing in this post unintalled /redownloaded etc. still photostream does not sync photos with my pc.??

  • USNZer Level 1 (0 points)

    I have read through all of this and tried all of this! but still no photos streamed from my PC to iPad. I know it is working as it is going to streaming folder and when decided to allow them onto my iPhone they were streamed there. However, they just won't go to my iPad. Have you had a solution from Apple as yet? It is really frustrating as it is one of the main reasons I got the iPad.

  • AppleForumAlias Level 1 (5 points)

    Well, I did not tried that, but what helped me was:

    1. Open Task Manager
    2. Kill ApplePhotoStreams.exe and iCloudServices.exe
    3. Restart iCloud services with opening the iClous control panel (search for iCloud in the System Settings / Control Panel of Windows)

    Suddenly, a new process ApplePhotoStreamsDownloader.exe startet, and all photos have been synced to my folder.


  • OKADA Tsuneo Level 1 (0 points)

    Your answer solved my same problem.

    Thank you!!

  • Joe Siegler Level 1 (10 points)

    OKADA Tsuneo, whose solution are you talking about? 

  • dchbbc Level 1 (0 points)

    This might be old news and not work for everyone, but after several sleepless nights thinking about this and reading what ihelpuserid said (after I did this!) here's what worked for me...

    I signed out of icloud. Moved my Photostream folder to C/Users/Public....Set the folder to share with EVERYONE...Set Security to EVERYONE and AUTHENTICATED USERS....Changed the subfolder My Photostream to Downloads.....Resigned back into icloud....changed the file locations to the new folders in PUBLIC.....Took a picture with my phone and it went to my ipad and to the folder on my PC.....The Uploads folder had all of the pictures I stored in it from my ipad and phone and they wouldn't go to the ipad or phone, so I copied them to a temp folder on my desktop, deleted them out of the uploads folder and repasted them back to the uploads folder. The started going to my phone and ipad in seconds.

    I don't know how much of that had to be done or if any of it had to be done but after several days of reading page after page and trying things, I tried everything and it worked...

    Oh, I also followed these security settings before I did anything (this didn't work on it's own but I did it anyway),


    I hope this helps, and a good question is, why doesn't Apple tell you some of this stuff and why don't you ever see Apple weigh in on this? Maybe thay have but I can't find it.

  • vee528 Level 1 (0 points)

    I think my solution is more for Windows Vista 32.  I have not had a problem since my last post.


Previous 1 9 10 11 12 13 Next