Previous 1 4 5 6 7 8 Next 397 Replies Latest reply: Jul 21, 2015 5:31 AM by Symbiatch Go to original post
  • WaterOz Level 1 (10 points)

    Wish I could say it worked for me... but it didn't.  Thanks for a new suggestion though!

  • cdn-tallguy Level 1 (0 points)

    I admire you WaterOz, I've long given up on iCloud, turned everything off even the wireless sync,

    didn't work reliably, sometimes it did, sometimes couldn't find the iPad...

  • Rndmzr Level 1 (0 points)

    Photostream isn't working for me again, so my initial skepticism on the "solution" I found (that my software firewall was the issue) was well founded.

  • FTutone Level 1 (0 points)

    So, I had a similar problem. Photo Stream initially worked for me with no problem. Then it stoped working. The only think that happened between the the two was a re-boot of the desktop system. I am running Win 7 on a 32-bit machine with bitdefender as my firewall and antivirus.

    Althongh all the folders were created correctly when I sent up the icloud sync, I found that the Photo Stream and the My Photo Stream folders were no longer being shared after the reboot. Once I shared BOTH of them again, everything worked as advertised. I have not re-booted the desktop since I did this but when I do, I will check to see if the folders are still being shared.

    I am NOT on a domain but using a workgrup and also have Homegroup enabled.

    I hope this helps.

  • andy216 Level 1 (0 points)

    What partially worked for me was changing the 'Compatibility mode'  on C:\Program Files (x86)\Common Files\Apple\Internet Services\ApplePhotoStreamsDownloader.exe (right click the file and choose the Compatibility tab). I tried every mode and the ones that bizarrely worked were 'Windows 95' and 'Windows 98'. I also have Run this program as an administrator ticked as well, but not sure if that is required. When I then launched the program manually it created the My Photo Stream and downloaded away and no longer consumed 100% CPU.


    However, it only worked if I ran the program manually and presumably ApplePhotoStreams.exe or iCloud.exe was now struggling to launch the ApplePhotoStreamsDownloader.exe now I had changed the Compatibility mode. So I then changed both those programs mode so they both have Run this program as an administrator ticked. However, evertime I reboot my machine I have to open the iCloud control panel (which gives me the security warning now it runs as an administrator) and only then does everything seems ok. It is all very messy, but at least I can actually get my photos downloaded. For the record my wife's 32 bit Windows 7 machine has no problems PhotoStream just my 64 bit system.

  • Repp1 Level 1 (0 points)

    I'm having exactly the same problem.  I've gone through all six pages of discussion and tried most of the suggested fixes.  Nothing has worked.  When I originally installed iCloud control panel the photos from my iPhone were downloading to my PC. I don't know what it was that made it stop working, but I sure hope Apple comes up with a solution.  Still works fine on my iPad.   (I know the problem is not related to the router, because even when I connect my iPhone to the compter via USB, it still won't download the photos from the iPhone to the PC.)

  • HowardFromNorthVancouver Level 1 (0 points)

    The Photo Stream download to my 32-bit Windows 7 PC now seems to be working .  I never had an issue uploading. 


    Yeserday I changed "C:\Program Files\Common Files\Apple\Internet Services\ApplePhotoStreamsDownloader.exe" to XP SP3 compatibility mode then killed this process, which was running at 100% of one of my CPU cores.  I also configured iCloud to download to a new "download" sub-folder of the default Photo Stream folder. 


    It isn't clear to me whether all of these actions were necessary to solve the problem but when I took a new photo this morning and checked the download folder a few hours later, there it was!  Also, Downloader.exe is not running continuously as before - it seems to be a client application called by ApplePhotoStreams.exe only when there is something new to download.

  • Elessar77 Level 1 (0 points)

    Hi all.

    With windows 7 it could help running the ApplePhotoStreamsDownloader.exe as administrator (right click on the file within "C:\Program Files\Common Files\Apple\Internet Services" and select the "run as administrator" option).

    It worked with me.


    Hope it helps.



  • Dr_Hibbert Level 1 (0 points)



    I had the issue of my photos were syncing to my pc but not to my iPhone. After hours of searching, installing, firewalling, I found the solution, which was mentioned here, was to create one upload and one download folder inside the main photoshare directory.


    I know it is probably a few different issues but this one worked for me.

    Good luck!

  • osaebousa Level 1 (0 points)

    Have the same problem. Just wondering if there is a limit in iCloud. I checked the properties for the PhotoStream folder in Windows - and it contains 2909 photos - and is exactly 5GB in size.


    Makes me think if there is a 5GB limit for PhotoStream after all - if you do not upgrade your iCloud storage.


    Anyone out there with more than 5GB of photos in their PhotoStream folder - and that has a original free 5GB iCloud account?





  • databong Level 1 (0 points)

    Thanks Water, for being so patient and persisent.  I'm with you on this.  Tried all the schemes mentioned in the 6 pages of suggestions (well, except for the "is the power switch on" variety ), and still nothing.  This is definitely a problem that is challenging for users to diagnose.  Hopefully Apple will figure it out. 


    If they can get iCloud reliable on Win, then they Win!

  • databong Level 1 (0 points)

    Water, question for you:  on the diff between the pooter that works and the one that doesn't:  is one connected to the Innernetz via cable and another via WiFi perhaps?  This just popped into my head a minute ago cause I remembered that iCloud streaming isn't active on i-devices unless they are WiFi connected.  I'm wondering if the Windows pooter that works is WiFi and the one that doesn't is cable connected?  I'm sure they aren't cause that would just be way too easy.

  • WaterOz Level 1 (10 points)

    Both have been connected the same way.



    I noticed Apple released a new version of the iCloud Control panel.  Did this fix the problems for anyone?  Mine still doesn't seem to be working... although maybe it's too soon to tell...

  • edfromminnetonka Level 1 (25 points)

    Tried it. Photostream still grayed out and not selectable on this Win7 x64 machine.

  • GaetanoFormato Level 1 (0 points)

    I had the same issue, i read all 6 pages and i didn't find the solution. Then i found this way, and it worked for me:


    - Open iCloud Panel and uncheck PhotoStream

    - Close any iCloud process and delete the Photostream Folder you used before

    - Open iCloud Panel and check photostream, click apply


    After that it worked for me, i copied a photo in the upload folder and i saw it magically appearing in the download folder and on the iPhone


    Excuse me for the English, i'm Italian


    EDIT: Let me know if it worked for you

Previous 1 4 5 6 7 8 Next