1 2 Previous Next 18 Replies Latest reply: May 27, 2012 11:25 AM by robinwarnocknfla
howwow Level 4 Level 4 (3,485 points)

Hello all.

 

Ever since I upgraded both my iPhone 4 and iPad 2 to iOS5, I notice a little "oddity".

 

Both devices tend to internittently, loose connection to my home AirPort wifi network.  I have to manually re-conect them by choosing my wireless network.

 

And it seems to be the same at work/office, both devices also tend to "forget" my office wireless setup.

 

Anyone experiencing the same "problem"?

 

Thanks and cheers


iMac 27", Mac OS X (10.7), iPhone 4 32Gb | iPad 2 64Gb 3G WiFi
  • 1. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    JayR3113 Level 1 Level 1 (0 points)

    My iPhone 4S constantly switches back and forth between WiFi and 3G.  Does anyone know why it would do this when my wireless router is only 15 feet away.  Why wouldn't it stay connected all the time.  I have no problems with the connection to my macbook.

  • 2. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    howwow Level 4 Level 4 (3,485 points)

    Hi.

     

    Thanks for posting.

     

    Like you, I have no idea why it is like this.  Both my iPad and iPhone 4 (iOS5) are showing the same problem of "drifting between 3G and WiFi".  And my AirPort Base Station is also less than 3 meters away, together with me in my room!

     

    I "suspect" it is the iOS thing.

     

    Even in the office, my wireless router sits on top of my MacPro tower, besides me, and the same thing, switching between 3G and wifi.

     

    I think an update is necessary.

  • 3. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    Wynndel Stanton Level 1 Level 1 (5 points)

    Both iPad 2 and iPhone 4s running iOS5 wifi issues here as well. I have 3g but I want it to work!!!

  • 4. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    Dave Miller Level 1 Level 1 (85 points)

    iPhone 4 bought 2 weeks ago. Verizon is the carrier. Updated to iOS5 last night. Haven't been able to maintain a steady WiFi connection at home since. Tried resetting the iPhone network settings. Started broadcasting my wireless SSID. Reduced wireless security from WPA2 to WPA. Pretty much rendered my iPhone useless on WiFi. WiFi Connection drops too often to be useful. Remote App has been rendered useless. G3 speeds don't always cut it. This is driving me insane!

     

    This has to be bug. No?

     

    The Wireless Router is a Linksys WRT300N V1. The firmware is no longer upgradable. Wondering if there is an incompatibility issue with the earlier wireless n spec?

  • 5. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    howwow Level 4 Level 4 (3,485 points)

    Hi all.

     

    I really think it is an iOS5 problem.  iPad 2 before iOS5 upgrade has no problem keeping log into home wifi network and office wifi network.

     

    Same with iPhone 4. Just got a new iPhone 4S.

     

    And both devices the same, drifting in and out of wifi.  So this cannot be the iPhone 4S' problem as it is new, presumably the device is not faulty.

     

    Hopefully for a updated fix soon

     

    Cheers

  • 6. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    odysseus Level 3 Level 3 (910 points)

    I just acquired an iPhone 4 from my brother. Its Wifi connectivity seemed fine until I took it to an Apple Store today for home button and camera issues, where it was actually repaired instead of exchanged for a refurbished model. Is it possible that the "genius" could have impaired the Wifi reception by damaging a connection to an antenna, for example?

  • 7. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    DennyR Level 1 Level 1 (0 points)

    I am having the same trouble as everyone else is describing here. I have an iPhone 4 with iOS 5. So far I have not found any answers here or elsewhere on the interwebs on how to fix it.

     

    Until today, my wireless router (D-Link DIR-615) was set to WEP security, but after iOS5, the phone would not maintain a wi-fi connection for longer than a minute. So searching around today, I found advice to make sure my router's firmware is up to date and use WPA instead of WEP. So, I did both of those things, and am now having the problem everyone is talking about here.

     

    Are we just waiting for an iOS update from Apple? I hope not. I have the 200 MB data plan, and that is perfect for me as long as Wi-Fi works the way it is supposed to. But if this keeps going the way it is, conspiracy theories of trying to get more $ out of users will abound.

  • 8. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    a.zimmer Level 1 Level 1 (0 points)

    This ***** and very annoying!! One minute I'm on wifi, next I'm on 3G, have to go to settings then select my wifi, time and times again! Come on! Fix this! I'm in the middle of a game here.

  • 9. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    tosc Level 1 Level 1 (0 points)

    I experience exactly the same. The Iphone automatically connects to my home wifi for a few seconds, then switch to the 3G. If I try to reconnect, it won´t find my network. If I use WIFI finder or anything like that, my iPhone 4 does not find a singel WIFI network nearby.

    As I can see from the discussions, the first message about this problem was posted 17th October, and Apple has not replied yet. This is so arrogant and costs me a lot of money using my 3G at home.

     

    Looking forward to an urgent solution !

  • 10. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    DennyR Level 1 Level 1 (0 points)

    I've found a temporary solution until they fix the problem. Use WEP 128 bit. It's not as secure as WPA but better than nothing, and the problem goes away.

  • 11. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    Fred Thorne Level 1 Level 1 (0 points)

    I'm having similar issues with my Airport Extreme and iPhone 4.  Everything was working fine until I noticed I no longer access my WiFi at home on the phone, and can only get data through the 3G network.  My iPad 2 and iMac access the router just fine.  Phone calls are fine.  (Well, as fine as they can be on AT&T who refuses to install a decent tower near my home and who I finally got to give me a Microcell which works often but not reliably enough especially when I'm really close to it which I don't understand.  (Sigh.)  Sorry.  Got carried away there on an AT&T rant.)

     

    I too suspect it is iOS 5, though I cannot fathom why it hasn't surfaced as an issue until now.  I will have to try the phone out at Starbucks (where they offer free WiFi) and see if it's the iPhone.  Perhaps it's an iOS 5 incompatability issue with AirPort?  Perhaps AirPort needs a firmware upgrade for compatability with iOS 5?  Though other users seem to have issues with their non-Apple WiFi routers, and that doesn't explain why my iPad 2 is able to access AirPort.  I chucked my Belkin router and shelled out the $$$ for AirPort extreme because my Apple TV refused to work with the Belkin router, but which was admittedly starting to get a little long in the tooth.

     

    Has anyone with these issues been able to successfully access WiFi at a location other than at home with their AirPort extreme?  That might help isolate where the problem is.  Is anyone with these issues at a Starbucks now that can repond whether they have WiFi access there?

  • 12. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    Fred Thorne Level 1 Level 1 (0 points)

    All righty - Here is my solution that I found worked for me.  For history, please see my post of 11:42 am this morning.

     

    I did visit a Starbucks this afternoon and determined I was experiencing the same difficulties with their free AT&T WiFi that I experienced at home with my AirPort Extreme.  That suggested to me a problem with the iPhone, nothing else.

     

    So back home I went in my iPhone's "Settings," chose "General," scrolled down and chose "Reset," then selected "Reset Network Settings."  I entered my passcode and confirmed I wish to Reset Network Settings.  The iPhone screen went blank, the modern Apple icon appeared in the middle of a black screen, and a few minutes later my phone desktop re-appeared.  To my surprise, it promptly reconnected to my service provider's phone network (AT&T).  I then went in to "Settings," chose "WiFi," selected my personal home network, and entered its password.

     

    Voila!  I'm back in business.  I don't know why it worked, but it certainly cleared my iPhone of all previous WiFi settings.  That seemed to solve the problem.

  • 13. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    AlienMike Level 1 Level 1 (0 points)

    My 1 month old IPAD 2 (Christmas for my wife & I) Wifi worked fine before I had to go out of town just after upgrading to 5.  Bought a Verizon MiFi 4G LTE wifi hot spot while out of town, really nice with really great data rates. 

     

    Then I came home to the apartment.  Ipad worked fine last night, while updating my magazines, surfing, reading and playing some games.  But this morning WiFi is in and out like a yo-yo.  I have 10-30 second cycle on ALL Wifi transmitters I have access to in the building.  I cannot get one to lock on but for very short periods if at all.  (Wife is not going to like this when she gets home.)

     

    Have even reset all my wifi settings on my router and my MiFi.  Cannot even link into an unsecured Linksys someone has in the building.  Unsat being tethered to my computer or diddling on my smartphone.

     

    Believe this is a software/antenna coordinatation issue.  The selectivity between the signals (b/g/n & unsecured) is not being bracketed and locked onto.

     

    APPLE:  Listen, this is NOT a router problem folks, although, as suggested in other posts, you might want to isolate to g or n to make the signal easier to lock on.  The WEP/WPA could be a problem with the selectivity being toughter when you use the higher encryption (WPA/WPA2).  One post who was desperate shifted to WEP (128-Bit) encryption.

     

    Apple really should hire some decent antenna engineers, then match them up with the software folks.  This really should NOT be happening.  My unit has not been dropped or mishandled in any way, although it should be mildly ruggedized if United Air Line pilots are using them for enroute charts.

     

    Will go to a WiFi isolated area where I can try my MiFi 4G wifi hotspot in an uncluttered EM environment and post my findings.  If this is not a structural problem, my guess is it will work.

     

    Steve J.  would not be happy with the Apple Wifi H/W-S/W coordination.  Let's get this issue resovled.

  • 14. Re: Is it just me or my iOS5-updated devices tend to "forget" my wifi?
    JayT1973 Level 1 Level 1 (0 points)

    First of all my iphone 4 would not connect to home wifi, but ipad2 was fine.  I tried going into Settings, selected my home network, selected static  and input the same settings from my ipad into my iphones IP address, Subnet Mask, Router & DNS. This didnt work, but I messed about a bit and hey presto my iphone was picking up my home wifi.  My joy didnt last long as my ipad2 has now lost the home wifi connection.  I reset my original network settings on my ipad, but the only thing this has changed is that I now get the 3 bar signal in to top left hand corner to show I have a wifi connection, but each time i try to connect i get the ''No internet connection'' error message.  My lap top still works fine, but this is just a Samsung model.  Frustratred is not the word as I love my ipad, but am totally limited to what I can use on it at the moment!!!!!

1 2 Previous Next