Previous 1 2 3 4 5 Next 321 Replies Latest reply: Nov 20, 2012 7:04 PM by Dwags22 Go to original post
  • gaen Level 1 Level 1

    I found a following solution which worked for me after playing a bit around here with my devices:

    I checked out my (Netgear MBR624GU) routers settings and found it's a "b/g-Mode" only model!

    Firmware upgrade on the router didn't solve anything, so I switched off wifi on my MacBook

    and connected it with an ethernet cable to the router, restarted the router, the MacBook and the ATV. 

    My iPhone 4 on iOS5 got no reboot.

    After that, I found the problem solved....

    When switching back my MacBook (late 2008 on Lion 10.7.2) to WIFI (b/g) for testing, the troubles came back.

    So i decided to think, as I could not solve a b/g/n mode (software ?) problem on my Devices,

    to swap my router for a newer N-mode supported model (Netgear MBRN3000), which also brings

    more security (and speed) to my network. I adjusted the new Router to "N-mode" only.

    Now, the ATV, MB and IPhone 4 work smoothly together in Wifi-N-mode.

  • Jim Bob, Wasilla Level 1 Level 1

    Well done Gaen for finding a solution to your problem.


    Unfortunately I have always had my AE and iPhone 4S setup for 802.11N 2.4 GHz and have the connection problem so Apple need to get it fixed soon.

  • aschmere Level 1 Level 1

    I may have found a solution/workaround for the airplay problem occuring in conjunction with the iPhone 4S. I tested it with my B&W Zeppelin. So far I had the issue described here, that after a few minutes of airplay playback the Zeppelin used to crash and even had to be rebooted. In my environment this reproducibly occured after 2-3 minutes airplay playback at maximum. When I deactivate the option "Cellular data" under "Settings" -> "General" --> "Network" - which does not limit the functionality at all while being at home joined to my home WLAN - the issue does not seem to occur anymore! Final tests still have to verify this workaround, but I am pretty sure meanwhile, that this is a valid workaround. The idea came to my mind during watching reviews in the App Store concerning the "Samsung remote" app, which in conjunction with an iPhone 4S crashes immediately after starting the app. In one recent review it was mentioned that deactivating "cellular data" resolves the problem, which is true for the "Samsung Remote" App - and it seems to be also true for the Airplay playback. Maybe both issues with both apps are interrelated.

  • aschmere Level 1 Level 1

    Correction: Further tests have shown, that in my environment deactivating "cellular data" leads only to an increase of the interval between the crashes from about 1-2 minutes to approximately 10 minutes, so this procedure might improve the situation, but it does not solve it at all.

  • Jim Bob, Wasilla Level 1 Level 1

    That's a shame. For me I had Cellular data turned off anyway so it wouldn't have made any difference.


    Get on with it Apple...the only two Apple producs I've ever bought at an embarassing $1100 AUD+ don't work properly !!!

  • _Otacon_ Level 1 Level 1

    I have two iPhone 4S.  The white one crashed my wifi (AP Extreme rebooted) every time after 1-2 min AirPlay streaming; but, the black one works perfectly well with AirPlay.  All configurations are exactly same in two iPhones.  Finally, I decided to reboot the white one.... voila.... problem solved.   I guess this might be a bug in iOS.

  • CD3660 Level 1 Level 1

    Come on Apple, this is totally unacceptable. The fault is clearly with the iPhone 4S and needs to be sorted, YESTERDAY!

  • pig30n Level 1 Level 1

    Got the same issue !


    I thought I had a faulty 4S until I saw this thread ...


    The airplay from iPhone 4S music player sometimes drops the whole network, sometimes gets the Zeppelin into "Limbo Mode" that needs complete restart.


    I experince this drop everywhere between 30 sec - 1 hour of airplay.


    I tried resetting then reinstalling each one of them (iOS 5, BW ZeppelinAir and TimeCapsule).

    Nothing helped.


    Airplay from my MacBook does not stop even after 10 continuous hours.

    Airplay from an iPhone 4 works until the battery finishes.


    I looked into my ruter logs and I think airplay drops exactly when it rotates the TKIP group key for the WPA security.

    My guessing is that there is a bug in the iPhone 4S WiFi software driver.

    This could explain why it drops the whole network.


    iPhone 4S has a new WiFi network card that supports wireless-n over 2.4 Ghz (65 Mbps).

    iPhone 4 has only wireless-g (54 Mbps). So the new WiFi software might have problems.


    I might be wrong on this .... but I'm sure there's nothing wrong with the Zeppelin or TimeCapsule.


    Cheers !



    Equipment I used to test this:


    Time Capsule 3rd Gen

    B&W Zeppelin Air

    iPhone 4S 64GB Black

    iPhone 4 16GB Black

    MacBook Pro Early 2011

  • scottwy Level 1 Level 1

    this is the best investigated scenario.  i wish there was a way to ensure that apple reads this breakdown of the issue.  my experience is identical to yours.  thank you for being so precise and looking into the router logs.  i've been meaing to do the same thing but...anyway thanks.

  • tjhenn Level 1 Level 1

    Similar scenario as most others.

    4s drops it's wi-fi connection about 15-30 seconds into using AirPlay with my Apple TV 2.  The Apple TV is hardwired to the router.  This occurs whether I'm trying to play music, videos or mirror to the Apple TV.  When the 4s drops its connection, it will not connect to the wi-fi network again for several minutes.  The Apple TV is on the latest iOS version.


    Had a 3GS and it had no issues streaming music to the Apple TV.  It was using iOS 5.  My wife's iPhone 4 also using iOS 5 has no issues with AirPlay.  There is something about the 4s that is causing the issue.  Not sure if its hardware related because it has streamed several hours of Netflix over wi-fi without ever dropping the connection.  The issue only occurs using AirPlay. 


    I believe Pig30n's theory is correct, related to TKIP security.  I disabled wireless security temporarily on my router and AirPlay worked as expected for 10-15 minutes.  No network disconnects.  Now we just have to hope for an iOS update that can fix the issue because I don't want to leave network open.  Last time I did that the neighbors used 20GB of my 200GB monthly cap.

  • Tillone Level 1 Level 1

    Same problem here with iPhone 4S and Zeppelin Air.

    The airplay connection runs for exactly 10 sec and then drops.

    I have to reset the Zep Air to work again with the other devices (iPad2 - iPhone4)

    I hope a fix soon.

    Thank you.

  • andychap Level 1 Level 1

    Have just purchased an Iw1 Home Airplay speaker and I am having problems with dropouts after a few seconds when using my iphone 4s. The speaker works fine over Airplay with an iphone 3gs, Ipad 2 and imac 27".

    I also have an Apple TV 2 hard wired to my router and the airplay to this works flawlessly with all devices including the iphone 4s. Confused as to why the iphone 4s will work with the Apple TV but not with the I W1. Any suggestions would be appreciated.

  • S Spence Level 1 Level 1

    Count me in. I'm having the same problem. New iPhone 4S crashes both my airport extreme and my airport express when I use AirTunes.


    Hope this will be addressed!

  • tbertran Level 1 Level 1


  • iphone4sproblem Level 1 Level 1

    I called the apple support and they sent me a new 4S to replace my old 4S (10 days old) one. Still having the same problems as all of you!!

    And: This problem is not only related to US iphone 4S! I'm living in germany.

    I called the support again but they can't help. The offered me to send me another new phone.....

    This is the worst cell phone purchase I ever made (an not my first iphone). Do something apple!!!

Previous 1 2 3 4 5 Next