4 Replies Latest reply: Nov 14, 2011 5:19 AM by fikovnik
rob_west Level 1 Level 1 (0 points)

During the iOS 5 / iPhone 4S launch, while waiting for my 3GS to be able to upgrade, I simultaneously upgraded my MacBook Pro from 10.7.1 to 10.7.2. As soon as I did so, I could no longer access SSL-specified URLs in any browser. Specifically, and most annoyingly, the login page for my work's guest wireless system. HTTP sites work, HTTPS sites do not, in other words. I should mention that 10.7.1 did not give me this behavior.

 

I tried a number of things: clearing out Safari preferences, network preferences, etc. and finally tracked it down to what seems to be a certificate issue. I am guessing this, because I cannot launch Keychain Access. It kicks off, and builds the menus, but then goes into a rainbow wheel and becomes unresponsive.

 

After a flurry of things I tried, including dumping my personal keychains (~/Library/Keychains) and system keychains (/Library/Keychains), resetting PRAM (don't know why that would work, but it's always suggested), removing WiFi from the connection methods under a new location in the Network preferences pane, re-establishing permissions on keychains (chmod 755) and changing ownership (chown -R), etc. I got it to work. And it worked for the entire day while I was at my job.

 

After returning home, working there for awhile on my WiFi there, and then coming back to work the next day - same problem. But the sequence of things I tried didn't work this time. So, I tried a bunch of other things, including the things I did the first time and got it to work a second time. There didn't seem to be a magic bullet - it always seemed like "Ah ha! That's the thing I need to do" and then after another cycle of going home and then coming back to work, that one thing had no effect and it was back to randomly shotgunning diagnostics and troubleshooting methods, including:

 

* Running Disk Utility from Recovery mode

* Installing a fresh copy of Lion from Recovery mode

 

I've watched the console, and to be honest, I may be missing something, but I can't seem to pin it down.

 

The main symptoms, in summary are:

* Wake computer from sleep, and my MBP connects to my guest wireless at work

* Safari cannot launch - it goes unresponsive after the icon bounces for a minute

* Chrome launches, but when trying to access SSL sites (primarily the wireless login page) it gives an ERR 7: timeout.

* If I change the https: for the login page to http: - suddenly I'm allowed to logon and get internet access. But still no SSL pages.

* Attempting to launch Keychain Access bounces the icon, the menus build, and then the program becomes unresponsive.

 

Has anyone seen this behavior before? I've done a lot of searching on this, and it would seem that another group of folks have a similar issue here:

http://forums.techarena.in/operating-systems/1435689.htm

 

Searching for "Keychain Access Not responding" and similar terms brings up some helpful stuff, but nothing that solves the problem.

 

Thanks in advance for any help!


MacBook Pro, Mac OS X (10.7.2)