Previous 1 2 3 Next 42 Replies Latest reply: Jun 27, 2014 7:33 PM by JaMRaG Branched to a new discussion.
Paul Spurling Level 1 Level 1 (5 points)

My new iPhone connects to the wifi at work without any problems. At home, though I have tried many times and can't get connected.  My home wireless router is a Linksys E2000. My MacBook Pro connects to both work and home wifi without a problem. So, I know the iPhone's wifi unit isn't dead and I know my home wifi isn't dead.

 

The iPhone sees my home network, and allows me to enter a password to connect. Then the status indicator by the network name just spins until the phone goes into power-save mode.

 

Things I have tried:

- reset iPhone network settings

- toggled iPhone WiFi on and off after changing router settings

- set router to channel 9

- changed router to channel "auto"

- set router to channel 11

- eliminated wireless security login requirement on router

- set router to N only

- set router to Mixed network mode

- set router channel width to 20MHz

- set router channel width to Auto 20/40MHz

- made sure router is not using MAC address filtering

 

 

Related topics I have read:

https://discussions.apple.com/message/16490677

https://discussions.apple.com/message/16502121

 

Message was edited by: Paul Spurling - fixed title

  • Paul Spurling Level 1 Level 1 (5 points)

    Update: Got it working. Maybe because my wireless router is acting as just a WAP instead of a router, I had to use a static setup on the iPhone.  Once I assigned it a static IP and told it the IP of the LAN router, all is well.

     

    If there is a better solution I'd like to hear it, but at least I can utilize my system now.

  • succeed Level 1 Level 1 (25 points)

    hey, good to hear you got it working.

     

    it sounds like your router might have a dhcp issue. try to go back to automatic ip address, but reboot your router before you try to connect

     

    also it might be worth checking to see if there is a firmware update for the e2000. i've had similar problems in the past and a firmware update cleared up my issue

  • moosquare Level 1 Level 1 (0 points)

    Hey, I'm having the exact problem! All my previous iphones worked perfectly with the home wifi, but not the 4S which I just got today. I can connect the 4S with a neighbour's wifi, but not my home wifi. The status indicator just keep spinning.

     

    Can you tell me what you did to make it work?

     

    Thank you!!

  • Paul Spurling Level 1 Level 1 (5 points)

    I went to settings > Wifi and selected my network. Then I chose Static from the 3 IP address options. I chose an IP that I knew was unused on my network and entered it, my subnet mask, router and DNS.

     

    I have not had time to try succeed's suggestion re: DHCP and firmware

  • Theapplefanboy Level 1 Level 1 (0 points)

    I can't get mine to work either, except I followed everything all of you said in your entries and next to the Wifi name on the iPhone it gives a check and says your connected but it doesn't indicate it in the status bar it just says 3g.

  • Edifier16 Level 1 Level 1 (0 points)

    Hi! When you wrote router, your referring to the IP address e.g. 192.168.0.1?  Where do you find the DNS?  Sorry, I'm not to familiar with these.

  • RDPphoto74 Level 1 Level 1 (0 points)

    You need to restore your Network Settings.

     

    No need to mess around with your router!

     

     

     

     

    Settings > General > Reset > Reset Network Settings....   Ta-Da!

  • Marlow Level 1 Level 1 (10 points)

    Brilliant...Simple......fixed it in 30 secs after a day of nothing working!! Thank you

  • hedkandi Level 1 Level 1 (0 points)

    Hi, i have tried this and when i enter my router name and password it just had a connecting ring going round on the side of my router name. it wont connect, the only thing i have done with my router is placed it in a different room to gain better signal, which is working but for some reason it wont connect it just has this connecting ring trying to connect

  • LMST Level 1 Level 1 (0 points)

    Make sure that your router and modem are as far apart as possible.  I had this problem today, and I had just moved my router about a foot closer to my modem, and I suddenly lost Wi-Fi on my iPhone, but not on my computers.  When I moved my router back to its original spot, which is about 4 feet from my modem, the problem disappeared, and my iPhone recognized my Wi-Fi again.

  • amy_dean Level 1 Level 1 (0 points)

    I'm electronically challenged, so maybe this seems elementary to someone else, but it wasn't to me.  I couldn't get my I-phone 4S to hook up to the home WIFI, either.  It hooked up elsewhere okay.  But what I found is that when it asked for the "password", it wasn't the password it was asking for---it was the WEP key.  I found the WEP key on my home wifi's administrator's page.  Hooking up to my wifi at work also required the WEP key, NOT the password that the communications company gave us when they set it up.

  • kenmedford Level 1 Level 1 (0 points)

    Thank you! I was submitting the incorrect "password" as well and kept getting rejected until I tried the WEP key.

  • sweetness91 Level 1 Level 1 (0 points)

    I was also having this exact same problem. I knew it was this iPhone in particular because this is my second 4s (the first had a defect and I had it replaced literally two days after I got it).  My first phone connected fine and we have four laptops, two desktops and two iPods that work just fine on the wifi, so like I said: knew it was the phone. It was wierd because, though, because the phone would connect to wifi networks in public places (libraries, hotels, restaraunts, etc).

     

    Don't ask me why, but all i reset my network ( as RDPphoto74 suggested ) and tried to connect. Didn't work. Then I turned off the "ask to join networks" feature and then tried again to connect again it connected within a second. Don't know why that made the differece, but it worked for me, so maybe it will also work for someone else having this same problem.  Hope it helps

Previous 1 2 3 Next