Previous 1 2 3 Next 86 Replies Latest reply: Feb 3, 2015 9:32 AM by bluelotus1618
knotwrite Level 1 Level 1

Trying to get Windows 7 up and running on my 2010 MBP. After downloading the Windows 7 .iso and inserting my 4 GB flash drive (which should be large enough), I open up Boot Camp only to see that the option for "Create a Windows 7 Install Disk" is grayed out.


I don't have any DVDs on me, and I don't really feel like wasting gas going out and buying a pack of them just for this while I have a perfectly functional USB flash drive on hand.

MacBook Pro, Mac OS X (10.7.2)
  • Csound1 Level 8 Level 8

    Have you downloaded the Windows Support Software (the precursor to making the disk?)

  • kermit4161 Level 1 Level 1

    I am having the same issue with a Windows 7 installation with Boodcamp. Since the 10.7.2 update, the BCA has changed, combining the partitioning and installation into one step. It won't recognize my ISO disk as a valid installer disk, so Applecare Support recommended creating a Flashdrive install disk... but that option is greyed out. I have found no way to get access to that option.


    My opinion is they broke the BCA trying to make it more user friendly. It worked fine for me in the initial 10.7 build and in 10.7.1. Now it is basically unusable (for me).


    If anyone knows how to get this opened up, I'd really appreciate it.





  • kermit4161 Level 1 Level 1

    Just an update from Apple Support... it'll depend on the model of computer you have whether or not the USB Flashdrive boot option will be available. If the computer doesn't support booting from a USB drive, then the option wont be available. The tech helping me out is going to get me a list of computers supported. I'm not sure this is the whole answer though as the laptop I'm working on is a brand new MBP.. so we'll see. I'll post the list when I get it.

  • kermit4161 Level 1 Level 1

    The official word from Apple is the create a bootable USB flash drive option is only available for the MacBook Air (since it doesn't have a DVD drive).

  • Fortuny Level 7 Level 7

    And the 2011 Mac Mini... for the same reason.



  • Charles Smith16 Level 1 Level 1

    So then if I have a MBP circa 2009 how can I install Win 7? I have a Win 7 Pro .iso on dvd and on the desktop but it just won't go not matter what I do. Any suggestions? I had already installed Win & previous to iOS5 update but obviously now it's broken

  • Fortuny Level 7 Level 7

    Burn a DVD of the ISO.


    Use Disk Utility to do it and lower the burn-speed to 2x just in case.



  • kermit4161 Level 1 Level 1

    Yep, that's how I finally got mine to work. The ISO image that worked on 10.7 for 2 iMac Bootcamp installs wouldn't work for 10.7.2. I finally had to go to a PC and burn a new ISO image and got it working. The new Bootcamp Assistant is really picky for whatever reason.



  • Missinmedia Level 1 Level 1

    I have a iMac 2.8 Ghz Intel Core 2 Duo with Mac OS X Version 10.6.8.


    I also have a USB drive formated as Master Boot Record in MS-DOS (FAT) format. The USB has a capacity of 4GB+ and for now only includes a file named 'unattend.xml'  and a folder named 'drivers'. I created this USB drive when advised by a Boot Camp support site, because the Windows 7 install created a blank screen with a small flashing line on the upper-left of the screen.


    The I have burned an ISO file of Windows 7 Pro English 32 bit from the Microsoft site (I'm Gold partner).


    So I started of by clicking on the Boot Camp Assistant, tried to download the nesecarry Windows drivers, but it refused...  This seemed to be a normal problem which I could ignore (I heard). So I selected 'I have the Max OS X Installation Disc....'  and pressed continue.   I now prepared the size of the Windows environment and when that was finished, I inserted the burned DVD (which works perfectly fine on non-Apple computers).


    All this time, the USB drive was in the back of the iMac.

    I waited a while and the computer rebooted. A white screen appeared and after a while, the screen went to black, with the flashing little line on the upper-left of the screen...


    What is it that I do wrong?   Any help is really appreaciated.

  • xxcrashxx Level 1 Level 1

    I have figured out a way to enable this option.  This is only what worked in my instance.  I will try to do a quick tutorial here.

    Open Utilities(or where ever the boot camp is at.) Hold Ctrl key and click Boot camp, The second option on the pop up menu will be Show Package Contents. Click that, then open Contents folder, then open the info.plist file with the property viewer.  Scroll down to USBBootSupportedModels, open that listing and look at each item.  By default you should have:


    IM130, MM50, MP60, MB80, MBP90, MBA40


    Heres what I did.  I brought up my system information and looked for the Model Identifier, Mine is MacBook2,1.  Based off how the above numbers are based, I put 2 and 2 together.  I added a child string to the list in the info.plist file and typed in MB21(this will vary based on your Model Identifier).  I had to save the info.plist file to another location(apparently it wont let you save to the one in the .app).  I then renamed the original info.plist file in the Boot Camp Contents folder to info.plist.old(just to preserve the old file), then took the new edited file and dropped it into the Contents folder along with the info.plist.old file and everything else in there.  Once thats done, you just back out to the Utilities folder and open Boot Camp Assistant.  If everything went properly, you should have the option now checkable, if something went wrong, you probably didn't decipher the Model Identifier properly.


    I have not attempted an install just yet, I will be trying this in the next few hours.  For the record my Macbook is the black Macbook Mid 2007 model.  I will update this thread once I try this process and see if my macbook will boot off usb properly.

  • The hatter Level 9 Level 9

    Adding a device ID - of course!


    Use to be needed to add a patch to enable DVD burn support for any old-timers.


    Of course, WHY this is necessary, and why "lock out" some models etc.


    ... Good grief Charlie Brown (moment) hits head on desk

  • xxcrashxx Level 1 Level 1

    it appears that my model macbook does not support usb booting.  after changing over the files, it did error trying to copy over the windows files, not sure why.  after a reboot the process went through completely.  on the reboot i got the apple symbol, then it would flash between the apple symbol, the circle with the line, and the folder with the question mark and would continue until powering off.  but it did successfully create the usb drive.  im guessing they disable the setting for systems that dont support usb booting??

  • Charles Smith16 Level 1 Level 1

    what a kluge, i'm just not going to install windows on my mac and keep my PC dedicated to windows items, not in Jobs fashion they took a nice thing and screwed it up beyond belief

  • cfxram Level 1 Level 1

    Thank You for this post. My macbook pro 17 is reported as model MacBookPro8,3 so I added MBP83. That didn't seem to work. But I noticed the boot firmware was MBP81.... so I added that and it worked.

Previous 1 2 3 Next