Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Feb 3, 2015 9:32 AM by bluelotus1618 Go to original post
  • mparrish91 Level 1 (0 points)

    I changed the plist file and the create windows 7 install disk is now highlighted


    however when bootcamp begins installing it comes up with an error- while copying windows installation files

    and says bootable usb drive could not be created



    my bootrom version is


  • kmurrayk Level 1 (0 points)

    I'm having the exact same issue

  • kmurrayk Level 1 (0 points)

    Hello all, my superdrive is damaged so I'm in need of a solution to install win7


    Here's my system:


    24-inch Mid 2007

    Model Identifier:          iMac7,1

    Boot ROM Version:          IM71.007A.B03

    SMC Version (system):          1.21f4



    I've tried editing the Info.plist, the option becomes available to make a USB installation. Everything goes smooth then when I reboot to begin the installation I get apple symbol, then it would flash between the apple symbol, the circle with the line, and the folder with the question mark and I have to reboot.


    Has anyone installed via USB with the Boot ROM Version I have listed?

    My superdrive has been dead for years so this is usb is my only option


    I've also tried with the physical win7 DVD using an external USB Optical drive, but upon reboot I stare at blank white screen.


    Thanks to anyone who can offer more help!!!

  • tvjohn Level 1 (0 points)

    So is my drive.


    Thanks to the posters for the usb work arounds.


    My target mac is a macbook 3.1, about 5 years old.


    I have win 7 pro' on it now


    To cut a very long story short, I created a usb stick (actually a SD card, 4 Gigs, from my camera) using the prior post suggestions, eg., my parameters at start of arrays, but it all failed to boot, in spite of Sys Pref's suggesting I could boot from the win7 usb connected device.


    What I did:


    somehow make the Bootcamp partition NTFS fomatted, rather than FAT.


    I copied the usb stick's contents, ie. the win 7 ISO files to the now NTFS formatted bootcamp partition, via Tuxera. I used the evaluation version & I may buy it, as the licence seems fair. Ive already bought Paragon NTFS but that's on my mac mini (SL + win 7) & I suspect, unlike Tuxera, is licensed for only 1 machine. Obviously I could check, but life is so short.....


    I used the Terminal approach to enabling Refit. Just installing Refit didn't work.

    Restart macbook & select Refit's suggestion of "Partition 4" (20 Gig's).


    To my amazement, win booted, took a few min's to decompress its files, then flew through the rest as files were on HD rather than DVD.


    You end up with 2 boot choices in windows, ie. the original install option, or the now installed win 7, so presumably a "boot.ini" is created by windows.


    As I did this yesterday, there's a fair chance I may remember more before senility sets in, if you need more info' .......

  • alexnelson Level 1 (0 points)

    Hi all,


    I noticed a lot of people are having the same issue I am. That is, after succesfully editing the .plist file, we hit a wall when trying to actually boot from the USB. I gave up on booting from a USB and thought "maybe there's a way to do this through a virtual machine" and sure enough I found this: ve-with-virtualbox/


    I'm about to give it a go. I'll let you know how it turns out.

  • noision Level 1 (0 points)

    What a huge PIA! I am either about to try this or about to suck it up and replace my DVD drive into my MBP in order to load windows and then swap it out again (argh!) for the OWC data doubler harddrive enclosure. The less I mess around with small wires and screws the better, but this method, which as far as I know so far, seems the best bet is nearly as meticulous if not more.


    We need a patchstick solution!

  • alexnelson Level 1 (0 points)

    A pain indeed. However, I can confirm this worked perfectly for me. The instructions are very clear for the most part. It may be faster to pop your optical drive back in. I didn't have that luxury. Mine was busted.

  • Madarame79 Level 1 (0 points)

    rEFIt !!!! dbartul you're a genius!


    I'm stuck too with the" No bootable device--insert boot disk and press any key" and it's not possible because I installed Lion from that same 8Gb pen drive one month ago. I will try asap with rEFIt thanks!



    iMac 8,1 early 2008

    -info.plist corrected as described

    -strings in the first line otherwise with my configuration doesn't work

    -Boot Camp Assistant partitioned the usb pen with no problem

    -1 Error during the copy of the files to the usb pen. I restarted the process and the copy went fine

    -Stuck at reboot with "No bootable device" with a pen drive already use in the past on my iMac to boot Lion setup

  • Levi Figueira Level 1 (0 points)

    Moving the new entry to the top of the array was what did it for me… Thanks guys!

  • Lit L Help Level 1 (0 points)

    This seems to have done the trick for me!!

  • jmendez1905 Level 1 (0 points)

    Thank you so much for your help it worked for me. Late 2011 MBP 13 inch Boot ROM Version:          MBP81.0047.B27



  • pmelopereira Level 1 (0 points)

    Thanks ! It too worked after moving the entry to the top of the array. Excellent tip

  • theyellodart77 Level 1 (0 points)

    I am encountering a bit of an issue with the first step.  I seem to have altered the plist file correctly,  but when I save the new info.plist even with the information at the top into the package contents folder, and try to open bootcamp it seems to have broken the bootcamp assistant.  it wont show up in the spotlight, and when I go directly to the utilities folder to click on it i find it but it is unresponsive. I click on it and nothing happens. I did notice that when I saved the old info.plist.old It automatically rearanged the title so that plist is still the end file extension which I expect is normal,  but I could not get boot camp to reopen until I removed the duplicate plist file that we created,  which took me back to square one.  Thoughts? 



  • totalmacn00b Level 1 (0 points)

    Ok first off I have to say I have been only introduced into the mac scene after spending my life on PCs since DOS 3 ..... I was having real trouble getting the boot disk option to work and tried a few time with no luck (still very awesome help and thanks alot to aero253 for this detailed post). But THANKYOU gekkonaut I was about to give up and I moved my strings to the top and IT WORKED. Thanks so much to you all ! ! !

  • backlyt Level 1 (0 points)

    It took me a lot of playig around with the plist but I found that putting the entry in a sequential order worked. Also, I have MBP81 and I put MBP80 instead and it worked. Now to try to install...