Previous 1 5 6 7 8 9 Next 120 Replies Latest reply: Jun 28, 2015 2:24 AM by cameron Adrain Go to original post
  • damongaspee Level 1 (0 points)

    I think installing Mountain Lion simply reset the Photostream service, the same as doing it manually. I really don't trust Photostream and certainly don't recommend it to people -- dropbox has almost the same functionality and is completely reliable.

  • neilrcooper Level 1 (0 points)

    Further to my post on July 31 the photostream stays on no problem but when I open iPhoto the photostream has not been updated with any new pictures taken on iPhone and iPad. If I exit iPhoto and immediately open it again the photos are all there. Obviously a few bugs still lurking in this upgrade.

  • John P. Level 4 (1,145 points)

    For those who are having this problem, look in the folder "~/Library/Application Support/iLifeAssetManagement/" and see if the following file is included in the folder:




    I noticed that prior to following the steps outlined below, the file "iLifeAssetManagement.db-journal" was missing. After following the steps below, the issue was resolved.


    This is a fix I was given by Apple has to be followed precisely in this order.


    a) Turn off Photostream in System Preferences > iCloud. Close/Quit System Preferences.

    b) Visit ~/Library/Application Support/ and delete the folder "iLifeAssetManagement" and empty the trash.

    c) Reboot your computer.

    d) Go into System Preferences > iCloud and re-enable Photostream

    e) Open iPhoto.


    This is by no means a guarantee but I have done these steps and (knock on wood) the issue has not reoccurred.


    Be sure to submit feedback to Apple directly if you're still experiencing this issue, or if the issue was resolved using this procedure.


    Here is the direct link for iCloud feedback (Photostream is listed under Feedback Type).


  • Ethy Level 1 (0 points)

    Thanks for the above advice John P, I was hopeful after I first tried this that it had worked. However turning my laptop back on today and again I have to enable photostream manually in iPhoto.


    I now have a ILifeAssetManagement.db-journal file (yay?!) - sadly still no proper Photo Stream service.


    Quite frustrating really - I'd hoped upgrading to ML would mean fewer bugs!

  • stevencarpenter Level 1 (5 points)

    Apologies posted in the wrong thread....

    Now moved post to here,

  • stevelockridge Level 1 (0 points)

    John P, this may have worked for me. Rebooted, turned on Photostream, opened iPhoto. Photostream was on in iPhoto and photos are downloading from iCloud. I will test a few more times over the next couple of days and report back here.

  • Koruru Level 1 (5 points)

    Thanks to John P.'s Entry / Solution. Worked fine for me.



    Here is a fix I was just given by Apple has to be followed precisely in this order.


    a) Turn off Photostream in System Preferences > iCloud. Close/Quit System Preferences.

    b) Visit ~/Library/Application Support/ and delete the folder "iLifeAssetManagement" and empty the trash.

    c) Reboot your computer.

    d) Go into System Preferences > iCloud and re-enable Photostream

    e) Open iPhoto.




    Thanks so much! Photostream now works fine again.

  • RobertOSX Level 1 (0 points)

    Thanks So much. That surely helped me.

  • Ethy Level 1 (0 points)

    Ok - a quick update as my fix was a little different!

    After trying out John's method above with no success I was waiting till the next ML update came out - after updating I still couldn't keep photostream enabled plus I could no longer update iPhoto as it said I needed to sign into a different account!


    I called up Apple support and ended up doing the following:


    1) Delete the iPhoto application and empty trash

    2) Go back into the App Store/purchases and re-download the iPhoto app


    It's now remembered that it belongs to my account, plus photo stream now stays turned on!


    The support rep did mention that if you exit iPhoto before it has finished syncing Photostream it will default to being turned off. So far I've rebooted several times over a couple of days and given iPhoto a good minute to sync before I quit - so far no problems!  

  • Valerie Mcmillen Level 1 (20 points)

    For me I find that if I lose WiFi, or turn it off, then I have to turn Photo Stream back on---one of the most annoying things, it reloads ALL the previous photos--but other than that, it stays on. It took me MONTHS to figure this out, but thats what does it for me! The wifi.

  • PFJ30 Level 1 (10 points)

    Eek! So many posts... never sure it feels better to know you are not alone


    My photostream pics appear in iPhoto under Web section and whilst they appear in Library in the correct Event, and in Events, on the Event title bar in both it says No Pictures, or "0" and no picture is displayed on the Event Tile.  Any thoughts?


    My question beofre I discovered this was just going to be (and still is) "Once pics are imported into Library from photostream do they stay there after 3 months when photostream presumably dumps the oldest month in favour of the latest?"


    Hey ho



  • Don Mclellan Level 1 (15 points)

    My two bits.


    I too have had the same problem and was complacent with it however this was not good enough.


    In my adventures to try and solve the issue many many hours were spent updating and waiting for conversions and watching the Spinning Ball O'Death.  Making the update to iPhoto 9.4.x from 9.2.x was very painful, my recent iMac (mid 2011) right out of the box condition used only for iTunes and iPhoto suffered many evenings.


    The conversion of photos for use on both Aperture and iPhoto 9.2.x to 9.3 or 9.4 was impossible, plain and simple.  The conversion process would get to step 3 of 11 at 47% and crash, dozens of times after I tried to clean out any and all possible problems.  More than just a couple of evenings the iMac would overheat and Kernal Panic leaving no trail to follow.


    In the end I have taken any hint of iPhoto and removed it several times might I add, got my boxed iLife and reinstalled (photo's were saved to an external drive and hidden under the porch until I was content).  Next I updated to OS 10.8 "most recent" and iPhoto 9.4.most recent, also iOS6 on everything else Apple branded. 


    Next I imported all photo's (Create new was only solution to get it running) and watched the mess it created.  May I say at this point the Photostream seems to stay on however I have no idea how many days it will take to restore the Events, Albums and Faces I once had.


    The mess spreads to iTunes as well, the photo events are a mess similar to the corrupt version 9.1.x.   iTunes and iPhoto are a cruel joke at the moment and my best advise is to keep the old versions alive as long as you can.  Syncing to an iPhone 4 warns me "5,224 items could not be synced.  See iTunes for more information".  Of course iTunes has no warnings nor information waiting.  Seems odd at best since I don't use the iPhone for music nor much else other than a few app's and photo's, I have an old nano in the car for music and it sync's just fine.


    I may have the photostream working fine (only a few days) yet the mess left behind is much worse.


    Finally, iPhoto's advise to wait for "up to an hour" for converting a large library and such to take place on updating to version 9.4.1 is false.  Try 12 hours.  Perhaps I am dreaming but I don't think 35,000 is a really large library of photo's?  Perhaps even more disappointing is the time it takes to sit and wait and check on it and wait again and go for lunch and then wait some more for it to eventually crash with no warning all the time wearing a path on the desk from the mouse dragging pref's to the trash and restarting.


    One thing I have yet to try is to replace the HDD and reinstall everything from new or unplug the iMac and stick with the iPad and phones.

  • santiagocamara Level 1 (0 points)

    Works Greatttttt !! Tks a lot Buddy!!!!! I was very furious about that.

  • Heat132 Level 1 (0 points)

    actually all i did was:

    1. Go to system preferences, then icloud
    2. Uncheck photo stream
    3. Close system preferences and iphoto if you have it open
    4. Reopen iphoto and go to photo stream
    5. Turn it on and you should be done!
  • tplusfive Level 1 (0 points)

    John - this solved another problem - I subscribed to a photo stream in iPhoto but I'm not seeing any photos.  Thanks for your help .

Previous 1 5 6 7 8 9 Next