Previous 1 2 3 4 5 Next 92 Replies Latest reply: Aug 8, 2014 5:16 PM by LVANDERV Go to original post Branched to a new discussion.
  • 1to3ate9 Level 1 Level 1

    I have the same issue after updating my 4s last night and found a solution -- you have to enter your country calling code for each phone number (for US add +1 before each phone number in ur contacts) and the numbers will automatically change back to the contact names.


    Still definitely a bug but this solution seems to fix it for now.

  • StrokerAce12 Level 1 Level 1

    I have an iPhone 4s (Verizon) which worked fine until after the 5.0.1 update and now have the same problem where my contacts are not displayed with instant messages or phone calls.  After the update, contact names were not displaying in either phone calls (e.g. incoming calls, recent calls) or my instant messages.  Before the update, I never experienced this problem or anything related to it.


    SOLUTION #1 ATTEMPT (*228): I did the *228 (option 1) that people have recommended.  That worked so that my telephone calls were matched with my contacts.  However, I still could not see contact names with my instant messages.


    SOLUTION #2 ATTEMPT (partial reset): I called Verizon and they had me do the power button + home button to reset the phone.  For whatever reason, that flip-flopped my issue so that the contact names were now seen for instant messages, but not telephone calls.


    SOLUTION #3 ATTEMPT (full reset): The Verizon representative got an iPhone representative on the call and we tried a full reset on the phone (where it nukes your data).  This did not help at all (neither messages or phone calls showed a contact name).  I had to do a restore.


    SOLUTION #4 ATTEMPT (+ country code): I read where if you add a "+" and country code in front of the number in the Contact that this resolves the issue.  For one of my contacts I added the + sign followed by the country code.  Interesting, this flip-flopped the problem just for that Contact by making the phone calls with just this Contact show the contact name, BUT NOW the messages with this Contact do not show the contact's name (all of the other contacts remained the same).  This clearly indicates this is a software problem as there should be no reason for flip-flopping (it happened to me twice).


    SOLUTION #5 ATTEMPT (Waiting for iPhone Technician):  The iPhone representative has escalated my problem to an iPhone technician who is suppose to call me.  If the technician is able to resolve the issue, I will report the same here (but in the meantime, everyone with this problem should report it too Apple immediately!).


    If you have this problem, please contact your cell phone company and have them get an iPhone representative so they can get this very serious issue fixed.  It is important that everyone with this problem report it to Apple otherwise nothing will be done!


    Let's hope Apple addresses this bug in their software!  We can then have them focus on the Siri problems. :-)

  • kealani Level 1 Level 1

    Before you start adding digets to all of your phone numbers, go to Settings - Phone and turn off International Assist.

  • StrokerAce12 Level 1 Level 1

    Hi Kealani, I have tried turning off International Assist and that doesn't help my phone (doesn't seem to change anything).

  • LME3003 Level 1 Level 1

    I am having a silimiar issue with my iPhone 4 after updating the software. Not only can I not add in contacts to a text message, but I can not view my contects or edit them at all. The + sign does not appear at all. If I click on a contact name it just takes me back to the home screen! If I go into settings and try to click on contacts I am also just taken back to my home screen. Argh! I will call Apple when business hours arrive. Very frustrating, but this has been helped by knowing I'm not the only one with these issues.

  • 1to3ate9 Level 1 Level 1

    Just got off the phone with Apple Support -- My issue was that contact names were not showing up on my Messages list, just their phone numbers.


    Since I use Verizon, the first thing they told me to do was call *228 and choose option 1. (already did that)


    Then that told me to go Settings > Messages > turn iMessage on, then off

    -- that didnt work so...


    They told me to go to Settings > General > Reset > Reset Network Settings

    and then signed back onto my wifi and it worked (at least for now) - The names on my messages list immediately came back.


    Hope this works for you too!

  • StrokerAce12 Level 1 Level 1

    Hi Everyone,


    I just tried a solution I found on this this thread: which seems to have worked so far for my phone.  All I did was the following:


    • Step 1: Call *228 and select option 1 to update your phone;
    • Step 2: After your phone is programmed, double-tap your home button which will show you the multi-tasking bar and kill the Phone App by holding down on the Phone App icon until you see the minus sign and then select the minus sign to close the Phone App (NOTE: I killed all of the apps that showed up so if you kill just the Phone App and it doesn't work, maybe repeat the above and kill all of the apps);
    • Step 3: Select the home button once which closes the multi-tasking bar and let your phone set a few minutes (it took about 3-5 minutes before my phone history and other items synced to show the Contact name instead of the phone numbers).


    Amazingly, this simple process seems to resolve the issue for instant messages and incoming phone calls.  I hope Apple resolves this very serious bug in their software as it appears this bug has existed ever since the iPhone 4 was released and I expect it will pop up again for me eventually (at leaset I will know how to fix it quickly). 


    I believe it is important for everyone to bring this issue to Apple's attention otherwise this bug will never get fixed and we will all continue the experience this problem.  In the meantime, I hope the above solution helps someone at least temporarily until Apple figures out this bug.

  • I Am A CiscoKid Level 1 Level 1

    This worked for me until I rebooted my phone.. As soon as I rebooted my phone, the fix was lost.

  • bkmacy Level 1 Level 1

    Dialing verizon at *28899 and recieving the update from verizon seemed to resolve the issue with incoming and outgoing phone calls.  Those names are now mapping to those numbers.


    However, messenger still seems to have the same issue.  Anyone have any luck fixing the mappings to messenger?


    Agreed - this was a big missed bug probably cause by rushing out the fix to the battery and not doing full regression testing!

  • Mcdinzie Level 1 Level 1

    I have just changed to an iPhone 4s from a 3G and can no longer see my contact names on messages.  I am from new Zealand and not on Verizon but telecom...and the resetting networks does not work. Any other solutions that don't involve Verizon???

  • Ben52646 Level 1 Level 1



    Okay, here is how you fix this problem:


    STEP 1. First you have to dial *228 on your iPhone 4S. You should note that *228 is a Verizon over-the-air programming number.


    STEP 2. Wait for sometime until the system responds, then you have to press “1″ to “Program or activate your phone”.


    STEP 3. After sometime the system will say, “Settings updated”. Then you have to wait until the call disconnects.


    STEP 4. Now double click the Home Button of your iPhone 4S to open the Task Manager.


    STEP 5. Now close Phone, Message, and Contacts Applications on your iPhone 4S.


    STEP 6. After waiting for five minutes, open the Message App on your iPhone 4S to check the fix.


    That’s it. In this way you can fix iOS 5.0.1 contact bug on your iPhone 4S. If you are not able to fix this issue after using the above steps then again you have to close the Message App and restart your iPhone 4S. It is expected that soon Apple will release iOS 5.0.2 to fix this issue.

  • Kadao Level 1 Level 1

    Dear all,


    I´ve the same problem but with an iphone 4 with ios 5.0.1.


    It doesnt show incoming calls or msgs names but only shows the numbers.


    However I cannot try the verizon "fix" as I live in Angola. However I noticed that this only happens to the contacts with I stored with the country code. For instance if the contact is stored as +244 xxx xxx xxx, incoming calls and msgs display only the xxx xxx xxx.


    If I remove the country code and store only the number it recognizes it without a problem.

  • yacorange Level 1 Level 1

    *228 worked for me

    iPhone 4s and Verizon

  • NealX Level 1 Level 1

    Well, calling *228 and choose option 1 worked for me. iPhone 4s iOS5.0.1 on Verizon.



  • M2Carr Level 1 Level 1

    I have a brand new Verizon 4S with the 5.0.1 OS. Same issue as everyone else, no name in the text and caller ID.

    I too called *228 option 1 - to program your phone

    Then called *228 option 2 - roaming update

    Performed a hard reset - Hold down the Power and Home key until the apple logo shows up

    this solved my issue for now...

Previous 1 2 3 4 5 Next