1 3 4 5 6 7 Previous Next 91 Replies Latest reply: Jul 11, 2014 6:08 PM by Type5 Go to original post Branched to a new discussion.
  • 60. Re: Contact names not showing in sms iphone 4s
    grimbo695 Level 1 Level 1 (0 points)

    i have this problem to i did everything i read here now when they call it works now text doesn't

  • 61. Re: Contact names not showing in sms iphone 4s
    danafromohio Level 1 Level 1 (0 points)

    Just wondering if anyone has seen this problem persist or reoccur after updating to iOS 5.1 this week. I'm worried about doing the update over-the-air as that seems to have caused the problem with iOS 5.0.1.

     

    Ever since I did the *228 fix in November, my call logs & messages have stayed attached to their proper contact name. I just don't want this to happen again so I plan to do the tethered iOS update later this week.

  • 62. Re: Contact names not showing in sms iphone 4s
    JohnnyMac66 Level 1 Level 1 (0 points)

    Same issue here... i have tried several suggestions from this and other forums.... no luck.  I have reported it.

  • 63. Re: Contact names not showing in sms iphone 4s
    Nametab86 Level 1 Level 1 (0 points)

    This is not the first update where it's happened.. Often impacting those who have imported contacts. Seems to only affect contacts in the 'other' field.

  • 64. Re: Contact names not showing in sms iphone 4s
    pannvree Level 1 Level 1 (0 points)

    Coming in late to the Verizon 4S phone but have a similar issue - merged contacts from my blackberry and wife's Amaze droid but her telephone contacts do not appear at all?   BUT when we connect to bluetooth in our car she can see and use all her telephone number contacts?!?!  My telephone contacts are visible - hers are not?  Is this a store merge error by verizon?  Is there another "contact" list somewhere in her iphone?  The data (telephone numbers) are in there somewhere proven by the fact that they appear in our cars using bluetooth - help? 

  • 65. Re: Contact names not showing in sms iphone 4s
    magnusfromarlington Level 1 Level 1 (0 points)

    I am having very weird behavior with incoming international calls on my iPhone 4S, iOS 5.1, with Verizon; sometimes the incoming call has +"country code" which is preferred but most often it comes across without a plus sign and looks like a local number which is totally unacceptable, a third version is 011"country code" which is somewhat OK but does not map with my address book, and a last 4th version where +1"country code" which is also totally wrong.

     

    I have been in contact with Verizon but level 2 support say it is most likely an issue with iOS 5.1

     

    Let's say I get a call from Sweden which has country code 46 - I have seen the following 4 versions of phone number formats:

     

    +46"area code" "number"

    01146"area code" "number"

    46"area code" "number"

    +146"area code" "number"

     

    The first two work OK if you are in the US but if you receive an international number starting with 011 you cannot redial that number if you are outside US/Canada as other countries do not use 011 as their international access code. In most of Europe it is 00 for instance. So if you want a true universal format it would have to be the one starting with +"country code". As a former Ericsson employee I have never had this issue with any other phone or service provider - it is not rocket sience; very dissapointed this is lingering around! Digital cell phones have been around since the early 90s (GSM) - that is 20 years ago...

  • 66. Re: Contact names not showing in sms iphone 4s
    Phillip Hennche Level 1 Level 1 (15 points)

    The imessage on, off fix sorted it for me!! what a relief!! hope it works for others?

  • 67. Re: Contact names not showing in sms iphone 4s
    Sakbo Level 1 Level 1 (0 points)

    What you can do is, save in two formats of the same number,

     

    Ex-

    1. +94 777111111    ---> (+Country code ) & (mobile number )   ---> so you can see the name in messaging

    2. 777 111111          ---> (mobile number)   ---> So you can see the name when the same person calls you

     

    Idea is to duplicate the number in 02 formats so if the same person calls you or texts, you will be able to see the name

     

    worked for me !

  • 68. Re: Contact names not showing in sms iphone 4s
    andrewwynn Level 1 Level 1 (55 points)

    I had this problem since i restored my iPhone 4 onto my iPhone 4s. turned out to be a corrupted address book database on the phone.

     

     

    deleting the database @ /Users/Library/AddressBook (all files starting with AddressBook) (while Addressbook NOT running and when iCloud sync and iTunes sync both off) and re-run address book to create empty database before re enable sync solved it!

  • 69. Re: Contact names not showing in sms iphone 4s
    JocelynnfromVA Level 1 Level 1 (0 points)

    Thank you!  This worked for me.  I noted that below someone mentioned it works until you reboot.  At least I have a fairly quick fix for now.  ALSO, I noticed on my phone that "other" phone contacts were fine.  It only removed the name and did the international notation when I was communcating with someone else that had an iPhone.

  • 70. Re: Contact names not showing in sms iphone 4s
    selissa Level 1 Level 1 (0 points)

    I have an AT&T iPhone 4 and my SMS messages had no names anymore, only phone numbers. I went to Settings, General, Reset, and selected Reset Network Settings ... And it fixed the problem! Yea! My messages all have their corresponding contact names now. :)

  • 71. Re: Contact names not showing in sms iphone 4s
    DOSHU Level 1 Level 1 (0 points)

    Issue for me was the iCloud contacts overriding exchange gmail contacts, I simply did settings/mail&contacts&calendars/iCloud account/ turn off contacts and when asked to keep or delete chose delete option. This allowed my phone to use gmail exchange contacts once again and problem solved. Apparently iPhone and iPad have problems with multiple accounts synching contacts.. Funny enough multiple gmail accounts cause no problems. Only iCloud for me. Make sure you delete contacts when it asks you, otherwise it will still have corrupted contacts on your phone. If you don't have contacts synced through a web server well, I am sure deleting the contact and recreating it should help fix that..

     

    ICloud only is good for backing up app data, bookmarks and photos and since apple asks you to forfeit the rights to your privacy when you use the service so why keep contacts, emails and docs on there anywhore...

     

    Anyslut, hope it helps somebody! Just accounts interfering with each other, if adding a number straight from call log or from txt app to contact doesn't solve your problem, this is it.. Phone number is a phone number..

  • 72. Re: Contact names not showing in sms iphone 4s
    Brad Majors Level 1 Level 1 (0 points)

    Not sure if you got this fixed McDinzie, But I fixed a NZ Telecom Iphone 4S with this issue by

     

    1) In Settings, General, International, changed English to British English

     

    2) and then do this again and set it back to English

     

    3) Then close all your Apps, ie double click the Home button and when the apps show up along the bottom, hold your finger down on an app until  "–" signs appear then press each "–" sign to close each app.

     

    4) Finally reset the phone by holding down the power button and home button until you see the Apple logo (ignore the swipe button), it will then restart and should be good then

  • 73. Re: Contact names not showing in sms iphone 4s
    Wildwomn207 Level 1 Level 1 (0 points)

    Had to do a reset on iPhone 4 After updating to IOS 6.0.1.....lost everything... This is for Simple Mobile users.

    Apple iPhone - Internet and MMS (All Models)

    Cellular Data

    Select Settings.

    General Settings.

    Select Network.

    Select Cellular Data Network.

    Select APN.

    APN: simple

    Username: Blank

    Password: Blank

    MMS

    APN: simple

    Username: blank

    Password: blank

    MMSC: http://smpl.mms.msg.eng.t-mobile.com/mms/wapenc

    MMS Proxy: 216.155.165.50

    MMS Message Size: 1048576

    MMS UA Prof URL:http://www.apple.com/mms/uaprof.rdf

     

    Had no contact icon on home screen ... Found it in the utilities icon.

    Pulled it down... When trying to add contacts it didn't show any alphabetising...

    Went into settings under the mail , contacts..

    Set it to sort Order by first then last name in both locations...

    Still wasn't right..... ADDED MY NAME and PHONE to my contacts...

    Went back into setting to the mail, contacts and where it said " my info"

    I clicked that and chose my name and everything is back to normal... Hope this helps!

  • 74. Re: Contact names not showing in sms iphone 4s
    Twitch701 Level 1 Level 1 (0 points)

    I had to go into the message and save the number as a new contact. I deleted the contact that was apparently corrupted and everything seems to work at this point.

1 3 4 5 6 7 Previous Next