Previous 1 2 3 Next 37 Replies Latest reply: Jul 20, 2013 9:57 AM by karl-d Go to original post Branched to a new discussion.
  • Surfing_Mike Level 1 Level 1 (0 points)

    Not sure if this was resolved, but here is how I resolved it. 


    I had two accounts in iCloud.  Account #1 had different contacts than Account #2 had.  When I switched both to iCloud I suddenly had duplicates of everybody, except for the contacts that were different between the two accounts. 


    My solution was to go to Address book Preferences.

    Click accounts.

    Select Account #1 and uncheck the "Enable this account"

    Then select Account #2 in address book. 

    Click on one address and "Command + A" for select all. 

    Then File > Export > Export vCard.  (I saved it to my desktop)

    Then back to Preferences, disable Account #2, enable account #1.

    File > Import - then navigate to the vCard you just created on desktop. 

    Address book will immmediately ask you if you want to import, and tell you how many duplicates you have. 

    Select yes.  Now you will have all your accounts from different accounts together. 

    I would suggest no longer using the account that is not your primary iCloud account for contacts anymore by going into settings and under iCloud, deselecting the Contacts for the secondary account on your computer, ipad, iphone...etc. 


    Hope that helps. 

  • Brenda Bell Level 1 Level 1 (5 points)

    @Surfing_Mike: You shouldn't have to export to vCards. Launch Address Book and click on the red "group" button so your groups are on the left and your contacts are on the right. Select the group you want to copy from, click a contact, enter Ctrl-A to select all, then just drag all the contacts to a different group.


    Once all of the contacts are in the same group, you can then use Card -> Look for Duplicates to clean things up.

  • Surfing_Mike Level 1 Level 1 (0 points)

    @ Brenda: That solution would work, except that I had TWO different accounts.  The first time I did that there were only 8 duplicates, when clearly there were two of every contact.  The reason was because of the two accounts.  I wanted both accounts to be brought into one. 


    Thanks for the reply.  Just trying to be helpful. 

  • Csound1 Level 8 Level 8 (44,720 points)

    Dennis Burnham wrote:


    Beware Bruce -- I was as satisfied as you until Sync Services began destroying all the hard work I invested in making things consistent and accurate.  Keep backups!

    Sync Services are not involved with iCloud, iCloud pushes changes, there is no 'sync'

  • v-m Level 1 Level 1 (0 points)

    That worked for me. Thanks Russel!

  • Gwyneth Llewelyn Level 1 Level 1 (0 points)

    @russell's suggestion seems to have worked for me as well. Whew! I know what the problem was. I have both an iMac and a MacBook at home. I have just recently upgraded to Lion (I avoided upgrading to Lion when it was brand new hehe) so iCloud is still a novelty for me. To keep the Address Book in sync between both Macs, I just manually moved a copy from the MacBook to the iMac. Then, just to test things out, I sync'ed the iMac with iCloud, and completely forgot I had done so.


    Today, working on the MacBook, I saw that contacts weren't being synchronised with iCloud, so I clicked on the checkbox — and instantly I got everything duplicated. Well, almost, I had added a few new contacts on the MacBook as well who had not been duplicated. Puzzled, I started deleting them manually, one by one... after 30 or 40 or so, I got tired and Googled for a simpler way to do this


    @russell's trick fortunately solved my problem! Thanks a lot!


    Now to kick iPhone sync'ing into submission. Ha! That's on another thread here on the Apple Discussions forums. Sadly, it's a way old iPhone, so, no, it doesn't support iCloud...

  • mundox Level 1 Level 1 (0 points)

    Russell's solution largely worked for me, except now I have 60 more contacts in my iPad (2279) than I do on my Mac 2219). This is due to Facebook 256 contacts on my iPad that are not on my Mac and 196 Exchange contacts on my Mac that are not on my iPad.  Oh well... I guess I can live with this difference.

  • --Nancy-- Level 1 Level 1 (0 points)

    Russell, this worked. Thanks!

  • karl-d Level 1 Level 1 (0 points)

    After I upgraded my secondary Mac from 10.6 Snow Leopard to 10.7 Lion (already had one machine using iCloud contacts syncing), I had duplicate contacts on the secondary Mac (I periodically exported them from the primary machine and imported them on the secondary machine). I could turn off one set by just clicking ‘iCloud’ contacts in the groups pane, but then the contacts on the local drive would gradually become out-of-date. I basically did what Russell suggested after first removing the old contacts from address book. My steps were:


    1. In the Address Book application, clicking on “Contacts on my Mac” (I had iCloud and Local contacts), selecting all the contact cards, and deleting them.
    2. In System Preferences > Mail Contacts Calendars: clicking on the iCloud account, unchecking Contacts, and then choosing Keep a local copy. Wait a minute while the machine works.
    3. Re-check Contacts in System Preferences, and choosing Merge.


    Now I have synced copy on the local drive and available when I’m off WiFi. It would have been slightly easier if I had removed all the contacts from the computer just prior or after installing Lion (since the local copy was a dated manual import anyway).

  • Csound1 Level 8 Level 8 (44,720 points)

    karl-d wrote:


    Now I have synced copy on the local drive and available when I’m off WiFi. It would have been slightly easier if I had removed all the contacts from the computer just prior or after installing Lion (since the local copy was a dated manual import anyway).

    The iCloud Contacts are always available to you, you do not need to be connected to the internet to see them. If you, add to, change or delete any of them the changes will be applied to the server-side contacts the next time you connect to the internet

Previous 1 2 3 Next