Previous 1 2 Next 29 Replies Latest reply: Feb 17, 2015 2:59 PM by raspbz
briefcase Level 1 (0 points)

i keep getting the message 'your itunes library does not contain any songs with artwork' whenever i try to choose the screensaver. I looked al over apple discussions for a solution and none worked. I did use a previous itunes library from windows to make my current library.

MacBook Pro, Mac OS X (10.7.2), 2010 13 inch
  • TheSmokeMonster Level 4 (3,230 points)

    when in itunes, go to advanced and then Get Album Artwork. This will populate your library with the art work if iTunes can find it.

  • briefcase Level 1 (0 points)

    i tried that as well, but i still get the no artwork message. most of my songs have the artwork so i'm guessing the problem is that its looking in the wrong place

  • TheSmokeMonster Level 4 (3,230 points)

    so in itunes you see the album art work (on your mac)? have you blocked spotlight from indexing itunes?


    let's try this, go to system preferences, spotlight, and then privacy. find your hard drive or whatever drive you have your itunes library in, find the itunes library and add it to the privacy list of spotlight. then remove it from the privacy list.


    spotlight will begin to reindex your itunes library. restart your computer and try again.


    also try putting your computer to sleep and wake it back up from the  drop down menu at the upper left of the main screen if the restart doesn't work.


    I'm not really sure how iTunes Album art screen saver finds the album but if spotlight has them it's repertoire, I'd imagine it would help to retrieve them, even if itunes isn't open when the screen saver starts.

  • briefcase Level 1 (0 points)

    ya im on a macbook pro 13in.  i tried adding and removing the itunes folder and i rebooted, but same message. I tried the sleep method, and same thing. Are the actual picture files supposed to be in the album artwork folder? because my album artwork folder just has a cache and download folder and no picture files at all.

  • TheSmokeMonster Level 4 (3,230 points)

    you should be on iTunes 10.5 (141) you'll be able to see which version you are on when you go to itunes>about iTunes when you're focused on iTunes.


    run software update to make sure you're on the latest build, als0 make sure that your itunes folder is the one you think it is. There shouldn't be an album artwork folder (I believe) as the album artwork is stored within the files themselves now.



    What I would do, is select the right folder you want your itunes library in. Then select "Copy files to iTunes Media folder when adding to library" and I also have "keep itunes media folder organized".


    this is when you're on itunes, select iTunes>preferences>advanced.


    make sure your itunes folder is being pointed at.



    Screen Shot 2011-11-10 at 5.07.26 AM.png

    doing this will order everything the way it needs to be for iTunes to work correctly... hit ok and then let itunes transfer all the files over. Again, there isn't an Album Artwork Folder in my itunes folder anymore, mainly because I believe it's done another way.

  • filotnie Level 1 (0 points)

    I have exactly the same.

    Screensaver settings says: "Your iTunes library does not contain any songs with artwork" which is simply lie! ;-)

    almost all albums covers are there in my main library.

    newest iTunes 10.5.3 (3) 64-bit

    Lion with all add-ons

    not long ago I have joined iTunes Match.. unfortunately haven't checked if it works before for long time..

    I have: repaired permissions, removed iTunesArtwork* in ~Library/Preferences/ByHost/.

    Still nothing.

    I have found that ~/Music/iTunes/Album Artwork/ has 4 directories inside:





    .. first 3 had random named dir (the same) with what seems to be artworks directories. Local was empty still copying there this random dir didn't help too..

    Any ideas please?

  • matroos8 Level 1 (0 points)

    To resolve the problem is easy:

    While holding down the "Option" key, click on the iTunes icon on your dock. Then just re-choose your iTunes folder in the Music File inside your home folder.

    Somehow this reconnects the broken chain for the problem of "No Album Art Found In iTunes".

    No need to redownload your album artwork, or repopulate the artwork, or delete anything from your preference folder. Nor is it necessary to repair permissions for this problem.

    I hope this helps you. Let me know.

    I am running the latest OS X Lion and iTunes update to date.

  • Leandro_Brazil Level 1 (20 points)

    Thanks, your recommendation worked perfectly...




    Leandro Meinhardt

  • PhatBatt Level 1 (0 points)

    Hey Matroos :-)


    I tried this earlier, and it worked! But then I moved my Library file to a new folder so that I could get all my playlists together and stuff in the same place. My album artwork folder now resides in the same folder as my .itl file.


    I tried your trick again because the screensaver wasn't working, option, click on the icon, select the .itl file, and voila. All my playlists are there, but once again, my screensaver isn't working. All of my album art is showing up in iTunes.


    I'm using the latest OSX and iTunes versions on a MBP15.


    What do you think?



  • human or dancer Level 1 (0 points)

    Matroos one question-


    When you said "rechoose" what did you mean with it? I dont really understand your explanation, could you give me a step by step runthrough please? Thank you!

  • human or dancer Level 1 (0 points)

    Matroos one question-


    When you said "rechoose" what did you mean with it? I dont really understand your explanation, could you give me a step by step runthrough please? Thank you!

  • matroos8 Level 1 (0 points)

    Hi there,


    To answer your question "rechoose" simply means "choose again". When you hold down the option button while clicking on the iTunes icon in your dock, an option window will appear. In that window click on "Choose Library", then on the left columb click on your home folder, in the right window double click on your "Music" Folder, then highlight the "iTunes" folder, then in the lower right corner of the window click on the "Open" button.

    This might restore your iTunes Arwork Screensaver. Do not be disheartened if it does not work the first time. Just keep on trying, doing it over and over again, testing it from your System Preferences.

    I hope that helps you.

  • human or dancer Level 1 (0 points)

    Hi matroos,


    I did exactly step by step what you told me to do, and tried over 15 times the same prcedure, but still nothing, help?

  • Gnarlodious Level 4 (3,220 points)

    No consolation, but I have had this problem for more than a year on one computer. I did file a bug report and had some extensive diagnostics with Apple about the problem. They admitted they don't know what the problem is and were unable to fix it.

Previous 1 2 Next