Previous 1 2 3 4 5 6 Next 77 Replies Latest reply: May 29, 2015 7:00 AM by fursty898 Go to original post
  • ZiggyIPod Level 1 Level 1 (0 points)

    tatin's suggestion on Nov 22, 2011 12:45 PM did the trick for me.

     

    Windows Vista

    iTunes 10.5.2.11

     

    Seems a little odd that there has to be a button to "Reset all dialog warnings," though!

  • turingtest2 Level 9 Level 9 (58,550 points)

    Really? How else would you expect to re-enable all the dialog boxes that have a "Don't ask me again" option, once those options have been set?

     

    tt2

  • ZiggyIPod Level 1 Level 1 (0 points)

    Okay, it wasn't clear to me that that was the purpose of this button. I see value in that, but it doesn't look like that's what tatin's solution does (i.e., I'm not getting warning messages I had disabled previously - quite the opposite in this case!). If "Reset all dialog warnings" essentially un-checks the "Do not show this message again" option on all dialog boxes, it should be clear about that (e.g., "Clear all "Do not show this message again" dialog preferences," or something to that effect).

  • turingtest2 Level 9 Level 9 (58,550 points)

    Indeed perhaps it could be clearer though I've always understood what it does. What is perhaps more confusing is that the other set of warnings to do with automatic downloads, passwords when purchasing etc. are controlled seperately from the store account pages and not from that button, so all doesn't really mean all after all.

     

    tt2

  • iGnome Level 1 Level 1 (0 points)

    Mrteee3's solution worked for me:

    Mrteee3 wrote:

     

    My Mac has been free of this unwelcome prompt for several weeks now.  Here is what I did:  I launched iTunes and signed in to the iTunes store using my Apple ID and password.  I went into "Account" and clicked the "Reset all Warnings for Buying and Downloading" buttom at bottom.  I clicked DONE.  Then I clicked my Apple ID which is displayed at upper right, and then clicked SIGN OUT in the window that appears.  That's it.  I can now reset Safari all I want and the prompt does not return -- or not yet anyway!  Good luck -- it worked for me.

    I also regularly re set safari and the problem seems independant of cookies in Safari- Thanks Mrteee3 and all others that offered this solution

  • glenra Level 1 Level 1 (0 points)

    I'd been having this problem on and off - randomly my iTunes login would just stop working - I'd get a login prompt but couldn't log in. Until I read this discussion thread it had never occurred to me that how I used SAFARI would affect whether ITUNES works, but it does. And no special plug-ins are required.

     

    In order to totally break iTunes login on a mac, just do this:

    (1) Exit from iTunes and launch Safari

    (2) In the Safari menu. turn on "Private Browsing"

    (3) Launch Preferences and navigate to the Privacy tab

    (4) On the Privacy tab, select "Block Cookies:Always" and then click "Remove All Website Data" (and confirm by clicking "remove now")

    (5) Launch iTunes again

     

    RESULT=> any effort to sign into your iTunes account will fail silently. If you have the "automatic downloads" feature turned on, you'll get a "sign in to enable automatic downloads" prompt that doesn't work. If you try to "download all available updates" for your iPhone/iPad apps, you'll get a "log into your account" prompt that will fail to work. There is no warning message that explains why login fails, but the reason why it fails is that iTunes wants to set an Apple.com cookie in Safari. Since you deleted cookies and aren't allowing new ones in, iTunes can't log in.

     

    I must have changed my iTunes password a dozen times before I figured this out.

     

    To fix it, turn off the above-average secrecy settings in Safari. In particular, set your "block cookies" to either "never" or "from third parties and advertisers". And don't delete the Apple.com cookie once it's been set.

  • Fractal Dimension Level 1 Level 1 (0 points)

    Thank you! It was that damned cookie.

     

    Problem solved after months of grief!

    artimon wrote:

     

    I discovered that signing in to the iTunes store in iTunes creates a cookie on the Mac. If you have an extension in Safari that deletes cookies on exit, you may be deleting the Apple iTunes cookie, and it will make you authenticate on iTunes startup. For me, I signed out of the store in iTunes, signed back in and then made sure I had the cookies from Apple exlcuded from auto deletion upon Safari exit.

  • robertfrommiddlebury Level 1 Level 1 (10 points)

    I can see that this is for Windows Itunes, but I'm on a Mac and I have this exact same problem. I, like several of the people here, am prompted TWICE to sign in every single time I open Itunes. I've changed my preferences, signed in, signed out, called Apple, restarted my computer, etc. None of it has worked. Until I saw this forum, I thought I was alone and that I had done something wrong with my settings, but I guess not. If anyone from Apple sees this, could you please arrange for this bug to be fixed? Thanks.

  • shauncarter Level 1 Level 1 (0 points)

    I have the same problem. It is very annoying.

  • TLCYoda Level 1 Level 1 (0 points)

    BLESS YOU.

     

    That worked for me.

     

    Thank you VERY much!

     

    - Ron

  • wxwizard Level 1 Level 1 (0 points)

    Yea! This fixed it!

  • Cornelius III Level 1 Level 1 (0 points)

    I'm currently running iTunes 11.1.3 on a PC / Windows 7.  Open iTunes.  Go to Edit/Preferences/Store.  Untick Music, Apps and Books under 'Automatic Downloads'.  You won't be asked to enter your Apple ID details the next time you open iTunes.  And you'll have to manually sync your Apple device with iTunes, which is my preference, anyway.

  • fm110 Level 1 Level 1 (0 points)

    This has been an ongoing issue for me. Thanks so much for the detailed fix. It worked!

  • Krishen Level 1 Level 1 (0 points)
    but the reason why it fails is that iTunes wants to set an Apple.com cookie in Safari.


    Nice bit of sleuthing there glenra!


    I just wanted you to know that 2.5 years later, your procedure still breaks (and fixes) iTunes 12.1.0.50.  I hope someone from Apple reads this!

  • JBJ0005 Level 1 Level 1 (0 points)

    This solved my issue as well....In Safari,I had cookies disabled entirely. I re-enabled cookies and voila, issue was fixed. Weird to me that Safari is linked to iTunes but I'm sure there is a reason...Thanks for identifying the relation, I was about to nutes after 2 days of dealing with not being able to login.