Previous 1 2 3 Next 39 Replies Latest reply: Feb 25, 2015 7:27 AM by thesteelegl Go to original post
  • bwolfy Level 1 Level 1

    This is great, I was having this same issue.  Glad someone has it figured out.

     

    So in disableing this 'snapshot' what does that do exactly?  I really would like to make sure time machine continues to back up. 

     

    What is the difference in time machine backups and the snapshot feature?  And if I restart will that take all the settings back to factory?  Or do I have to do this command again or another command?

     

    Thanks

  • wesehrt Level 1 Level 1

    Thank you thank you thank you!

  • elikness Level 4 Level 4

    The Local Snapshot is for laptop users who may not be continuously attached to a hard drive over Firewire or USB and now Thunderbolt connections. The Mac continues monitoring changes made to the local hard drive (every time a file is opened or saved or downloaded) and saves all the changes into the 'local snapshot'.

     

    Here's a Apple FAQ on local snapshot for your personal reading time:

     

    http://support.apple.com/kb/HT4878?viewlocale=en_US&locale=en_US

     

    On portable Macs, local snapshots are automatically enabled when you turn on Time Machine. Just like regular Time Machine backups, local snapshots are made hourly in the background.

    Note: The Time Machine status in the menu bar does not change when a local snapshot is created.

    Local snapshots are periodically condensed into daily or weekly snapshots to minimize the space used on your disk. If your disk is low on space, Time Machine stops creating new snapshots, and some or all existing snapshots may be removed to make space available for applications to use. If sufficient disk space becomes available again, Time Machine resumes creating local snapshots. This means your disk will have the same amount of available space as it would if Time Machine were not enabled.

    When you enter the Time Machine browser (used to restore data), local snapshots will appear on the timeline along with regular backups distinguished by different colors. Gray tick marks represent local snapshots and pink tick marks represent backups stored on your external backup disk or Time Capsule. Note: Pink tick marks will be dimmed if your portable computer is not connected to your external backup disk or Time Capsule.

  • bwolfy Level 1 Level 1

    Thanks for the link and clarification.  I would like to leave this feature on, however it still interfears with the project.  Hopefully Apple had a fix for this soon. 

     

    Again thanks!!!

  • John P. Level 4 Level 4

    Hey guys,

     

    I am noticing this issue as well, and I can confirm that turning off Time Machine is a workaround.

     

    Please submit feedback to Apple directly so that they know about it (if they don't already):

     

    http://www.apple.com/feedback/imovie.html

  • rustybrown Level 1 Level 1

    Excellent answers--you saved my bacon! I just wanted to add that I was getting mysterious failures in iMovie while trying to import from either the camera or a local camera archive. I'd get a message simply saying "the clip could not be imported". Turning off local snapshots as described here fixed that problem as well.

  • gfs543 Level 1 Level 1

    Thank you so much!  It fixed my iMovie problem as well.

  • thatguy121 Level 1 Level 1

    I did all that you said but this part "The type the word, exit and hit return. Quit Terminal." i didnt know what you meant and it still gave me the error if you could explain it in more detail. please help quick project due monday!

  • elikness Level 4 Level 4

    Inside your Applications folder on the Macintosh there is another folder titled "Utilities". Inside of that folder is an application called 'Terminal'. Launch that application called Terminal.

     

    Click in the Terminal application window, and hit the Return key a couple of times in order to see your command prompt that looks like this- yourMacName %:

     

    To turn off Time Machine snapshots type in the following command:

     

    sudo tmutil disablelocal

     

    The Mac will likely ask for your password, so type it in and hit the return key. At that point, if the command has executed properly you will see your command prompt return. Then type the word, 'exit' and hit return key. Quit Terminal application as you have now turned off the local snapshot.

     

    Open iMovie and try doing another export and see if the same error message pops up.

  • edwardzbrown Level 1 Level 1

    Its strange, when i type in the password no characters apear but I know its still typing because if you don't type the right password it says sorry, try again. However, When I do type in the password I get "sudo:tmutil: command not found. and it still doesn't work. I don't use timemachine. Never have. I still get the -2125 error.

  • Bill @ 417 Level 1 Level 1

    I'll add my appreciation to you for your responsiveness to a lot of frustrated people. I found this thread only after posting my question on the same issue (after submission I spotted the "More Like This" sidebar). I'm using a laptop with Time Machine at work; never suspected it would interfere with iMovie at home (disconnected from TM).

     

    Please tolerate one more question on this, perhaps to summarize.

     

    1. Does turning off TM accomplish the same solution without needing to go into Terminal? I'm assuming the advantage to the Terminal approach is the you can keep TM "on" and still avoid the iMovie problem.

     

    2. After all projects are finalized and exported, turning on TM gets you back to normal, correct? You just need to turn TM off the next time you want to finalize, export, or share, correct?

     

    Last question is more for Apple, if this has been going on since last October why hasn't there been an update fix? Perhaps the fix will be in Mountain Lion.

     

    Thanks again. I will try to Finalize my project again tonight with this work-around.

     

    Bill

  • Lionflower Level 1 Level 1

    Simply disabling TimeMachine didn't work for me. I'm running Lion on a MacBook Pro. I had to disable the snapshot feature using the terminal before my 27 minute HD video would finalize.

     

    I think I'm going to make a t-shirt that says:

     

    (sudo tmutil disablelocal)

     

    hee hee.

     

    Thanks for the help!

    ~S.

  • beebeme Level 1 Level 1

    so helpfull ty so much elikness

  • JonnyTex75 Level 1 Level 1

    Looks like great info. I'm in the middle of Time Machine running, so I'm going to wait to give it a try.  There's nothing like losing 3 hours of your life from failed video rendering!!!

     

    One question:

     

    How do I turn snapshots back on?  If I make the assumption that Apple will fix this problem, I kind of like the idea of snapshots and would like to be able to turn them back on later.

     

    Thanks!

  • JonnyTex75 Level 1 Level 1

    Let me answer my own question:

     

    sudo tmutil enablelocal

     

    in the terminal.

     

    this is from:  http://www.macworld.com/article/1164802/enable_local_time_machine_snapshots_on_a _desktop_mac.html