Previous 1 5 6 7 8 9 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL Go to original post
  • DDD-MAN Level 1 (0 points)

    Its been 6 weeks.  After a new TBD, it hasn't come back once.  I think I'm declaring victory for myself.

  • Robert Clare1 Level 1 (5 points)

    This bit me this morning with my new MBA and my new TBD (both on the order of 3 weeks old).  The display ethernet claimed no cable.  The display USB was perfectly fine.  I don't know about the display firewire.  After trying several sleep/wake cycles, I came upon this discussion and did the most commonly recommended 'fix': I rebooted.  And voila!  Display ethernet is back.  It does seem like it is some kind of Mac OS issue, although it is difficult to argue with results like those of DDD-MAN.  I must admit that I rebooted while attached to the TBD, so who knows whether that did some kind of reboot to the TBD itself.  If it happens again, I'll first try the ifconfig down and up cycle, then the DHCP -> Off cycle and then reboot standalone (ie, disconnected from the TBD), followed by reboot attached to TBD, as needed.   It's great that we have these discussion fora, since Apple seems so responsive... 

  • Smef Level 1 (0 points)

    I've also been experiencing this issue, and one thing I have noticed when I am having this problem is that when I go into network preferences -> Display Ethernet -> Advanced -> Hardware there is no MAC address available for the Display Ethernet interface.  Display Ethernet is also not available if I click the + button to add a new interface.  Has anyone else seen this same problem with no MAC address being displayed or the interface not being available in the "add" list?

  • waa Level 1 (10 points)

    Yes - I had the same problem and I reported it months ago.....

  • bowerymarc Level 1 (0 points)

    I'm still having this problem, with MBA and TBD.  Reboot solves it but I don't want to reboot, that's why I have a mac!  For me, it's only a problem with the TBD ethernet port.  It just won't reconnect.  C'mon apple, it's been more than a year!  Fix it or backport your fix from10.8 already!

  • pkrnjevic Level 1 (0 points)

    Finally Apple has fixed this! (at least for me ). The latest Lion update to 10.7.4 has fixed the Ethernet problem 100% so far. And most USB devices are detected immediately. However, my Apple wired keyboard is taking even longer to detect that before - <sigh>. Maybe that will be fixed in 10.7.5.

  • dfwapple Level 1 (0 points)

    Had hopes that 10.7.4 fixed the issue, but same behavior within 24 hours of installing the update.


    Time to tie up the support line at Apple and get them to send me a replacement display.


    Very disappointing.

  • urbicande Level 1 (0 points)

    Quick update on my side. I followed the advice of John May here:



    And deleted my /Library/Preferences/ (do that in single usermode). Everything has been working perfectly since then (more than a week now).

  • Kriya Yogi Level 1 (0 points)

    Permanent Binding Order Solution:


    I believe you are experiencing intermittent connection problems with your Thunderbolt Display Ethernet interface because your binding order needs to be configured properly, as follows:


    • In Lion, go to System Preferences > Network > select the Gear drop-down-list button located immediately to the right of the plus [+] and minus [–] buttons > then select Set Service Order...


    • In the Service Order list, drag your "Display Ethernet" interface to the top of the list > select OK


    • select Apply


    Technical Explanation:


    In the world of networking, "binding" means to "listen," so by placing Display Ethernet first in the binding order, you are asking Lion to listen first on the "Display Ethernet" interface before it listens on your "Ethernet," "Wi-Fi," or whatever other interfaces you have going.


    This way, for example, if you still have Wi-Fi turned on whenever you dock your MacBook Pro—which I would want, as a matter of convenience—then Lion will use your hard-wired Display Ethernet interface before it tries to use your Wi-Fi interface.


    This explains the hit and miss user stories and excruciating wait times for a connection that everybody is experiencing—depending upon their binding order. The most likely reason everybody is having connection issues with their Display Ethernet ports is because they have Wi-Fi listed before Display Ethernet in the Service Order list.


    In this Wi-Fi first example, then Lion will continue trying to connect using the Wi-Fi interface for a certain pre-determined time period until that period times out, then Lion will try to use the next interface listed in the binding order for its time period, and so forth.


    Every network operating system out there has to be told which interface to listen on first and Lion is no exception.

  • Mark TTU Level 1 (0 points)

    That doesn't explain the issues with USB devices not working though.


    I've found that if I open the display on my MBA, wait for it to come alive again (mouse and keyboard on the MBA work again and WiFi has picked up my AP), then connect the Thunderbolt Display, then wait for about 5s before touching anything (even bumping the mouse screws this up), then everything works as expected.


    I think Apple and/or Intel have some issues left to work out on Thunderbolt in general. I for one can't wait until they get those issues worked out.

  • Kriya Yogi Level 1 (0 points)

    Yes, I have not explained issues with USB devices.


    My reply is "in response to uribejm" and Jaime's original post about his or her "Ethernet port in Thunderbolt Display connecting intermittently."

  • DDD-MAN Level 1 (0 points)

    Sorry Kriya - if you look at this full thread you'll see that binding priorities has been tried many times by these users and apple support with no joy.  Apple has admitted problems and is issuing replacement displays.  These replacements work perfectly for those who've received them.  And this problem is true of Ethernet, USB, and FireWire lost connections. 

  • bertfromhouston Level 1 (0 points)

    I had the same problem and fixed it with:


    In network settings set the location to automatic so display ethernet can be seen.

    Go to the advanced screen and Renew DHCP Lease.


    An IPv4 address wil created and system will connect through Tunderbolt

  • Thosel Level 1 (0 points)

    I also had a problem with my ethernet connection in my brand new Thunderbolt Display, connected to my MacBook Pro Retina with OS X 10.8. It fluttered between no-contact (red), and no-IP-adress (yellow). Basicly, not working.


    This solved it for me, and hopefully solves it for you (assuming you don't have a broken ethernet cable, or some other silly hardware problem)


    1. Pull out your ethernet cable


    2. In system preferences, go to Network/Display ethernet/Advanced/Hardware


    3. Choose Manual, and your configuration (mine is Speed: 1000baseT, Duplex: Full duplex, MTU: Standard 1500) I think the fix lies in NOT choosing duplex with "energy efficient" mode.


    4. Save your way out.


    5. Plug in your ethernet cable


    6. Go to System preferences/Network/Display ethernet/Advanced and refresh DHCP


    7. Save your way out again.


    After I did this, my network's been stable and working perfectly. Hopes this helps.

  • weissefar Level 1 (0 points)

    bertfromhouston wrote:


    I had the same problem and fixed it with:


    In network settings set the location to automatic so display ethernet can be seen.

    Go to the advanced screen and Renew DHCP Lease.


    An IPv4 address wil created and system will connect through Tunderbolt


    Thanks bertfromhouston. This worked for me

Previous 1 5 6 7 8 9 Next