Previous 1 3 4 5 6 7 Next 131 Replies Latest reply: May 8, 2015 9:08 AM by PatrickL Go to original post
  • 2200xl Level 1 Level 1

    Excellent, I did the same thing Monday. Hopefully we'll hear back with a fix.

  • pcort Level 1 Level 1

    I just ran across this problem at work, it's a new MBA and Thunderport display, the issue's the user was having were the main display was set as the monitor and when he would disconnect to go somewhere the screen would never switch over, and when he reconnected it wouldn't switch over.  the 'fix' was closing the clamshell or detecting displays respectively.  Also the ethernet issue was present.  He was able to fix the issue by doing the EFI update, so make sure that you've installed the latest EFI update and [b]HOPEFULLY[/b] this solves the problem.

  • urbicande Level 1 Level 1

    Are you talking about the MacBook Air EFI update released yesterday?

  • pcort Level 1 Level 1

    Yeah I believe so.

  • DDD-MAN Level 1 Level 1

    Sorry. EFI update doesn't fix it permanently.

  • urbicande Level 1 Level 1

    Then, it's about time to release a new Thunderbolt display firmware update. This problem has been around long enough, I'm starting to lose my patience here.

  • pcort Level 1 Level 1

    does it fix the issue for a little while? Have you installed this update and then had the issues return?

  • gmatroni Level 1 Level 1

    I had the issue after I restored Time Machine, I reformatted Drive and then re-installed Lion and copied my files manually via xover cable between old mac and have not see the issue in 2 weeks now

  • 2200xl Level 1 Level 1

    Confirmed the latest MacBook Air EFI Firmware Update (2.4) did not fix the problem. The Apple Support told me they hope to have it fixed from a few weeks to a few months. Thanks Apple....

  • pcort Level 1 Level 1

    Well it seems to have worked for my guy.  He hasn't had any issues with the display not picking up the ethernet connection or the issues with the default main display.

     

    He hasn't seen any issues going on a week now.

  • Anthony Buckton Level 1 Level 1

    HI All,

     

    I've been using my MBP 15" and the display without a hitch since early December (sleep, dock the works - all good)

    Today I took the machine out with me to a meeting and on my return ... bing. No network through the display.

    I was saddened by this discussion which is right up now ... c'mon Apple.

     

    Happy to provide whatever debug is needed ... just want the network connection to work...

     

    AB

  • Dzeimsas Level 1 Level 1

    I have been reading all your posts and I feel all your frustration. My issue is not only the Display Ethernet but all the Display USB ports as well. I was having this issue a few months ago when I first got the TBD but when I installed the TBD firmware update (1.1) everything was working as it should... I was so excited! However, two days ago when I installed the MBP EFI firmware update (2.7) all the TBD issues came back. Its so disappointing and counter productive. Instead of working and writing code right now Im complaining and venting all my frustrations just like all of you.

     

    If anyone has had the same issue after installing MBP EFI firmware update (2.7) please let me know.

     

    Hopefully Apple will come out with a patch soon because at this point this TBD is just another monitor. Why spend $1000 plus If you cannot utilize the main features of the display.

     

    Dzeimsas

  • Stephenm54 Level 1 Level 1

    Thanks Endurion,

     

    I went to the hardware tab for Display Etherner, set it to manually, 100base TX, fully duplex and standard (1500) and it worked.  I had to try different speed settings, but once I set it to 100baseTX, it instantly turned on.  I have since tried rebooting, shutting down, going into sleep mode, unplugging from the TD etc. and it has worked with every scenario.

     

    Thanks!

  • urbicande Level 1 Level 1

    So right now I have the typical situation where I plugged my MBA to the screen and the ethernet port on the display can't be used once the computer came out of sleep. I tried to change the speed in the hardaware tab without success. Once I select 'Configure: Manually' nothing appears on the speed drop out menu.

     

    I'm pretty sure rebooting the MBA will fix it but I'm getting sick of doing it!

  • Flynnsta Level 1 Level 1

    Exact same problem:

     

    I have a 1.8 GHz Core i7 Macbook Air 13" 256 GB SSD connected to a thunderbolt display.  Worked very well for the first two weeks.  Just updated the firmware to 1.1 and now am seeing several port connectivity problems: USB (keyboard) and Ethernet.

     

    With different combinations of either rebooting my MBA or TBD, I can get at least one, or if I'm lucky, both port types to work again.  Is anything being done to address this?

     

    It's an awfully expensive display not to work as expected...

     

    Dissapointed, to say the least.

Previous 1 3 4 5 6 7 Next