13 Replies Latest reply: Jul 1, 2013 5:30 PM by Vernon Alexander
Vernon Alexander Level 2 Level 2 (450 points)

I have a 27" 2007 iMac with OS X 10.6.8.  When I open system prefs the majic mpuse software is not there.  All I get are the regular mouse controles not the special screen that comes with eth emajic mouse.

 

I tried to install the latest update, but the system states that it is already installed.

 

When I open the mouse control in asystem preferences all  see is tracking speed/double-click Speed.

 

I have no Magic Mouse controles, th emose will not scrole or do anything other than basic mouse operations.

 

How do I get the right softwear installed?

  • X423424X Level 6 Level 6 (14,205 points)

    Try smc and pram reset.

  • captfred Level 7 Level 7 (26,265 points)

    When the preferences don't show up it's usually a conflict with 3rd party software.  USB overdrive has a known conflict.  Uninstall it and restart.

     

    If you have 10.6.8 installed then you have the required support for the Magic Mouse.

     

    Regards,

    Captfred

  • X423424X Level 6 Level 6 (14,205 points)

    Do you have the bluetooth preference pane?  If so try pairing the mouse from it and then see if the mouse prefpane shows the MM controls (may have to relaunch system preferences first).

  • Vernon Alexander Level 2 Level 2 (450 points)

    This is my sister's computer and it recently died.  It would power on but crash or just would not boot.  I took a chance and upgraded her RAM and the system booted, then I wiped her HD and did a fresh install of Snow Leopard then a back up from time machine.

     

    I used a regular keyboard and mouse to do the repairs.  Then I took it back to her and connected her Magic mouse and Apple Bluetooth keyboard.  It worked but the preference pane for the magic mouse is wrong.  The system recognises the mouse as a "Magic Mouse" but will not show the correct preference control for the magic mouse.

     

    I tried reinstalling the Majic Mouse software and got a message "The Majic Mouse softwear is up to date.

     

    I parried the mouse several times using the preference pane and the drop down from the menu bar under finder.  Nothing.

  • X423424X Level 6 Level 6 (14,205 points)
    I parried the mouse several times using the preference pane and the drop down from the menu bar under finder.  Nothing.

    It's still not clear to me you answered my previous question, i.e., was the preference pane you used the mouse prefpane or the bluetooth prefpane, i.e., is there a bluetooth prefpane?

     

    Also, if you open your System Profiler and click on Bluetooth under Hardware, does it show it recognizes the BT hardware is present?

  • Vernon Alexander Level 2 Level 2 (450 points)

    The computer recognises both the bluetooth keyboard and "magic mouse".  I used the mouse preference pane and it lists the mouse as a bluetooth "Magic Mouse" but it is not the "Magic mouse "  preference pane.  It is a preference pane for a generic mouse even though it says "Magic mouse".  I have two computers at home that both use the magic mouse and I know what the pregerence pane looks like, and all the adjustments it gives even the animated movie in the preference pane. 

     

    The 27" imac with OS 10.6.8 is showing "magic mouse" but the preference pane is for a generic bluetooth mouse.

     

    I have paired the mouse with the preference pane, and using "Set up bluetooth device"

     

    The System Profiler showes

    Apple Bluetooth Software Version:          4.0.1f4

     

    Devices (Paired, Favorites, etc):

      blaw, blawr’s mouse:

      Address:          xx-xx-xx-xx-xx-xx

      Type:          Mouse

      Firmware Version:          0x84

      Services:          Apple Wireless Mouse

      Paired:          Yes

      Favorite:          No

      Connected:          Yes

      Manufacturer:          Apple (xxxxx)

      Vendor ID:          xxxx

      Product ID:          xxxx

      EDR Supported:          No

      eSCO Supported:          No

      Vernon Alexander’s Keyboard:

      Address:          xx-xx-xx-xx-xx-xx

      Type:          Keyboard

      Firmware Version:          xxxxx

      Services:          Apple Wireless Keyboard

      Paired:          Yes

      Favorite:          No

      Connected:          No

      Manufacturer:          Broadcom (xxxxxxx)

      Vendor ID:          xxxxxx

      Product ID:          xxxxx

      EDR Supported:          No

      eSCO Supported:          No

  • captfred Level 7 Level 7 (26,265 points)

    This is almost always caused by a conflict with 3rd party drivers. 

     

    Regards,

    Captfred

  • Vernon Alexander Level 2 Level 2 (450 points)

    That is weird being that I did a clean install on the computer before I pared the mouse and keyboard.

     

    The computer has never been used with any other Bluetooth device.   It has only been used with the mouse and keyboard that came with the iMac.

     

    I do not know what 3rd party software to look for being that I never installed any 3rd party devices.

  • captfred Level 7 Level 7 (26,265 points)

    First verify that you've updated to 10.6.8 in  > about this mac.  Native support of the MM occured somewhere around 10.6.2.

     

    Have you attached other devices like a Wacom tablet etc.

     

    I'm still unclear which iMac you have since you say it's a 2007 iMac 27".   The first 27" came out in 2009, so if it's a 2007 then probably a 24".  That model (in later years) had Leopard installed 10.5 

     

    Edit:

     

    If you find that you have 10.5.8 installed, then you need this update:

     

    http://support.apple.com/kb/DL951

  • Vernon Alexander Level 2 Level 2 (450 points)

    My bad, I don't know what I was thinking.  It is a 2007 24"

     

    Model IdentifieriMac7,1

    I did a fresh install of Snow Leopard before I added the magic mouse.  All the updates have been done, so all the latent software and 10.6.8.

     

    NO OTHER devices of ANY kind have ever been used with the iMac except the factory mouse and keyboard.

     

    The Mac refuses to display the correct preference panel, so no scrolling.  My sister is very irritated because I talked her into the $70.00 Magic Mouse which is NOT being Magic but Stupid....LOL

     

    I know it has to be something simple that I am just not seeing.

  • BarSmart Level 1 Level 1 (0 points)

    Did you ever find out how to fix this because I'm having the exact same problem. I actually returned a touchpad a few weeks back because I thought the thing didnt support scrolling. No kidding!  So I get the mouse today and it doesn't allow me to scroll.

     

    I check dozens of sites where people parrot the same thing "Well ahh it umm should only happen if some other software is conflicting" - and in my situation, as well as yours, no - no it is not. I never had any other USB related software on this machine.

     

    Yes it is 10.6.8 and yes it is completely updated.

     

    Heck I even ran some OnyX cleanup today just to make sure.

    I even tried to circumvent the lack of the 'Enable Scrolling" checkbox (or the entire menu it should be in) by installing MagicPrefs - and it just gives me a big red ! over the icon.

     

    Further research shows I'm missing some stuff in my library - important things like "com.apple.driver.AppleBluetoothMultiTouch.plist" (I see the one for my touchpad from Dec) but nothing for the MM.

     

     

    I did install this bluetooth update - which made me yank the mouse and re-add it: http://support.apple.com/kb/DL889

     

    Basically I'm stuck wonder when OS X became as crappy as Windows because I should never have to spend this amount of time finding out that other people have this problem - and nobody has a fix.

  • sibi4403 Level 1 Level 1 (20 points)

    Hi!

    Did you find a solutioin to this? My friend has the same problem.

    Cheers,

    Sigge

  • Vernon Alexander Level 2 Level 2 (450 points)

    I haven't found a solution. It's strange, seems like it should be  solved. by now. It's one of those things that can drive you crazy, if you let it. I talked  my sister into buying the Magic mouse which  is expensive, but I use one at home and I enjoy the features so much now I couldn't live without it.

     

    My  sister on the other hand, doesn't know what  she is missing and I'm not telling.

     

    Anyway, I hope this bit of chatting  will inspire someone to speak up. I mean, it's got to be something simple… Right?