Previous 1 2 3 Next 68 Replies Latest reply: Oct 13, 2014 11:38 AM by Terence Devlin
Emmangt Level 1 Level 1 (0 points)

IMG_0434.jpgIMG_0425.JPG

 

I am using an iPhone 4S and took several photos this weekend with the built-in camera App. I've imported them on my iMac using iPhoto 11 and 27 out of 250 are corrupted (see image attached).

 

Now iPhoto erased the original versions on my iPhone so there is no way for me to get these pictures back. They were showing ok when viewed inside the photo app on the iPhone itself. It is very frustrating. Has it happened to anyone before?? Can I still trust iPhoto and iPhone?

 

I am using an non-jailbroken iPhone 4S with iOS up to date and OS Lion un to date and iPhoto 11 up to date.

 

Thanks for helping!!

 

note: I had to reduce the images using photoshop for them to be uploaded here, but the photos are looking the same in my iPhoto library.

 

IMG_0436.JPGIMG_0441.jpg


iPhoto '11, Mac OS X (10.7.2)
  • Terence Devlin Level 10 Level 10 (128,685 points)

    Not sure the issue is with iPhoto. It may still be on the phone.

     

    Next time you shoot material, use Image Capture (in your Applications Folder) to move it to a folder on the desktop and view them with Preview before importing to iPhoto.

     

    Regards

     

     

    TD

  • robby_jai Level 1 Level 1 (5 points)

    this is NOT an issue with the phone. It is an issue with Iphoto during the import process. I would like to think i am technically savvy... but i am having identical issues.

     

    when i import them into iphoto directly from my iphone it corrupts a number of pictures identical to above.

     

    however when i use a disk software eg phonedisk and then copy the photos locally onto my hard drive and then use iphone to import the photos i have NO issues at all.

     

    so it is definitely during the iphoto import process from the phone.

     

    its a work around but its frustrating

  • Terence Devlin Level 10 Level 10 (128,685 points)

    Well that is very useful information, and certainly points the finger back at iPhoto. The reason I am dubious is that I've not seen a report of this issue before.

     

    What happens when you use Image Capture (in your Applications Folder) to move the files to the HD?

     

    Regards

     

     

    TD

  • Emmangt Level 1 Level 1 (0 points)

    I will try again tonight.

     

    5 Photos were not imported for an unknown reason. I think iPhoto just showed a message saying these 5 pictures were not imported and mentionning their file name. These 5 are still on my phone, showing ok, and also some pictures i took with the Hipstamatic app have been corrupted while importing but i beleive they still have a copy in the Hipstamatic app as well. I could try importing them again and see if they get corrupted the exact same way.

     

    I will try this this evening and let you know, and copy all the message errors if there are any.

    Thanks for the help!

     

     

    Emmanuel

  • Emmangt Level 1 Level 1 (0 points)

    Ok, here is the verdict.

     

    Using Image Capture for the few photos left I had on my iPhone did not turn up damaged.

     

    However, i am not able to reproduce the error this time with iPhoto while importing new photos i took today with the same iPhone. They turn up ok. Maybe it was a one time thing. I remember itunes might have been syncing my iphone at the same time, maybe there have been some data loss during the syncing yesterday... maybe a low memory thing. I am not a thecnical expert. But for sure this error may happen again to some users as i'm using only apple material with up-to-date versions of everything and i was doing a pretty basic operation.

     

    Further proving the iPhone is not responsible, I was able to e-mail myself the very same photos taken with the Hipstamatic app that were imported corrupted on iPhoto, and they are ok when imported via my email. So the original files on the iPhone were fine, while after going through iPhoto importing they were damaged.

     

    The only way to prevent this, since i'm going to be more careful next time, is that after an iPhoto import, i will keep the Photos on my iPhone rather than having iPhoto deleting them right away. If they show up messed up, Ill have a backup option.

     

    well well. everything can't be perfect i guess.

  • barrus Level 1 Level 1 (0 points)

    I am having the same problem. About 1/4 to 1/3 of the photos I import to iPhoto come in with lines and missing data similar to your results. iPhoto is definitely corrupting on import.

     

    The evidence is:

    If I email any photo to myself from the phone (even ones that were "damaged" upon import to iPhoto) the images are fine.

    If I upload the photos a second time, the images are usually fine.

    Images are fine when viewed on the phone.

    The images are only damaged some of the time when I upload them into iPhoto. Almost always one or more photos are damaged and not always the same ones. Usually I can get all of the photos if I just upload several at a time. I noticed this when I had about 130 photos and videos on my phone. I thought it had to do with the size of my photo collection (50,000 photos/videos and about 158 Gb of data) so I moved that collection to another computer / disk and I started from scratch - same problem.

     

    I've experimented with trying to make sure nothing else is running on the computer. I haven't checked both USB ports but they work for everything else, including harddrives.

     

    I'm using iPhoto 9.2.1 (628) which is also called iPhoto '11 on OS X 10.6

    I'm using an iPhone 4 with the latest iOS on it.

     

    I've stopped deleting photos on upload so that I can check. It's a hassle, but I don't want to lose any photos.

     

    By the way, I often get a note that some photos are damaged and can't be imported, but if I import them again or email them to myself, they are fine.

     

    To me, it looks like data loss during the import process.

  • kalkalith Level 1 Level 1 (0 points)

    Just to chime in – I'm having the exact same issue, and not just with the photos, but now with video too.

  • Terence Devlin Level 10 Level 10 (128,685 points)

    As a Test:

     

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

  • barrus Level 1 Level 1 (0 points)

    That was one of the tests that I ran. In fact, I assumed that I had a problem because I had over 50,000 photos in my library, but that didn't solve it. I also rebooted and did just about everything that I could think of (as a professional software developer) but couldn't solve the problem that way.

  • Terence Devlin Level 10 Level 10 (128,685 points)

    So the problem recurred in the Test Library?

     

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7)  and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

     

     

    Regards

     

     

    TD

  • barrus Level 1 Level 1 (0 points)

    Yes, the problem occurred in every single test that I did in every library I tried it with. I finally got most of my photos uploaded without error (I had to check them individually to confirm) after uploading several different times with different photos getting errors each time. I just deleted the ones with errors and tried again on those.

     

    I'll try the new account approach next time I have photos to upload and let you know what happens. However, the fact that it happened to several people (not just me) and in several situations and test libraries indicates that this is probably something Apple should be looking into and testing.

     

    The only change I made to this setup was an update to the latest version of iOS. After that, it took me weeks to upload the photos because every time I tried, some photos were bad so I kept putting it off until I had time to work on it for a few hours.

     

    Next time I have photos to uplod to iPhoto, I'll let you know what happens by posting to this forum thread.

     

    John B.

  • anthonyfromoakland Level 1 Level 1 (0 points)

    I am having the same issue - corrupt images, they can be emailed fine (ie not an issue with the iPhone 4).  I almost deleted the images from the phone which would have trashed the photos of the birth of our twins .   This is clearly an issue with iPhoto, which I am done with. 

  • sc0ttdav3y Level 1 Level 1 (5 points)

    Yep, +1 for me too.  Brand new iMac with 2 month old iPhone 4S.  And I deleted photos from the phone after importing before realising there was a problem, so I lost a Christmas video which was really important to me.

     

    For those in a similar situation, check your phone backups - I had an iCloud backup that restored my phone, then Image Capture imported the video fine.

  • -Byron- Level 1 Level 1 (0 points)

    I also have this problem.  The image appears fine on the iPhone, but appears corrupted in iPhoto and in the original image in the iPhoto library.  Has anyone submitted a bug report, or heard anything from Apple?

    IMG_2404.JPG

Previous 1 2 3 Next