Previous 1 2 3 Next 33 Replies Latest reply: Dec 15, 2011 12:26 PM by lschefman
michaelhuisman Level 1 (60 points)

I saved version 2.1.3 in the Applications folder just in case.


v2.2 has loaded twice, the twenty other times I've tried to start it, it hangs... 32-bit or 64-bit doesn't matter.


v9.1.6 of Logic Pro is not having a problem with my setup


strangely, neither is v2.1.3 of MainStage.


I've trashed the prefs, checked the setup in Audio/MIDI setup... all the usual stuff.


Anybody else seeing this?

  • Blueberry Level 4 (2,910 points)

    What MIDI Hardware do you have connected? Some driver issue?

  • michaelhuisman Level 1 (60 points)

    MIDI hardware.


    yeah... was following that one myself... down to a Yamaha Motif ES8, over USB (found a 64-bit driver so just updated that - saw that the MIDI Server process was restarting in 32 bit mode - that's resolved, was never a problem by the way, but no change).


    I have a Focusrite LiquidMix 56, it "adds" a MIDI in/out, that it runs over the FireWire connect. gotta have my audio interface... so can't let go of that...


    There's a MOTU ATP AV - whether it's on or off doesn't make a difference.


    There's a Behringer BCF2000, which is supported, doesn't make a diff if it's on or off (I reboot in between)


    and then... there's a Novation ZeRO SL Mk II... this thing was my 1st most likely choice, but it doesn't seem to be the prob either... so... but whether it is on or off, or that really messy AutoMap is running or not... no change.


    MS v2.2 MIDI architecture is likely changed, as you can now assign directly from hw to some-mapping w/o having to go through screen objects first (from the release notes - I never got that far). But *what* did they change??? Really hard to nail this down, if the previous version still works, the *new* version of Logic works, Live works, anything that reads MIDI works (NI apps vs. plugs, Ivory Standalone, you name it).

  • Blueberry Level 4 (2,910 points)

    Did  you figure out which device/driver triggered that issue?


    Regarding MS 2.2: The table view for all active mappings (concert/set/patch level) is brand new. It also allows you to create a mapping/assignment without a screel control, which is what you ask for: control a plugin parameter without going through screen objects first.

  • michaelhuisman Level 1 (60 points)

    not yet... haven't figured out which input is causing this.


    as for that table view... it's not that I asked for this... I think it's *interesting* and likely better in terms of resources... it seems like a good idea.... I'm actually still trying to get that far :-)


    my issues have been manifesting itself on my main studio machine (not the live rig). that's an 8 core MacPro. I could see (briefly) the two times that MS actually ran (which makes me wonder why it otherwise won't...) that multiple cores were in use, but I really want to see if my live rig, which is a 17" MBP from the summer of 2009, if two cores can/will be used better than they have been to date. Have held off on updating this machine because the usage of cores wasn't great anyway... perhaps now I'll make the jump.


    at any rate... installed version 2.2 on the laptop (no midi devices, no audio interface) and here MS v2.2 starts up fine.




    back to the mac pro, and I guess I'll start with nothing, add devices one by one and see what happens.


    again, I just wish I knew what has changed whereby the situation no longer matches up with what v2.2 is expecting.... because *everything* else works just fine...

  • aerol Level 3 (525 points)

    When you say you 'saved version 2.1.3' what do you mean.. or maybe, how did you save it?  Reason I ask this is that it seems that the App Store install will seek and update the app not by using the app name (as in the past when if you renamed the app it couldn't be found by the updater). So I'm just wondering if something happened during the upgrade process on the Mac Pro.

  • michaelhuisman Level 1 (60 points)

    Hi. In the finder I just duplicated Mainstage, which leaves the original in place, as-is. The copy got renamed to MainStage 2.1.3, then I did the app store install.

  • michaelhuisman Level 1 (60 points)

    been on this ALL day. no repeatable success unless there are NO MIDI devices at all.


    Monitoring the console indicated that the USB MIDI driver for my Yamaha ES8 wasn't 64-bit, so I updated that.


    There are no differences in console messages during startup of MainStage with the following exception:


    during v2.2 startup it immediately posts two messages


    16:26:08 [0x0-0x80080]   MTEngine

    16:26:08 [0x0-0x80080] MTEngine>


    I don't know what this is, but v2.1.3 doesn't post these messages on the console.




    OS X seems to recognize that the process has hung as it posts this message on the console and creates a logfile


    16:37:22 spindump:

    Saved hang report for MainStage version 2.2. (419.23) to /Library/Logs/DiagnosticReports/MainStage followed by a timestamp, then the name of this machine ".hang"


    To say that I'm flabbergasted by this is an understatement.


    I thought to give reinstallation a thought, so I deleted v2.2 of the app, also removed it from the Launchpad (I never use this, it's just that the App Store installs here).


    Then it got even weirder... unlike the iOS app store, the Mac app store app insisted that MainStage was already installed on this machine, and offered no way of reinstalling...


    I restored v2.2 then from my nightly clone of the startup disk.


    Should there be someone who can read the "spindump" I'd be happy to post... but I'm truly not a happy camper at the moment.

  • Blueberry Level 4 (2,910 points)

    Try contacting Apple via - you should attach the spindump to it.

  • michaelhuisman Level 1 (60 points)

    Thanks Blueberry..., really...


    no way to attach a dumpfile to on that site... if I throw the contents of the dump into the text, the website kicks my feedback response out with an error.


    I'm a little tweaked at the MainStage team today.


    All I really wanted was the EVB3 sustain pedal fix that they released in Logic months ago... that I had to *pay* for that... okay... not chique, but whatever. 


    that I paid for this and it won't even start up???


    that's just plain bad...


    I've lead technology projects of all kinds for a long time... my question is simply "Who tested this?"

  • Blueberry Level 4 (2,910 points)

    I totally get your frustration, but you seem to be the only one with a hang at launch while initializing MIDI, so there must be something special to your setup. The trick is to find out what! Can you post the spindump here and reference to it in the feedback - I am sure the Apple guys will find it that way, too.

  • Bobfrompowell Level 1 (10 points)

    I'm having the same problem. if my midi interface is turned off, Mainstage comes up ok. With the midi interface turned on the initialization hangs. Everything worked fine before the "update."

  • Blueberry Level 4 (2,910 points)

    What MIDI interface do you have?

  • Bobfrompowell Level 1 (10 points)

    I have a Midisport 8X8/s. it worked with Mainstage 2.1, and still works with Logic. Thanks

  • aerol Level 3 (525 points)

    If you have Console app launched (Applications/Utlities) when you launch Mainstage does anything about MIDI get printed in there?

Previous 1 2 3 Next