Previous 1 2 3 Next 177 Replies Latest reply: Sep 3, 2012 12:42 PM by Sofiakhan
mwiesner Level 1 (0 points)

iPhone 3GS.

 

Whenever I go into a specific app in the app store, none of the buttons work properly.

 

1) clicking on the price no longer downloads the app,

2) the ratings button does nothing,

3) the 'tell a friend' and 'git this app' buttons jump back to the top of the app window,

4) pictures usually don't show up.  They usually appear as five gray rectangular boxes with white borders (though in one app one too-large-for-the-window picture shows up (see pic),

5) the 'app support' button still goes to the developer's website.

6) the 'top in-app purchases' banner is just text now.

 

Has anyone experienced this?

 

photo(38).jpg


iPhone 3GS, iOS 3.1.3
  • fasih Level 1 (0 points)

    dude I too have the same problem plz let me know if u get any solution

  • mwiesner Level 1 (0 points)

    When did your problem start? My problem started yesterday, a few hours after I updated some apps (not sure if they're related; I didn't try to shop immediately before/after updating).

  • Thom_D Level 4 (1,120 points)

    Have you tried shutting down the apps running in the background or restarting your phone? If you have too many apps sitting in the background you may not have enough memory to display all the App Store Buttons.

     

    Shut down all multitasking apps

    1. Double press the home button to display the multitasking drawer

    2. Tap and hold any app icon until it wiggles and displays the x button overlay

    3. Tap the x buttons to shut all the apps in the drawer down

    4. Press the home button to close the drawer

     

    Reset / Restart the Phone

    1.  Press and hold BOTH the Power and Home buttons at the same time

    2. Wait for the Slide to Shut Down screen to appear AND disappear

    3. Continue holding both buttons down until the silver apple logo appears

    4. Release both buttons and wait for the phone to restart

     

    Check out the App Store and see if the problem has cleared up.

     

    Hope this helps.

  • Thom_D Level 4 (1,120 points)

    @ mwiesner - Which apps did you purchase? Maybe they are to blame?

  • fasih Level 1 (0 points)

    Last night I downloaded Real Football and Real Tennis simultaneously and paused for some reason and again started both downloads and today afternoon when I tried downloading another app I couldn't

  • mwiesner Level 1 (0 points)

    @ Thom_D: Hey there, thank you for the advice.  Unfortunately my iOS predates the multitasking menu.  However, I deleted a bunch of apps that could be taking up memory (Facebook, Yelp, LinkedIn, Groupon).  Then I performed the two-button reset as directed.  Unfortunately, it did not solve the problem.

     

    @ fasih:  Interesting — my problem started last night as well. What iOS version are you running?

  • jimmcknew Level 1 (0 points)

    Same issues, iPhone 4s.  Currently have 7 apps awaiting download.  Also tried Thom_D advice with no joy.

     

                                       ???

  • fasih Level 1 (0 points)

    same 3.1.3

  • fasih Level 1 (0 points)

    buddy if u are downloading from wifi just switch off and on the phone, it will automatically ask for your A/c password and download will start again

  • AJSivesind Level 1 (0 points)

    I have the same problem on my generation 1 iPod touch, 3.1.3 (7E18)

  • lilianafrommelrose park Level 1 (0 points)

    hello i just got an iphone and same thing is happening to mine did you get your to work... i called apple store but they have no idea how to fix it need help

  • jimmcknew Level 1 (0 points)

    My problem spontaneously resolved itself around noon, pst.  Must have been something at Apple's end.

  • 123bertie Level 1 (0 points)

    Same thing & still not working for me.....

  • mwiesner Level 1 (0 points)

    @ lilianafrommelrose park: I did not find a solution; the problem persists.  I'll post again if/when it resolves... Please do the same.

Previous 1 2 3 Next