Skip navigation

App download buttons not working.

69514 Views 177 Replies Latest reply: Sep 3, 2012 12:42 PM by Sofiakhan RSS
  • mr.interested Calculating status...
    Currently Being Moderated
    Dec 16, 2011 5:06 PM (in response to mwiesner)

    I have the EXACT same problem, and it also started TODAY.

    I had no problems downloading apps on my iphone through the appstore a few days ago.

    The last app i downloaded was mirrors edge a couple of days ago when it was free.

     

    I have a first gen iphone with OS 3.1.3 ( last available OS for my phone).

     

    I have tried powering it off and back on several times.

     

    I have logged in and out of my apple account within settings, and within the appstore itself

     

    A few extra notes:

     

    App updates through the appstore on my phone still works, i can click on update all and it then updates them.

    I updated a couple of apps this morning ( Battery Doctor,Gamefly ).

    As of a few minutes ago there is now a new app (Airmiles) waiting to be updated, but i held off on updating it.

    So it looks like updating apps through the appstore on my iphone still works, but i cannot download any other new apps.

     

    Conncting to my PC and itunes i can sync my iphone and it pushes apps to my PC.

     

    I can download apps on my PC and push them to my iphone.

     

    I have plenty of free space and icon positions/pages for more apps on my phone.

     

    Its just the appstore on my iphone that NO-Longer works!

     

    The only thing i have not tried yet ( and i dont want to do ) is a factory reset.

     

    This is starting to look like some kind of appstore problem.

     

    I would really like a solution to this problem.

     

    PS. im from Canada, ( in case its only a Canada Appstore problem )

  • ligera_ Calculating status...
    Currently Being Moderated
    Dec 16, 2011 7:21 PM (in response to mwiesner)

    Same problem here, with 1st gen iPhone running 3.1.2; with a couple extra notes.

    The apps I already have usually have a grayed-out "Installed" button at the top of the infopage, but now the "Buy" logo is showing there.

    Also, for about the past week, I've had issues when I use the "Featured" icon on the bottom bar. There used to be 3 tabs at the top for Genius, Hot, & something else; those are gone now. The Sign In/Out & Redeem buttons at the bottom don't work. Until today, when I selected any of the featured apps, I just got a page of programming language; but now it does take me to the app description.

    This looks like Apple updated something and forgot to make it work on the older systems.

  • amandafromsalford Calculating status...
    Currently Being Moderated
    Dec 16, 2011 10:56 PM (in response to mwiesner)

    Exactly the same problem here on my first gen 'perfectly good working order' iPod ios 3.1.3.

  • Yapperhound Calculating status...
    Currently Being Moderated
    Dec 17, 2011 12:10 AM (in response to mwiesner)

    Same thing on UK first gen iPhone, started yesterday. Version 3.1.3 7E18

  • AJSivesind Calculating status...
    Currently Being Moderated
    Dec 17, 2011 1:18 AM (in response to mwiesner)

    I think it's that Appstore is no longer compatible with the iOS 3.1.3 cus everyone that has this problem has this version of the OS and I'm in Norway so it can't be location specific, it's that update that has made it incompatible. Now we just have to wait for Apple to fix that problem... I hope they do fix it...

  • cmr&xpg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 2:06 AM (in response to mwiesner)

    Hi,

    Just to tell you all that I'm using a 3G under 3.1.3, can't update it because of my company rules, and App Store is a broken link for me too (same issues as described before). I'm in France.

    In fact, with iOS 3.1.3, the "update" button is not working anymore for a while now (About 1 year) and until two days ago I was obliged to go to the app itself to dowload it or update from iTune on the mac. Now all is down!

     

    I hope apple will sort out this issue in respect of everybody and clients, since it would be a really big frustation to be obliged to buy a new machine etc....

    In the past, Apple was always supporting old versions for a while. (I have been running a Quadra for 12 years, and I developped an application which has been available from System 3 to Tiger, without any action into the original code! Leopard was the begening of non compliancy policy in Apple)

     

    We would not appreciate to see this firm going on sad market like its main concurrent.

    If so, we could go on full open source...!!!

     

    Thank to apple for figuring this problem out quickly.

  • giggsuk Calculating status...
    Currently Being Moderated
    Dec 17, 2011 3:40 AM (in response to mwiesner)

    I've also lost my update now button on my app store on my iPhone. I have an iPhone 4 with the most up to date OS. However I turned my phone off and back on and lo and behold everything's working fine again!!

  • Tissot_v8 Calculating status...
    Currently Being Moderated
    Dec 17, 2011 5:06 AM (in response to mr.interested)

    @mr.interested: i have done the factory reset, but it does not work until now.

     

    Where is now the problem? :-/

  • Tissot_v8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 5:07 AM (in response to Tissot_v8)

    I'm in Germany.

  • AJSivesind Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 5:08 AM (in response to Tissot_v8)

    Tissot_v8 wrote:

     

    @mr.interested: i have done the factory reset, but it does not work until now.

     

    Where is now the problem? :-/

    I believe it's in the update to Apple, it has made the Appstore incompatible to the 3.1.3 iOS, so we just have to wait until they release an update which solves it i guess...

  • cmr&xpg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 10:46 AM (in response to AJSivesind)

    Thanks for his advice.

    I did reboot my poor  but friendly old iPhone 3G running 3.1.3 (but less than 2 Y. old) with many hopes. But noway, it is still not working.

    We should all preach to get Apple figuring this out very quickly.

  • lilianafrommelrose park Calculating status...
    Currently Being Moderated
    Dec 17, 2011 1:20 PM (in response to mwiesner)

    any luck with the app store i need help just got the iphone and im bot able to enjoy it at all with this problem....

  • lyndel4 Calculating status...
    Currently Being Moderated
    Dec 17, 2011 1:56 PM (in response to lilianafrommelrose park)

    Yes I too am having this problem and it only affects devices running 3.1.3, iphone 3g and ipod touch 2g users can easyly avoid this problem by just updating but us with our iphone 2g and ipod touch 1g can not we will have to wait for a fix but this is strenge coming from apple I do not think this is apple way of getting us to upgrade and apple could be losing out on alot of money right now becosue people cant buy apps from the appstore and i dont wana belive that there finaly droping support for our older devices on the store becosue this is nothing like them, and am sure they would of test the store to see if it will work on other devices ater the update but i hope apple sees this and fixes it started happening for me since yesterday restored my device and problem still there

     

    Message was edited by: lyndel4

1 2 3 4 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.