Previous 1 2 Next 19 Replies Latest reply: Feb 28, 2013 12:12 AM by Razor Toshiba
Elvinalfie Level 1 Level 1 (10 points)

Good morning all, I just want to add my voice to the carcophony with regards iTunes Home Sharing setup to my iPad and my new ATV2.


This past weekend we bought a new ATV2 to go with the new TV. Got home, unboxed it all and plugged it all in. It all set up seemlessly, both the new TV and the ATV2 found the wireless connection, password accepted which allowed us to successfully connect to Netflix and YouTube. After playing around for a while with the new toys I decided to try and setup Home Sharing. I followed the instructions: turn on Home Sharing in iTunes, then do the same on the reset of your devices using the same user name and password. Check. Only, not "check" because it doesn't work.


I've been floating around these forums for a few days now trying to troubleshoot and find the issue. I have triple checked login information on all the devices. I have "reset" the ATV2 to no avail, all it did was get me back to the point of being able to use Netflix, YouTube, Radio / Music, and AirPlay. Last night I played around with the Windows Firewall thing in the XP control panel, adding the port numbers from one of the other posts. Nope. I change the wireless router setting to the correct WPA setting that's also floating around. Nada. I restarted the wireless router. Nothing.


I guess tonight I will log out of EVERYTHING, reset everything and then reboot everything. However, I'm expecting the same underwhelming results.


Even my husbands computer won't show up in Home Sharing, and both desktops are hardwired to the moderm/router thing.


I'm SO used to Apple's "plug and play" beauty that this is getting frustrating, I've NEVER had to work so hard to get one of their products to work.


So to summerize, I've tried a bunch of stuff without success. Netflix, YouTube and the Radio / Music functions work without a problem. I can push content to the ATV2 using AirPlay. However, I can't get Home Sharing to work, and I can't seem to buy stuff through iTunes on the ATV2.


What else can I try?





Your average, non-technical, home user.


Message was edited by: Elvinalfie for bad spelling.

AppleTV 2
  • GFromAt Level 1 Level 1 (0 points)

    I'm having exactly the same problem as you describe (home sharing to a new Apple TV, except I'm on a Mac running iTunes 10.5.2).  After trying for hours to adjust firewall settings, update the software on the Apple TV, turn home sharing off and on again, and restart my router, I decided to try turning on my wife's old laptop running an older version of iTunes 10.2.2.  As soon as I enabled home sharing on this old laptop, it popped up on the Apple TV.


    My conclusion: this has nothing to do with the Apple TV (or the network).  It's a problem with home sharing in the latest version of iTunes, and I have not found a solution. (Are you also running the latest version of iTunes?)

  • Elvinalfie Level 1 Level 1 (10 points)

    Yes, I am running the latest version of iTunes. I updated it from 10.5.1 last night as part of my troubleshooting.


    I've never tried to set up Home Sharing before this weekend, so I have no idea if it worked prior to the shift to 10.5.


    I have a VERY old iBook laptop sitting around at home, I wonder if that would work. Although I'm not sure it ever had iTunes loaded onto it because it pre-dates that shift in technology. It doesn't even have wifi capability, that's how old it is.

  • brucethecanuck Level 1 Level 1 (0 points)

    Good Qestion.


    Apple user since '95. Very familiar with ins and outs. Have 2 atv's,1 imac and 1 powerbook.  There is no way I can get homesharing to connect to music or video libraries. Paid internet content not a problem-figures. I have tried all standard troubleshooting and still nothing. I am at a loss as to next step except to complain directly to Apple.

  • ckuan Level 7 Level 7 (27,125 points)

    A few things you can try.

  • Dangerbird Level 1 Level 1 (0 points)

    I've had the ATV2 for a few months now and it worked perfectly fine up until this latest itunes update.  I have a user account and my wife has a user account on our iMac and we both home share our itunes libraries which worked perfectly... now only one of us can connect.. it's like one or the other.  I made an appointment for apple to call me tomorrow.  I'll try to remember to post the outcome.

  • Elvinalfie Level 1 Level 1 (10 points)

    I have more information:

    Yesterday I noticed that my wireless sync to my iPad hasn't been working so I hooked it up to the computer and assumed that I just hadn't clicked "apply" when I did the updates a while back. No luck, when I unhook it the "sync now" button greys out and it disappears from my iTunes Devices list. It all works fine if its connected to the computer but won't do anything if its not.


    My hubby got a new Xbox game yesterday and tried to download an update for it from Xbox Live (which we don't generally use) which just wouldn't work, it would just get to a point and stop. I then also noticed that my Chrome browser hasn't been automatically updating like it should, and this morning I remembered that when I tried to update iTunes from within the program the other day it wouldn't let me, so I had to download it directly from the Apple site. The download wouldn't appear in Chrome so I had to open up IE (YUCK!) to get at it.


    All this leads me to believe that it HAS to be a router issue. Is that a fair conclusion?


    My router is a Belkin 43A1 and up until this point its been on its default settings with an IP address of I don't even know where to begin looking to try and fix this conflict that might be happening. Any suggestions for me?


    Oh, and by the way, all these devices can use the internet just fine. Its when I start trying to sync over the network that they appear to have issues.

  • Elvinalfie Level 1 Level 1 (10 points)

    Thanks ckuan, I'll try those things.

  • Elvinalfie Level 1 Level 1 (10 points)

    Well, this evening I've updated the firmware, and also noticed that the correct time zone needed to be entered into the router settings. After doing that, iOS5 wireless sync has started working.


    Still trying to get Home Sharing to work though.

  • Elvinalfie Level 1 Level 1 (10 points)

    Oh snap, I think I've got it all working.


    Although, in the left iTunes column I only get "DEVICES" with it showing my iPad. It doesn't seem to bring up the "SHARED" heading?

  • ckuan Level 7 Level 7 (27,125 points)

    Some say to switch off wireless sync in iTunes (With your iPad connected and selected) Summary page.

    Can you confirm that as a test for your Home Sharing?

  • bryguy76 Level 1 Level 1 (0 points)

    I've had tonnes of problems with this.

    It turns out, I had my Windows Firewall settings set up as if I was a public network, and it would cause tonnes of connectivity problems (only with my Apple TV).  I had set up all of the reccomended settings for I/O ports and so on with relatively no success.


    When I turned off the Public Networks firewall, everything began to work fine.

  • Leduromax Level 1 Level 1 (0 points)

    This morning, no home sharing on my apple tv3....Again! Also no remote (iPad or iPhone) working. Went to my iMac, clicked on my external drive seagate on which my iTunes library is located in order to get the hard drive out of sleep mode. Shazam !!! Instantly remote is working on both iphone and iPad....However, even though Ican access my library and play anything on the iMac, I CANNOT play it on the apple TV3. That confirms I might have 2 problems the **** seagate drive going to sleep and preventing remote app to work and...the other problem beeing the one we are all unable to solve, including APPLE, as to the disfunctionnal homesharing.


    Please apple and everyone else stop talking about routers, channels, wifi or other non firmware related issues. Our networks, are fine, the channels (especially odd channels like 5  or 8) will do nothing but increase interferences. My former apple tv was working perfectly fine as fine as all many other devices I use on my wifi. I have no firewall, no antiviruses by the way.



  • Lewis.Hooper Level 1 Level 1 (0 points)

    Home sharing problems

    I have had ongoing problems with Home sharing and given that there were lots of posts I  had to sift through before finding what works I thought I would share what seems to have

    solved my problem. This path was developed over a period of time and I am not reporting on

    steps/suggestions that seemed to have no impact.

    I have a windows based network with several pc's and IPod/ipad/and apple tvs

    1) setup one computer as your itunes station by deauthorizing any other computers. 

    (IPADS/IPODS/Apple Tv's are ok you can leave them alone)

    The rest is network/router issues.


    2) Check your wireless access points carefully.  My wireless devices

    (ipod/ipad apple tv)  work best when hooked to an apple airport wireless.   They do not

    work when connected to another wireless ap on my network.( I may troubleshoot and solve

    that problem but not yet)


    3) the final step was the Router.  Mine is a dlink 825 and the final step was enabling

    multicasting.  (For DLINK 825 sign in  click the  advanced menu at the top  then advanced networking on the left side and multicast is at the bottom of the page. click enable)


    I did not open ports as others have suggested as that seemed to be madness.


    This worked for me. And I hope its some help to the others who struggle with this. 


    Bottom Line. 1) Only one PC with ITUNES to start with and deauthorize other pC's, 2)go with

    an apple wireless as a wireless point if you can. 3) Make sure your router is setup for



    I have now switched Itunes to my WHS 2011 server with Ihomeserver, which gives me the

    benefit of having Itunes always on.  which was another problem with home sharing it seems

    to work only when the host computer is on and Itunes is running.

  • Bobdope2002 Level 1 Level 1 (0 points)

    hi bud!


    Kinda stumped here with this damned thing

    Basically me mates dad has just phoned me to go and have a ganders at it.............Im trying my damned hardest to get it to connect via a network to his pc so he can play his music through it

    i tried running it through his Talktalk Internet hub thingy ma jig which worked then disconnected and wouldnt connect again (wired)

    I then set it up directly to his ethernet port on his PC which 110% didnt work

    I tried setting up a network on the wizard thing which didnt work either

    Could it be that he is running XP still????


    I got angry with it and had to leave it


Previous 1 2 Next