Previous 1 2 Next 19 Replies Latest reply: Jan 3, 2012 5:12 AM by Linc Davis
daffApple Level 1 Level 1 (0 points)

Hi Everyone,

 

I have bought a Mac mini with  Mac OS X 10.7.2. I am trying to install Xcode 4.2.1 on it through App store but the process stops as soon as it started with a message: "The Application cannot be downloaded The application you tried to download could not be downloaded. Check your internet connection and try again."


It's happening since saturday, so it's not a temporary problem as i initially thought.

 

Please help me with this.

 

Thanks in Advance.


Mac mini, Mac OS X (10.7.2), MODEL NO. A1347
  • softwater Level 5 Level 5 (5,370 points)

    Have you tried downloading anything else from the App store since this occurred? Just pick any free app and see if it will download.

     

    It sounds like your mac is new, so I'm assuming that there's more than 4GB free space on the disk, of course?

  • Linc Davis Level 10 Level 10 (153,450 points)

    Launch the Console application by entering the first few letters of its name into a Spotlight search. Select "/var/log/install.log" from the file list. Post the messages from the last installation attempt, beginning with "PackageKit: ----- Begin install -----". Post the log text, please, not a screenshot. Edit out excessive repeats, if any.

  • daffApple Level 1 Level 1 (0 points)

    @softwater:
    Thanks for the reply, I just tried another free app. and same error again. what do you suggest I should do now?

  • softwater Level 5 Level 5 (5,370 points)

    Are the date and time settings on your new Mac mini set up correctly for your region? This can cause problems if not.

     

    If yes, try signing out and signing back in to the App store again. In the App Store menubar, choose 'Store > Sign Out'.

     

    There's some support articles here, but I couldn't find one that was exactly the same as your issue from a quick scan.

     

    http://www.apple.com/support/mac/app-store/troubleshooting/

  • daffApple Level 1 Level 1 (0 points)

    Thanks for the reply. I have no Log in the install.log after Dec 30 11:50:02 but I have tried atleast  25 times this morning itself. Some thing wrong here?

  • softwater Level 5 Level 5 (5,370 points)

    There's no point looking in the installer log. Nothing has been downloaded to install.

  • daffApple Level 1 Level 1 (0 points)

    Date & time = OK

    Sign Out and Sign In = Done

     

    Still the same. Thanks for the link, will try finding in it and let you know here.

  • daffApple Level 1 Level 1 (0 points)

    Hmmm.

    You are actually right!
    So, what should be my next step with this?

  • softwater Level 5 Level 5 (5,370 points)

    OK, you'll have to role your sleeves up a bit.   The App Store has a 'secret' debug menu which will allow you to reset it (you can also do a few other things here, but don't mess about any more than you have to!).

     

    First thing is to enable the debug menu.

     

    1. Quit App store

     

    2. Open Terminal. Paste this command into the Terminal window (don't select any space before or after the command)

     

    defaults write com.apple.appstore ShowDebugMenu -bool true

     

    Press 'Return'.

     

    3. Open the App Store. Choose 'Debug > Reset Application' from the menu bar.

     

    See if that helps.

     

    NOTE: you can remove the debug menu with the same Terminal command as above but replace 'true' with 'false'

  • daffApple Level 1 Level 1 (0 points)

    NO its the same . It stopped as soon as it started.

    This is really annoying!

    I have seen other threads where they mention the same issue after a part of it has been downloaded, but my stops right in the starting (maybe even before that).

  • softwater Level 5 Level 5 (5,370 points)

    OK, I'm running out of ideas. I've got two left!

     

    1. Be careful with this. In the 'Debug' menu again, click on

     

    Show Download folder...*

     

    Click 'command-i' on your keyboard to open the 'Get Info' window. Look at the permissions at the bottom. They should be 'read & write' for your computer, and 'read' and 'read' for the other two. If the first one is 'read' only, that would stop any downloads. If so, change it (post back here for instructions if you don't know how to do that).

     

    I wouldn't recommend messing with anything else in the Downloads folder, as I'm not sure what it might do, so if the permissions are OK just exit.

     

    The second option's not very satisfying I'm afraid, but short of someone else joining in with any better ideas, go

     

    2. Contact App Store support

     

    http://www.apple.com/support/mac/app-store/applications/

     

    (*Note: this is the App store download folder, not your ordinary dowload folder. You can only get to it through the debug menu.)

     

     

     

    Message was edited by: softwater » added note

  • daffApple Level 1 Level 1 (0 points)

    K. Here's how it looks, it has two Names (must be users):
    My user has Read & Write privilege but "everyone" has No Access.

  • softwater Level 5 Level 5 (5,370 points)

    Hmm, mine look like this

     

    appstorerights.png

     

    but I'm not knowledgeable enough to say whether yours are wrong and mine are 'right'.

     

    You could IF you have a backup of your system, try changing 'everyone' to 'read only' and seeing if that helps, but I'm not sure why it would — and if it doesn't, immediately change it back or you might just be making more problems than you have already.

     

    Now, before you do that or anything else, I've realised we've forgotten the first rule of computer troubleshooting: have you tried restarting your whole system? Please do so now. It's amazing how many problems a simple restart will cure.

  • daffApple Level 1 Level 1 (0 points)

    Looks like I am in a war here against my Mac! it's not ready to surrender for anything I do!!

Previous 1 2 Next