7 Replies Latest reply: Mar 4, 2013 3:39 AM by Dweebnik
stestardi Level 1 (0 points)

There are dozens of reports on this bug on the forums, and not one of the suggestions worked for me.  After reading slocks post at https://discussions.apple.com/message/17157627#17157627, I noticed that iTunes did indeed back up different apps each time I quit, restarted, and re-attempted sync, and that it always failed on the same one (USA Today in my case).  I deleted USA Today from my phone, quit and restarted iTunes, and synced again.  iTunes reinstalledUSA Today for some reason, but the sync completed then successfully, and all subsequent syncs also complete successfully.  I then noticed that the App Store was promptimg me to update USA Today, which I did fully expecting that the update would cause the problem to recurr, but it did not.  So it appears a corrupt app is causing this problem, and deleting the app from your phone may resolve it.

 

If you are getting this error, my suggestion is to watch during the sync, and note which application is being copied when the sync fails.  Delete that app from your iPhone, and try to sync again.  Please post the results here.  Thanks!

  • westsidegirly Level 1 (0 points)

    For me app wasn't the problem, the problem was the app needed updating.  I updated all in my iPhone, but that wasn't doing it.  I followed what someone else did and updated my apps "in iTunes" and it was perfect!

     

     

     

    Confirmed!

     

    I was getting the same error message. After reading your post, I updated all my apps in iTunes. Sync worked as normal after that. Now we'll have to see if this happens again when other apps are updated.

     

  • markymark8 Level 1 (15 points)

    I found a variety of solutions posted here. They helped me fix this error that was coming up on my iPhone a few days ago. Hope this helps!

  • cherber12 Level 1 (0 points)

    I had the same problem.  Then I noticed it kept crashing on Yelp.   I deleted it from the phone, then restarted the phone and iTunes, and the sync worked fine!

  • MGKCNM Level 1 (0 points)

    What worked for me was to go to iTunes on my computer and sync all my apps.  After that when I tried to sync my phone it worked.  Finally.  Restarting both phone and computer did NOT work.  iPhone 3g with most up to date version.

  • leehaoyong Level 1 (0 points)

    I encountered the same problem but I have solved it.

     

    I was upgrading my iPhone from the iPhone 4 to the iPhone 5 and I had synced everything else, music, pictures, contacts and settings but my apps would not sync.

     

    Here are the things you have to make sure is done.

     

    Transfer all purchase from your old phone to your PC.

     

    Do the restore for all the other items from the old backup.

     

    Now, in your new phone or the phone you want to copy the data to, go to the Apps tab and check, Sync Apps.

     

    From there, you can select the apps that is already stored in your computer and manually check them.

     

    All the previous notes, games and settings will be exactly the same as what you had.

  • 1luckyman Level 1 (0 points)

    bad link

  • Dweebnik Level 1 (0 points)

    I had this problem and noticed I had an app open waiting for me to enter some date (email address).  When I closed this app the reconnected the sync worked.  So there you are: check for any apps waiting for input!