Previous 1 2 Next 25 Replies Latest reply: Aug 28, 2012 11:29 PM by dpbakker
edpurves Level 1 Level 1 (0 points)

My MacBook Pro is not sleeping as set in the energy saver preferences. It will sleep the display but something's keeping it awake. It sleeps fine when the lid is closed but it's impractical to keep flipping it up and down... Every once in a blue moon it does sleep and I marvel at how and why but the other 99% of the time, it's got amnesia.

 

Any ideas??

 

Thanks


15" MBP i7 Hi-res, Mac OS X (10.6.5)
  • Carolyn Samit Level 10 Level 10 (95,975 points)

    Try Resetting the System Management Controller (SMC)

     

     

    Mac OS X (10.6.5)   <  your profile

     

    If that is correct, there are updates available from your Apple menu > Software Update...

  • edpurves Level 1 Level 1 (0 points)

    I gave that a try and it the LED on the MagSafe power adapter gave a flash to confirm, unfortunately that hasn't resolved it.

     

    I think it might be a application running in the background... Any ideas how I could identify which one?

     

    Thanks

     

     

    __________________________________

     

    I've got 10.7.2 installed at the mo, I'll update my info

  • Dave Stowe Level 5 Level 5 (5,080 points)

    Try booting into (Safe Mode).....that would disable any third party apps that might be running in the background....

    support.apple.com/kb/ht1455

     

    ....from there you would just have to experiment to figure out which one might be the culprit......

     

    ....also go to System Preferences > Energy Saver > Wake for Network Access....see if the box is checked....if so remove the check....

  • pereclies Level 1 Level 1 (0 points)

    hey Dave Stowe, I was having the same problem, it turned out to be the network, just like you said, so thanks

  • edpurves Level 1 Level 1 (0 points)

    Hi Dave, the other reply promted me to have a go with trying out your suggestion as I didn't get round to it when I first saw it and forgot so sorry for the delay!

     

    Turns out it's still not sleeping on safe mode either! And Network Access is definitely off...

     

    I'll have another go to see if there's something running in the background...

     

    Thanks, Ed

  • pereclies Level 1 Level 1 (0 points)

    May also want to not only check that "wake... network access" is deselected, but also that internet sharing is turned off. I had both on for mine.

  • IanB Level 4 Level 4 (1,370 points)

    I had this problem with a MacBook but only when connected to power.  Turned out that there were printers with sharing enabled.  Unchecking that solved the problem.

     

    This might not apply to your situation but I thought it worth mentioning.

  • edpurves Level 1 Level 1 (0 points)

    Thanks for the suggestions guys. Had a look but they're all unchecked already...

  • LoRob Level 1 Level 1 (10 points)

    For me it was definitely a print item stuck in the print queue. Open Print & Scan in system preferences, select any printer(s) with a red or yellow badge, and then click the "Open Print Queue" button to show the print jobs and delete any that have not completed.  Seems too darned simple to work but it did.

  • Dale Weisshaar Level 6 Level 6 (15,855 points)

    This is for a Mac that won't sleep.

    Here is Apple's  KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file. If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password). If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Some have resolved sleep issue by downloading the  Combo update, from this site (yours may be corrupt), not Software Update  disconnect all firewire + USB devices except keyboard + mouse,Repair Permissions, re-install update, Repair Permissions again + try

    USER TIPS……..

    Check in System Preferences > Energy Saver is "Wake for network access" checked? If so, uncheck it.

    One user reported, " I couldn't make my macbook pro to go to sleep because I had my wireless headphone receiver still plugged in. I unplugged it and then it went to sleep."

    Also, if you have an External Western Digital (WD) hard drive and have installed  WDDMService and WDSmartWareD on your Mac, it may not sleep. Fix is to un-install those....you don't need them to use the drive.

    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    One provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute. After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    "I  have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps. Check the printer queue!"

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE

  • edpurves Level 1 Level 1 (0 points)

    Hi Dale,

     

    Thankyou for a very extensive and thorough answer!

     

    I went straight for the PleaseSleep App and that seems to have worked a treat. I'll trying and explore the other options you've suggested. I have an Epson printer. Nothing in the print queue and it's not always connected, so I don't think that's it.

     

    I currently have a fair few things connected but have the problem even when it's just the Mac on it's own out and about...

     

    Incredibly, it just slept on it's own, right in front of me the other day, almost as if to wind me up but when I woke it, it didn't do it again!

     

    I think it's deep rooted as it didn't sleep on safe mode as far as I'm aware. Deleting the plist files might be best. Does the Mac automatically replace these or whatever it needs to do? It's not a realm I'm clued up on so I don't want to do anything detremental.

     

    Anyhow I'll keep you posted if I nail it.

     

    Many thanks.

     

    Ed

  • edpurves Level 1 Level 1 (0 points)

    Thanks for the suggestion LoRob,

     

    Unfortunately the queue's clean as a whistle tho. This PleaseSleep app has given me a watertight solution in the meantime!

     

    Thanks,

     

    Ed

  • grblade Level 1 Level 1 (0 points)

    I tried everything to get my MacBook to sleep. Nothing worked until I cleared my print queue. Now it works fine! Thank you!

  • Dale Weisshaar Level 6 Level 6 (15,855 points)

    You are welcome!

Previous 1 2 Next