Previous 1 2 3 4 Next 367 Replies Latest reply: Nov 13, 2014 9:44 PM by orchetect Go to original post Branched to a new discussion.
  • thinkdfrnt Level 1 Level 1 (0 points)

    Thanks Mac OS XP but I believe we're having the same glitch, mine may have just happened during a different event.

    The IMDb app works fine but I still receive the error message "Unable to purchase..." whenever I download a new app or update an old one.

  • Getslow Level 1 Level 1 (0 points)

    Hi all,

     

    I've bookmarked this thread since I experienced the same problem, so I could check back later for possible solutions. But since today the problem was suddenly solved. I don't know which of the following steps actually solved the problem, but this is what I did:

     

    1) Start iTunes and go to your apps

    2) Download all the updates to your Mac/Pc

    3) Connect your iPhone to your Mac/Pc

    4) Go to the 'apps' tab of your device, and select an app which you've just updated to synchronise with your iPhone (I don't know if this is necessary, but this is what I did). In my case it was an app that wasn't on my iPhone before synchronising.

    5) Synchronise

     

    Problem seems to be solved. I've downloaded one update and one app since I followed these steps and haven't seen the error so far.

     

    Let me know if it works for you!

     

    edit: iPhone 4S, Windows 7, iTunes 10.5.3.3

  • Mac OS XP Level 1 Level 1 (75 points)

    I'll try, but would that solve the problem long term? Also don't get your hopes up too much, because the errors we have been getting are not constant. We may be able to install five apps or updates just fine, and then the next day the message pops up.

  • SuperBojangs Level 1 Level 1 (0 points)

    I synced my iPhone with my iTunes and yes it did seem to fix the problem however it's been doing it to me again as of late. It's probably something that apple will have to fix with an update.

  • Xentix Level 1 Level 1 (0 points)

    I have the same problem, but with ipad 2. Your solution to the problem does not help.

  • Michael Fata Level 1 Level 1 (5 points)

    Same here. On my iPad 2 I had an app that the dev said needed to be deleted and re-installed because updating would cause the app to crash. I deleted the app and when I tried to re-download I got the "Unable to Download. Please try again later" message. I successfully downloaded and installed the app again, but at least once a day when I install app updates or download something new I get the "App x could not be downloaded. Please try again later" message. I've deleted and re-installed the app and I still get the message if the app is installed on the iPad or not.

  • AndreXuxu Level 1 Level 1 (0 points)

    Exactly the same problem as the OP here. iPad 2, updated iOS. One thing I noticed is that when my Restrictions are disabled, the error so far has never happened. On the other hand, when my Restrictions are on (except evidently for Installing Apps), every time the App Store requests my account password for a new purchase, for an update or for a redownload of a previously uninstalled app, the error appears.

     

    So for me, at least for now while Apple does not fix this, this workaround seems to be working. If this works for others, it suggests that the problem could be related to a bug with the App Store and the Restriction system.

  • Mac OS XP Level 1 Level 1 (75 points)

    I don't have restrictions enabled...

  • AndreXuxu Level 1 Level 1 (0 points)

    ****, sorry to hear that. This probably means that my workaround was just a happy coincidence... Will post if it stops working for me. Just tried another download and no error again...

  • Nestea80 Level 1 Level 1 (0 points)

    Guys, this happens randomly. It doesn't happen every single time, so just because you downloaded an app 3 times in a row without problems doesn't mean it's fixed.

  • Getslow Level 1 Level 1 (0 points)

    I have to admit, the error just popped up again. I'm trying my own solution now for the second time, I hope it will 'fix' this problem again.

  • SeriousRic Level 1 Level 1 (0 points)

    I've got the same problem but with 15 apps! I went to the apple store and the guy there said he hadn't seen the problem, so no help. I've also had lots of crashing problems since ios5. Have others been having this too?

  • ikemarrus Level 1 Level 1 (0 points)

    Same thing happening here - very annoying.  I've signed in and out of the store - and it didn't happen for the next update - but sounds like it will happen again. 

  • Mac OS XP Level 1 Level 1 (75 points)

    User ryanpetris just posted this to another thread. You may want to try it out and see if anyone still has the problem afterwards or if it's solved:

     

    I has this happen to me last night to. Ultimately, this worked:

     

    1. Open the App Store

    2. Goto the Features page.

    3. Scroll all the way down to the bottom and press on the button with your Apple ID.

    4. Press logout.

    5. Reboot yor device (!! VERY IMPORTANT. This didn't work until I did this part).

    6. Once rebooted, sign back in to your account.

  • Mac OS XP Level 1 Level 1 (75 points)

    Update: Didn't work

Previous 1 2 3 4 Next