Previous 1 2 3 Next 202 Replies Latest reply: Oct 20, 2012 7:19 AM by NicSpox
Yves M Level 1 Level 1 (10 points)

Since 10.7.3 update, I have to manually reconnect to my WiFi network at every Wakeup from sleep.

 

It  WILL  try to connect by itself, but it will quit trying after 6-8 seconds.

The WiFi icon in the menu bar will then remain gray until I click on it and manually choose my WiFi network.

 

It  DOES  reconnect automatically upon Restart, though.

 

My WiFi network comes from a third generation Time Capsule, with the most recent updates applied.

 

Had no such problem yesterday in 10.7.2.

 

 

YM


iMac, Mac OS X (10.7.2), Mac OS X Lion 10.7.3
  • Carlo TD Level 3 Level 3 (550 points)

    Using Airport Utility 6.0 simply reset your router to default settings, then start over. I am sure it is that simple.

  • dhwalt Level 1 Level 1 (0 points)

    Same problem here but with WiFi from a Netgear DGND3700. Lion has had WiFi issues roughly as follows, on my 2010 iMac:

    10.6.8 Snow Leopard - excellent

    10.7 Lion - poor WiFi

    10.7.1 Lion - poor WiFi

    10.7.2 Lion - fixed WiFi

    10.7.3 Lion - back to no WiFi following wakeup from sleep

     

    On past history this thread could grow as users update to 10.7.3. I am hoping for a fix and it could be that we have to wait for 10.7.4!

     

    Dave

  • Rick Bolton Level 4 Level 4 (1,125 points)

    I also am experiencing the very same issue - although it happens ONLY on our i5 iMac (not on my i7 MBP nor on our i3 iMac).

     

    What to do?

  • Yves M Level 1 Level 1 (10 points)

    Carlo TD

     

    Well, I've just reset my TC Router to its default settings and, for the moment, my Time Capsule seems dead !

     

    Upon restart, I get the green light for a second or two and then the steady yellow light for about 50 seconds (which I find normal).

     

    But instead of getting the steady green light afterwards (at which point the WiFi connection normally gets alive), I get that yellow flashing light that will keep on flashing forever.

     

    I've then tried hard resetting with a pencil at the tiny recessed knob at the rear of my TC, and the problen remains: the boot process still ends up with the same flashing yellow light.

     

    Disconnecting / Reconnecting the Wan Ethernet cable didn't help neither.

     

    Luckily, I have an old D-Link WiFi Router on hand. That's how I'm now back on the Internet to find a solution.

     

    Any suggestion ?

     

     

    YM

  • Carlo TD Level 3 Level 3 (550 points)

    sure... how did you reset your TC? did you use a hard reset or a soft reset? If the soft reset does not work try the hard reset... dont forget it takes a moment to write the infomation change inside the router. let me know, I am availabe.

  • dhwalt Level 1 Level 1 (0 points)

    For Rick,

    Not a fix - a workaround requiring a download of SleepWatcher and dabbling with the Terminal:

     

    Expand your download to the desktop.

    Read the instructions.

    Step by step:

    Open Terminal and for a first time installation.

    sudo mkdir -p /usr/local/sbin /usr/local/share/man/man8

    sudo cp ~/Desktop/sleepwatcher_2.2/sleepwatcher /usr/local/sbin

    sudo cp ~/Desktop/sleepwatcher_2.2/sleepwatcher.8 /usr/local/share/man/man8

     

    echo '#!/bin/sh' >~/.sleep

    echo '/usr/sbin/networksetup -setairportpower en1 off' >>~/.sleep

    chmod +x ~/.sleep

    echo '#!/bin/sh' >~/.wakeup

    echo '/usr/sbin/networksetup -setairportpower en1 off' >>~/.wakeup

    echo '/usr/sbin/networksetup -setairportpower en1 on' >>~/.wakeup

    chmod +x ~/.wakeup

     

    cp ~/Desktop/sleepwatcher_2.2/config/de.bernhard-baehr.sleepwatcher-20compatibilit y-localuser.plist ~/Library/LaunchAgents/de.bernhard-baehr.sleepwatcher.plist

     

    Posting may screwup the syntax so be careful and the last cp is all one line with a space between ...plist ~/Library...

     

    Restart your machine to have the LaunchAgent do its thing. Your WiFi should restart after sleep - always.

     

    Dave

  • Yves M Level 1 Level 1 (10 points)

    Carlo TD

     

    You were right !

     

    I didn't wait long enough after the hard reset.

     

    Thanks for the help.

     

    YM

  • Rick Bolton Level 4 Level 4 (1,125 points)

    Dave - thanks for your detailed response.  There is developing news about the 10.7.3 "software update" download causing problems beyond this wifi one we are discussing here.

     

    I think I am going to wait a bit before diving into the terminal workaround you outlined.  Every so often Apple simply blows these Airport updates and it takes some time for them to set things right.

  • Rick Bolton Level 4 Level 4 (1,125 points)

    This problem is only impacting one of our Macs as previously mentioned.  So I wonder if the issue is related to 10.7.3 or AU 6.0 or something wonky with the install on our i5 iMac or .........?

  • Rick Bolton Level 4 Level 4 (1,125 points)

    Continuing - OS 10.7.3 will not allow me to trash AU 6.0 (to revert to AU 5.6) - any ideas on how I might be able to trash AU 6.0?

  • Bob Timmons Level 10 Level 10 (87,730 points)

    No need to trash 6.0. Just add 5.6.

     

    You can have both on your Mac and simply choose the version that you want to use.

  • Rick Bolton Level 4 Level 4 (1,125 points)

    Well - I decided to load the 10.7.3 COMBO over the "software update" to 10.7.3 I did yesterday - problem appears to be resolved - wifi connects from sleep after the combo download :-)

  • Rick Bolton Level 4 Level 4 (1,125 points)

    Problem solved - I let it sleep for a longer period and wifi connects solidly after about 5 seconds !!

  • LPRflyer Level 1 Level 1 (0 points)

    Well I installed via the software update. Thought all issues fixed but no.

    When my imac wakes from sleep the network box is greyed and says no network. If I tick the remember net work box it connects but if it sleeps the same thing, or if I switch user or open the network box and and click my network it works.

     

    How long has the world and their wife been trying to resolve this problem?

     

    Should i install 10.7.3 again through the combo update?

     

    Come on Apple this is pretty basic stuff, even my PC has never ever had this problem with any version of windows!

Previous 1 2 3 Next