Previous 1 9 10 11 12 13 14 Next 202 Replies Latest reply: Oct 20, 2012 7:19 AM by NicSpox Go to original post
  • Carlo TD Level 3 Level 3 (550 points)

    remove all your preferred networks in the system preferences - network.

  • Vegas_George Level 1 Level 1 (0 points)

    Just thought I'd chime in with a "me too!"  I have two i7 iMacs, a Mini, and an Air.  The Mini and the Air are OK, but they haven't gotten the latest updates.  I keep my iMacs fully updatted.  Neither of my iMacs will auto connect to my Airport Extreme on waking up.  And, they both lose the connection after periods of inactivity.  My iMacs used to be OK.  I can't seem to remember exactly when they started doing this, but it must have been after one of the recent updates.

     

    Apple, you really need to fix this now.

     

    Oh, by the way, I have already tried just about everything, and nothing works to fix the problem.  It's not permissions, or router settings, or plist files, or the system file, and resetting the PRAM doesn't do it, and dumping the entire network, including all the keychain references doesn't help, new user accounts have the same problem, and I even went to the extreme of reinstalling Lion.  All to no avail. 

  • tomassosan Level 1 Level 1 (0 points)

    Hey Carl TD, did that and did everything Vegas_George did (except reinstall Lion).  Also, reinstalled 7.3 update from the Apple site and I also flushed the DNS cache

    sudo killall -HUP mDNSResponder

    I turned WiFi on and off, set up new network after hard reset...I'll use the power button to wake my iMac until Apple fixes this.

  • Dan5718 Level 1 Level 1 (0 points)

    James,  Thank you for the form.  I trust Apple is on top of this....after all their stock just exceeded $500 a share.

     

    Dan from upstate New York.

  • appleofmyimac Level 1 Level 1 (0 points)

    Been having the same problems as others here.  The work around I use was posted by someone earlier and has worked for the past couple days.  I changed the sleep settting in System Preferences under Hardware...Energy Saver to "Never".  Not letting the computer sleep solved the immediate issue of losing wifi on wake-up.  Hope this gets fixed in the next up-date.

     

    I'm new to Mac and have to say I didn't expect to have an issue like this from a quality product like Apple.

     

    iMac mid 2011 i5.

  • Bob Ferrara Level 1 Level 1 (0 points)

    Spoke to Apple support yesterday about this issue and was told a fix is on the way.

    Hope it's soon.

  • temeeo Level 1 Level 1 (0 points)

    Just want to add to my previous post that I also noticed wi-fi drops after the update to 10.7.3 ...

  • TrolleyPusher Level 1 Level 1 (0 points)

    I hope Apple is onto this too. Although their stock is up because of their own cannibalization of iMac via iPads etc.. Not necesarily a bad thing but iMacs & OSX don't appear too high on their priorities anymore, and given how important the laptop/desktop still is I hope they also give it the attention it deserves. Perhaps part of the reason Lion has been a relatively troublesome OSX?

  • lucar1990 Level 1 Level 1 (0 points)

    Ahaha I think there will be no update by Apple. This summer will be launched Mountain Lion (10.8) so if you don't want to be stuck with wifi issue downgrade to 10.7.2, otherwise wait until this summer, update to Mountain Lion and turn you Mac into a Huge iPhone!! Apple is getting worse every day!

  • Pondini Level 8 Level 8 (38,720 points)

    lucar1990 wrote:

     

    Ahaha I think there will be no update by Apple.

    Baloney.

     

    Snow Leopard was updated at least three times after Lion was announced, and twice while it was in beta testing. 

     

    There's no reason to think there won't be any more updates to Lion in the next 5-7 months.

  • LPRflyer Level 1 Level 1 (0 points)

    Well let's face it Apple have got a pretty big mountain to climb to sort this debacle out. What I find the most frustrating about this problem is that they keep denying the problem exists and won't even make some statement about it. The least they could say is yep we have a problem and are trying to sort it out soon.  Remaining silent is second rate customer service to say the least.

  • gmiller0 Level 1 Level 1 (15 points)

    This is DEFINATELY a Mac OS Lion issue.. Im not sure if anyone has chimed in yet, but I run BootCamp on my Mac and when I am running Windows, I have absolutely NO issues with waking from sleep with the mouse and having my wireless internet connection..  SO... This needs to be fixed.. I just downloaded iMessage "hoping" there was a secret patch in there for us, but there was no:(

  • mickylx Level 1 Level 1 (5 points)

    I had this problem too when I updated to 10.7.3. I think I solved it using the following steps.

     

    1) Logged into the administrator's account and turned off wifi.

    2) Opened System Preferences > Network > Advanced and deleted the network SSID.

    3) Opened Disk Utility and ran Repair Permissions.

    4) Reinstalled 10.7.3 using the combo updater.

    5) Ran Repair Permissions again after the installer restarted the iMac.

    6) Turned on wifi, selected my SSID, and entered the password.

     

    Then I logged out, put the iMac to sleep, and waited a few minutes. When I logged in to the admin account, wifi joined the network automatically.

     

    Next, I logged in to my standard account and wifi didn't work. I opened keychain and deleted the SSID from the "login" keychain set (do not delete the SSID in the "system" set). Then I tested it by logging out, putting the iMac to sleep, then logging back in.

     

    So far, I have not had any problems for the past 8 hours. The iMac will automatically join my home network when I wake it from sleep and log in.

  • mickylx Level 1 Level 1 (5 points)

    I forgot to mention that I was wondering if steps 3 - 5 were necessary. Maybe just resetting the SSID and deleting the SSID in the "login" keychain was enough to fix the issue? Anyone want to give a try?

  • larrycz Level 1 Level 1 (0 points)

    mickylx wrote:

     

    I forgot to mention that I was wondering if steps 3 - 5 were necessary. Maybe just resetting the SSID and deleting the SSID in the "login" keychain was enough to fix the issue? Anyone want to give a try?

    Only steps 1, 2 and 6 doesn't fix the issue for me.

     

     

    Stuermer wrote:

     

    When waking up by pressing the power button instead of using the mouse, it reconnects without having to select the network manually. Not a solution, but maybe a workaround.

    This works as a workaround. When using the power button to wake up my iMac instead of the Bluetooth keyboard or mouse, the wifi re-connects fine each time. Using USB keyboard or mouse also works. It seems the issue is with waking up over Bluetooth.