Previous 1 2 3 4 5 6 Next 202 Replies Latest reply: Oct 20, 2012 7:19 AM by NicSpox Go to original post
  • jonmuss Level 1 Level 1 (0 points)

    I am having the same problem on my week old iMac. I had no problems whatsoever on OSX 10.7.2 but after the upgrade to 10.7.3 I too am not able to auto connect to WiFi after waking up from 'Sleep' mode.


    I have tried the combo install after the 10.7.3 update but that did not fix the problem.


    I have found that if i bring the iMac out of Sleep mode using the power button as was mentioned earlier in this thread, Everything works normally but when i use the mouse or keyboard the problem re-occurs.


    I have tried all of the fixes mentioned on other threads but nothing has worked so far!


    I hope the problem is resolved soon!

  • Hydnjo Level 1 Level 1 (0 points)

    Anyone know if 10.7.2 Client Combo (still available) can be safely installed after "upgrading" to 10.7.3? Don't think I'll be giving up too much and my computer will behave as it did last week.

  • Nyk0n Level 1 Level 1 (20 points)

    not too sure but can always try im sure the installer will say yay or nay

  • Hydnjo Level 1 Level 1 (0 points)

    You first?  ;-)

  • RainyWeather Level 1 Level 1 (0 points)

    Similar situation - I did the update to 10.7.3 from 10.7.2.  After the update, every time I woke the computer from sleep, it could not find my network.  I had to go to network preferences and connect manually EVERY time.  I called AppleCare about this and they had me do some things and now I can't connect at all.  I don't mean this as a complaint about the AppleCare person, who was very nice and trying things he thought would help.  But there must be a big problem with this update they aren't yet aware of, because AppleCare made it worse - now I can't connect at all - the wifi icon is grayed out with an exclamation point across it and no matter how many times I go through network diagnostics, it ends up telling me wifi has a self-assigned IP address and will not be able to connect to the Internet.  Took computer to the Genius Bar, where they completely erased everything and reinstalled Lion - (with the update, up to 10.7.3).  Worked fine in the store, but took it home and tried to connect and still the icon is gray with an exclamation point.  In network diagnostics I first get the message that wifi has no IP address; after I run through the diagnostic procedure, the message says it has a self-assigned IP address and can't connect to the Internet.  Waiting to talk to an AppleCare senior advisor tomorrow.  This is a very new 21-inch iMac; just purchased in December.

  • RainyWeather Level 1 Level 1 (0 points)

    I'm replying to my own post as a way of adding a post script with more information.  I just read the Apple Article entitled "About the OS X Lion v10.7.3 Update" and noted that one of things it is supposed to fix is a wifi connection issue when waking from sleep.  I wasn't having that issue and wasn't aware there was such an issue until I did the update, so maybe if one wasn't having that problem, somehow the thing that is supposed to fix it, creates it.  Also, just further information:  Right out of the box with this new computer I had wifi issues.  The connection seemed to "flicker."  The computer found my network with no problem, but the connection would just flicker on and off.  I'd be working on a website, click link to go elsewhere on the same website and get the message that I was not connected to the internet.  For awhile turning wifi off and then back on would reconnect me, then that stopped working.  I never knew for sure if I was going to be able to connect and then I had three kernel panics in three days.  Even though my old G4 iBook was still connecting with no problem, I had AT&T come check it out.  They said the line was congested (that might not be the wording, but my impression/understanding was that I a lot of people were trying to connect on the same "line" or "wavelength" or signal).  They took care of that and said my modem was fine, but I was so nervous about damaging my expensive new computer that I bought a brand new, more powerful ("business style") modem.  I had no wifi problem for two weeks, so I thought it had been an AT&T problem, but then I did the upgrade to 10.7.3 and the waking from sleep problem started.  Now I'm wondering if the original "flickering" problem was primarily Lion or Apple related, rather than AT&T, especially since I could get a solid connection with my old laptop throughout this time period.

  • pounderfire Level 1 Level 1 (0 points)

    Hello Everyone:


    Apple should go back to Snow leppard but, with a Lion feel to it! Ha Ha! Just kidding! However, why is Apple releasing such bad updates these days? It's like those days when Microsoft Windows ME was around! I switched back to mac at a wrong time!


    Anyways, can you guys do me a favor!


    1) Shut down your mac

    2) Turn it back on and press command + R

    3) Go inside the lion recovery but, don't reinstall it!

    4) In the top right hand corner you will see the wifi icon

    5) in the apple menu tell the computer to sleep

    6) Wake it back up in two minutes with your mouse


    Does it wake up with Wifi? If it does, I wonder why?


    Also, it's good that the IPad and IPhone and the MBP do not have this problem.


    Apple does not care for the IMac anymore! I am going to cash out my stock! Sure, I don't have much, and Apple could careless if I do but, at least I'm making a sort of gesture about how I feel!

  • gemecker Level 1 Level 1 (0 points)

    Same here. New (3x) iMac 27" core i5. After the update, every time I woke the computer from sleep, it could not find my network (Bootcamp with Win 7: no WiFi Problem). MacBook Pro, iMac 24" mid 07, iPhone, iPad no WiFi Problem. I could not fix the Problem (Changed Router, Bluetooth off, clean Install and so on...) Apple, it´s your turn.

  • pounderfire Level 1 Level 1 (0 points)

    I spoke to a senior advisor today and I never seen him so defensive. He insulted my inteligence by stating that I'm the only one having this issue!


    Anyways, in my opinion, the newest MBP hardware is different from the newest IMac. And within the MBP line-up, the hardware is also different. For example, a 13 inch MBP hardware is different of that of a 17 inch. Hence, this is why a 17 inch MBP can wake up from sleep and connect but, the IMac cannot.


    So, whenever there is a software update, perhaps it tends to favor one form factor over another since each form factor has its own hardware configuration. So, I think Apple should have different software updates for different form factors and seperate them entirely.


    I'm starting to think that Apple does not care for its IMac line-up and are focusing their efforts on the MBP line-ups.


    Anyways, I'm going to buy another IMac and MBP and then take them apart piece by piece to see how the parts differ in each form factor. Of course they will be the same generation but now i'm curious. I also wonder if Apple had more problems now they switched away from PPC to intel.

  • temeeo Level 1 Level 1 (0 points)

    1+ , same problem like the original poster.

    I would get occasionally on 10.7.2 right after (like within a second) waking from a sleep the "none of the preferred networks available" message, but within a second or two the computer would actually connect and I would just have to dismiss the message (either with esc. or just click cancel)

    Now with the 10.7.3  nine times out of ten the mac doesn't connect after waking from a sleep, and I have to select the network manually...   I've tried the usual troubleshooting (deleting the network from preffered list along with the password in keychain access, all the resets, deleting the plist files), none of it helped...


    I'm on month old iMac 21.5inch 2.5QC i5 ...

  • Hydnjo Level 1 Level 1 (0 points)

    Same here - I'm the only one, never heard of this problem before my call, I must have done something to screw up my settings(?), reinstall 10.7.3(combo). After explaining that I had already done the reinstall to no avail and that this forum has plenty of users with the same problem he said he would look into it and call me back. He didn't (36+ hours). VERY un-Apple-like.

  • Carlo TD Level 3 Level 3 (550 points)

    oh gosh.... I own an iMac and a Mac Book Pro... and I have ZERO problems from both.

  • RainyWeather Level 1 Level 1 (0 points)

    Well, I'm really lucky - I got a wonderful AppleCare senior advisor.  At first she thought it was just me, but she wasn't condescending; she just tried to help me and was as nice and patient as she could be.  I had started with the "no wifi connection after waking from sleep" problem (everytime I woke my computer, I had to manually select the network).  Then it advanced to not being able to connect to the Internet at all!  When nothing worked she did more research.  Three long phone calls, but she found the answer and I'm connected again. 

    As far as the "no connection after sleep problem," she said they are now well aware of the problem and working hard on it, but as a temporary fix they're just asking people to not let the computer sleep - just until they get this fixed.  She had me go to system preferences (click on the apple icon in the upper left corner and select "system preferences" from the drop down menu), then select "energy saver" (click on the picture of a lightbulb in the "hardware" row).  Then make sure that "put the hard disk to sleep when possible" is NOT checked.  Next, on that same page go to the top sliding scale (the one labeled "Computer sleep") and slide the pointer all the way over to "Never."  Then leave it like that - JUST TEMPORARILY, until they get this fixed.  It's fine for the display to go to sleep, just not the hard disk.

    Once Apple gets this fixed, you'll probably want to go back and check "put the hard disk to sleep when possible" and move the pointer to whatever is a reasonable amount of time for you.

  • Hydnjo Level 1 Level 1 (0 points)

    Or wake from sleep by tapping the power button. That's what I do and WFi connects every time.

  • jkoerber Level 1 Level 1 (0 points)

    I unchecked the "put the hard disk to sleep when possible" box in the Energy Saver preference screen and even after the computer has been sleeping for several hours, I am now connecting to airport automatically.


    Not sure why but this has been working well since yesterday, no matter how I wake the computer.

Previous 1 2 3 4 5 6 Next