Previous 1 2 3 Next 43 Replies Latest reply: Jan 27, 2013 1:54 PM by cRiLle Go to original post
  • Alvin Nguyen Level 1 Level 1 (0 points)

    Hmm mine is a 15" 2010. Shouldn't make any difference though. Just to make sure we are on the same page,

     

    You have an external HDD with Lion installed.

    You are going to boot from that HDD.

    You are going to run software update and select only the EFI update and do the reboot.

     

    Would that be the process?

  • astro.boy Level 1 Level 1 (0 points)

    hi i had the same problem.

     

    my main system (24GB) is on a 60GB ssd (optical bay), but i have a partition with a clone of the system on the original hdd.

     

    solution:

     

    1. clone your main system and the recovery partition with ccc to the second hdd (original hdd place). make sure your system is ok and you have enough space (repair disk permissions, make a new partition if needed etc. before you clone)

     

    2. boot into the clone system and check the system updater. install the efi update and reboot into the clone again. the update should be fine.

     

    3. now clone the updated system back to the first hdd. in ccc go to "disk center" and clone the updated recovery partition back, too. boot into your main system. done.

  • Thunderfury Level 1 Level 1 (0 points)

    The workaround proposed by astro.boy definitely works. I didn't find anywhere a way to solve the update problem (my configuration is a main SSD in an optical bay + HDD) and test it. It is a bit tricky but at least, you are able to make the update. Thanks for your help

  • edmechem Level 1 Level 1 (0 points)

    It's actually easier & quicker than all that. (or at least it was for me)

     

    I created a simple Lion boot drive, on a spare external USB drive. Booted from that. Ejected the internal drives, just for good measure. Ran the Firmware updater, and it worked fine.

     

    Done!

     

    Much preferable to opening up the machine, switching which device is in which bay, etc.

     

    Hope the Apple Firmware Installer script engineering & QA peeps have been reading this, and that we won't need to jump thru these hoops next time around...

  • astro.boy Level 1 Level 1 (0 points)

    could you perform it with a bootable usb lion installer disk? or do you mean you stopped after no. 2 with a fresh installed lion on the external drive (instead of a clone)?

     

    point no. 3 is for safety reason. after everything done.. i had to delete the clone recovery partition on the second hdd, because i had more than 4 primary partitions on it. boot camp/ win wont recognize more than 4. :/

     

    yes, it would be nice, if apple will fix the next efi update!

  • timchong Level 1 Level 1 (0 points)

    edmechem's method works! Thanks!

  • edmechem Level 1 Level 1 (0 points)

    astro.boy, I don't know about a bootable USB Lion installer disk - I presume you mean, one you'd make with Disk Utility, using the "InstallESD.dmg" inside the "Install Mac OS X Lion" package? (pretty sure MacWorld had an article on how to do this).

     

    I presume that'd probably possibly work too, uh, but maybe not. Anyone want to try and see? Perhaps the firmware installer script is looking for "one boot device, with two partitions - recovery, and startup volume" - *only*. Perhaps anything other than this will fail. So, just copying InstallESD.dmg to an external USB drive, would end up with a situation where you have a bootable Lion drive but without a recovery partition - I'd be curious whether the firmware installer would fail in this situation. Can't really test it myself now, because I'm 'on the other side' - having successfully updated my firmware.

     

    What I did is, I have a spare laptop, single internal drive, running Lion & a few apps. Using that machine, I plugged in a USB drive, erased it, and ran the "Install Mac OS X Lion" installer - targeting the external drive. At the end of the install, when Migration Assistant asked what to do, I chose 'from other disk' and pointed it at the internal HD.

     

    So what I ended up with, was an external USB drive, that had had a fresh copy of Lion 10.7.3 installed on it, including the Recovery partition, and then had a minimal user & a few apps, migrated over to it. A relatively 'normal looking' situation.

     

    I then attached this drive to my main laptop (the one w/ internal SSD & HD), booted up, *ejected the two internal drives*, and just ran Software Update. Worked fine (finally!).

     

    Good to know this also worked just now for timchong; not sure why the user earlier in the thread - who apparently did something similar - didn't also succeed... (if in fact they did try something similar).

     

    Bears noting - you probably wouldn't need a separate laptop to do what I did. In other words, that's probably a superfluous step to reproduce. You could probably just, run "Install Mac OS X Lion" on your main machine, but just point it to a freshly erased external USB drive. Create a minimal new user account at the end of install, & be done w/ it. Startup w/ option key, choose to boot from external drive, when Finder loads, eject internal drives (and I can say drives plural, since us oddballs w/ two internal drives: original HD + aftermarket SSD, seem to be the only ones in this boat), then run Software Update.

  • astro.boy Level 1 Level 1 (0 points)

    yes, i mean a install disk of lion on a usb stick. good for a fresh install of lion without a recovery volume... if you can start the updater from there it should work, but i dont think so, too.

     

    the other user likely just reinstall the system to the same ssd and didnt boot from an external hdd. i think the problem is the ssd of other brands. apple only support their own build-in ssd's (like trimm support).

     

    our method is the same. we both started the updater from a hdd to success.

     

    just to be sure... your usb drive is a normal hdd?

  • edmechem Level 1 Level 1 (0 points)

    Yep, normal HDD

  • shaymanjohn Level 1 Level 1 (0 points)

    Confirmed working for me too:

     

    • Installed Lion onto a USB flash drive, rebooted using the flash drive as the boot drive.
    • Manually downloaded the EFI Firmware update, installed it (didn't bother ejecting the SSD or HDD).
    • Changed the boot drive to be the SSD, rebooted.

     

    Done. Thanks for everyones help on here.

  • Johan Svanberg Level 1 Level 1 (0 points)

    I can also confirm that this workaround solves the problem. Great job!

  • bladbox Level 1 Level 1 (0 points)

    Just to follow up. I have Macbook Pro Mid 2010 with 128GB SSD in optical drive bay with OEM 500GB in original location. Followed edmechem advice. I installed Mountain Lion to external USB drive. Booted to fresh install of Mountain Lion on USB drive. Ejected SSD and 500GB drive, ran update and everything updated perfectly. Job job all!

  • nobelium Level 1 Level 1 (0 points)

    I confirm this workaround works as expected but in my case it wasn't as simple as running the update pkg from the dmg. Possibly because I had tried to run the update on my current Mountain Lion install, even when running off the external HD, it wouldn't work. I tried resetting PRAM, unmounting all drives except startup disk, installing from App Store, everything lead to the same no success result. Eventually, I was able to update it without knowing exactly what triggered the update. My guess was that using the Disk Utility from the Restored HD partition of the external HD to unmount all disks was the culprit.

     

    You know the update will be applied if it takes more than 10 seconds to run - a real update takes about 2-3 mins.

     

    Thanks everyone for the valuable tips!

  • cRiLle Level 1 Level 1 (0 points)

    Worked like a charm for me doing it like edmechem described.

    Okay, I had to boot a few times but got it working. Maybe I had forgotten the first time to unmounted the internal SSD and HDD.

     

    Thanks, edmechem!

Previous 1 2 3 Next