Previous 1 2 Next 16 Replies Latest reply: Jun 3, 2013 8:51 AM by bob264
bob264 Level 1 Level 1 (0 points)

All,

 

First:

I'm using a late 2008 MacBookPro 17" with 4GB RAM and a 320GB HD.

MacOSX Snow Leopard 10.6.8

 

Address Book 5.0.3 (883)

Mail Version 4.5 (1084)

 

Yesterday evening I found that Address Book was empty - no contacts displayed and Mail did not recognize the group name when I entered it in the To field.

 

Actions I've tried but did not resolve the issue:

  • Restoring Address Book from a Time Machine backup that was previous to when the problem occurred.
  • Deleting the Address Book app
    ~/Library Address Book Plug-Ins
    ~/Library/Application Support/Addressbook and
    ~/Library/Application Support/Yahoo! Sync

And then restoring these same items from a Time Machine backup that was previous to when the problem occurred.

  • Deleting the Address Book App and then reinstalling from my Snow Leopard Install DVD.

 

When I restored AB from Time Machine all my entries showed in Time Machine (even the backups made *after* the problem began) all vCards are there and seemingly are restored.  But, when I make any effort to use a card or change to a different card, AB quits and it's back to an apparently empty address book.

 

I have exhausted my limited experience and am hoping someone here can point me in a new direction.

 

Thanks,

Bob


MacBook Pro (17-inch Late 2008), Mac OS X (10.6.8)
  • bob264 Level 1 Level 1 (0 points)

    All,

     

    For what it's worth, Applescript can access my AB even though contacts are still not visible to me.  This gives me hope that all is not lost.

     

    Is helpful?

     

    Bob

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Why are you trying to delete the whole app, when it's just the plist that will most likely fix the job?

  • bob264 Level 1 Level 1 (0 points)

    Hacintosh,

     

    Thanks for your response.

     

    I thought the app might have been corrupt and that reinstalling from my DVD would resolve this.  It didn't.

     

    I found a discussion from 2008 that suggested restoring the plist might help but doing that from a backup well before when this surfaced didn't help.

     

    These are the ones I restored:

    com.apple.Addressbook.adb.plist

    com.apple.addressbook.plist

     

    I did not restore any of these - there are four with similar names but differ in the hex characters within:

    com.apple.AddressBook.sync.....plist

     

    Perhaps I didn't do this correctly though.  Do you have suggestion?

     

    Thanks again,

    Bob 

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    It's possible the backup also has a glithy substance here... that's interacting with another routine.

     

    Can you drag your com.apple.addressbook.plist to the desktop while addressbook is closed, then re-open the book to start from a newly generated default?

     

    If that still doesn't work, try to repair file permissions.

  • bob264 Level 1 Level 1 (0 points)

    Hacintosh,

     

    I tried your suggestion and moved com.apple.addressbook.plist to the desktop but noticed no change.

    Unfortunately, I didn't try the script to see if that functionality had been altered.

     

    I decided to move the rest of the Addressbook files to the desktop and noted that 17 contacts were dropped and were no longer accessible via the script.

     

    Moved the files back one at a time and ran the script after each move showed no change each time.

     

    Tried restoring those files from TM using the same backup as i did yesterday but again, no change.  Dropped contacts were still gone and AB still appeared empty.

     

    Ditto when the contacts were restored and when the app was restored - both from TM and both from the same date but no change.  I also tried an earlier backup but that didn't help.

     

    Then I noticed that AddressBook-v22.abcddb in folder "~:Library:Application Support:AddressBook:" had changed at about the time when I began moving the files you suggested.   There was also a version dated yesterday (named AddressBook-v22~.abcddb) when the contact list was complete so I renamed each file so yesterday's version was active.  Running the script showed my contact list was back at full strength although AB still appears empty.

     

    This file has now been copied to a folder on the desktop for safekeeping and intend to repeat your suggestion while testing at each step with the script.

     

    I forgot to mention in my original post that I had repaired permissions and had noticed no changes but did that again to see if maybe it might help this time - again, no change this time either.  I apologize for the omission.

     

    Thanks again for your help and I'll follow up soon.

    Bob

  • bob264 Level 1 Level 1 (0 points)

    I removed the AB files from the Preferences folder one at a time and ran the script to see if the number of contacts changed and that never happened. 

     

    After each script test I quit AB before continuing to insure no remnants of the preceding cycle remained.

     

    But, at the end, there were still a full-list of contacts (at least the count was unchanged) and AB still appears empty.

     

    Sorry I can't provide more definitive results.

     

    Bob

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Grrrr. This is becoming an interesting case to crack. I wish I was a bit more of an addressbook expert.

     

    Can you try a safe-boot? Maybe it's related to a font/cache issue, doubt it but there is little hope there. Also disabling the login items from the safe-boot may prevent some third-party software from gucking it up if that's happening.

     

    I also suggest loading up your FontBook and trying to verify all your fonts.

     

    I have a few other ideas we can try after/when those fail

  • bob264 Level 1 Level 1 (0 points)

    I did as you suggested and booted in Safe Mode, opened Font Book and validated the installed fonts:

    • 435 Fonts Passed
    • 36 Fonts with minor problems
      Of these, 35 were duplicates and
      one, Bauhaus 93, returned this message:  " 'kern' table structure and contents.  Proceed with caution"

    I felt safe removing the duplicates but must have performed that operation incorrectly.  I have six, yep, six fonts in Font Book now - including Bauhaus 93.

     

    Finally, the Address Book is still empty and is still accessible with the script so no harm done there.

     

    I'll figure out how to reinstall the deleted fonts (I moved them into a separate folder) and will be more cautious when I "resolve" the duplicates next time.  Live and learn.

     

    Thanks for getting me interested in Font Book.  It has been a learning experience and will probably pay off in the future.

     

    Bob

     

    I forgot to mention that I Validated the Fonts in both Safe Mode (no errors reported) and normal mode (the 435 Passed and 36 with errors).

  • bob264 Level 1 Level 1 (0 points)

    I've come to the conclusion that AB is not the root problem but only a symptom.

     

    The AB on my wife's machine, a Mac mini also running 10.6.8, with essentially the same contact list is working normally.   I've compared all the system files, and the contents where possible, against mine and have found no difference that didn't make sense.  This leads me to believe that AB is OK but something external to it is interferring with its operation.

     

    Font Book appears to be OK, validating the fonts returns no errors now, so does anyone have some other course of action I could pursue besides restoring my Mac HD to a backup previous to when this occurred?  Frankly I'm not sure this would resolve the problem anyway.

     

    Best regards,

    Bob

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    Well looks like we had started to beat AddressBook to death there. I"m starting to conclude the same thing. Unless, some expert may notice something simple we might have missed here.

     

    Perhaps it's another app (possibly third party) that is capable of pulling information from the AB.

  • bob264 Level 1 Level 1 (0 points)

    Third party Software:

         I have MSOffice 2008 Student & Home edition

    • This has been on the machine since I bought it more than three years ago with no problems caused.  As far as I can remember, it was last updated in December last year so I don't suspect that - yet.

     

         Adobe Photoshop Elements v8 and v10

    • v10 hasn't been updated since it was installed in late November 2011.
    • v8 was last updated 1/13/2010 (perhaps it was never updated - I don't know)

     

         Mahjong In Poculis - a game

    • this has been on my computer since October 2011
    • Since I thought this was most likely the problem, I uninstalled it (deleted it actually) and rebooted my machine but AB was still empty and my script worked as before so I reinstalled the game.

     

    I also created a dummy account on this computer with Standard permissions to see if that would affect AB - it didn't change a thing.

     

    Also on the machine is iWork '09 but, again, it's been on the machine for about a year.

     

    Uninstalling PSElements or MS-Office would make me cringe but let me know.

     

    Bob F

  • Detlef Otten Level 1 Level 1 (0 points)

    Had the same problem, even if the symptoms were a little different: mail working fine with contacts, contacts appear in third party apps Bento and Cobook, but address book in TimeMachine backups were also empty. Following a related thread here I restored address book folder (not the address book itself!) from TimeMachine and all contacts were back.

     

    Detlef

  • bob264 Level 1 Level 1 (0 points)

    Detlef,

     

    Thanks for your response.

     

    I have done this several times to no effect.

     

    Also, AB in Time Machine is not empty, not even the most recent backups are empty, so I know my contacts exist in AB.

     

    Restoring my contact list from TM has no lasting effect.  They will appear in Address Book only until I do something in the AB window, such as selecting a group or a contact, and then AB abruptly closes.  Immediately reopening AB and it is again "empty".

     

    I haven't mentioned this previously, but the Import menu option in AB is dimmed/disabled as are several other menu items.

     

    Best Regards,

    Bob

  • bob264 Level 1 Level 1 (0 points)

    Hackintosh / Detlef,

     

    I finally gave up and restored my system from a TM BU before all this happened and that seems to have resolved the issue.  I did this because Notes (in Mail) began behaving in a similar way in that the content of my notes could not be read and restoring them from TM did not change that.

     

    I'm trying to restore the files I use every day from TM but that it is not going smoothly.

     

    Anyway, thanks for your help - it's time to move forward.

     

    Bob

Previous 1 2 Next