7 Replies Latest reply: Aug 10, 2012 9:19 AM by christophe v.
Gary K. Level 1 (90 points)

When logging in to iCloud.com there is check box that allows the user to remain logged in for two weeks. This has worked fine  in the past but stopped working a couple of days ago for me on various machine with various browsers. The persistent login works as long as the browner is running. However, after closing it, login is required the next time the site is accessed. I hadn't realized what a pain it is to have this feature removed if in fact that is what has happened. Is there perhaps a setting I am missing? Any wisdom welcome!

MacBook Pro 17, Mac OS X (10.7.2), MBP 1,1; 32 GB iPhone 3GS; Vintage Macs & Devices
  • Carolyn Samit Level 10 (103,365 points)

    Hi Gary ...


    Maybe the cache, a reset, or deleting cookies will help, or all three.



    Try this on Safari ...


    From the Safari menu bar click Safari > Empty Cache. See if you can stay logged into iCloud.


    If not, back to the Safari menu bar click Safari > Reset Safari. Select the top 5 buttons, click Reset


    If that didn't help either, go to Safari > Preferences then select the Privacy tab then click Details.


    Type   apple   in the search field top right corner of that window then click Remove All Done.


    Quit then relaunch Safari. Try iCloud.com.

  • Gary K. Level 1 (90 points)

    Hi Carolyn,


    I have tried all of these things. I am an experienced Mac and Internet user and can even verify the exact cookie that is put on my machine to allow the 14 days of remaining signed in. Problem seems to be that the cookie is not being read. I have deleted all iCloud and Apple cookies, so I doubt if any of the cookies on my machine are corrupted.


    The text box into which the password is typed does not accept pasted text. Apple's own Keychain does not store the UID/Password combo either. So this has the perverse effect of encouraging users to create trivial, memorable passwords rather than difficult ones. Somehow I thought this problem was on the server side, but imagine there would be more complaints if that were the case. Thanks for the suggestions just the same.

  • Krellasaafi Level 1 (0 points)

    Hi, I'm having the same problem since the last day or so. If you find a solution please post it here, thanks!

  • Gary K. Level 1 (90 points)

    I have not solved this problem. However, it has gone away at least temporarily. I use a number of Safari extensions. I disabled all of them. After disabling them, I logged into iCloud (having to enter my password). Then I closed Safari and reopened it. I tried opening iCloud and my sign-in had been successfully preserved. So I figured that maybe one of my extensions was the culprit. So, I re-enabled all extensions one by one and found that my signed in status was preserved even after ALL of the extensions had been re-enabled.


    I find this "success" unsatisfactory. If the problem had been traced to one of the extensions (which include Ghostery, Disconnect, The Tracktor, iTubeX and ClicktoPlugin ), I would have been pleased with the effort. But it appears that just toggling one or more of them brought success and I have a feeling that it will not last. Or it could be that the problem just resolved itself on Apple's side during the timeframe of my efforts at tracking it down. Also, I have had the same problems in Firefox and Chrome. So try toggling all of your extensions, but I suspect the problem lies elsewhere.

  • Gary K. Level 1 (90 points)

    It has been 24 hours and at least a dozen Safari shut down/reopen cycles with the login to iCoud persistently working. So I am going to declare this problem solved. While toggling the extensions Ghostery, AdBlock, Disconnect, and Incognito may have solved the problem, I doubt it. With all of these enabled I am still enjoying success.

  • ter11 Level 1 (0 points)

    same here, but using firefox11 (or IE) on XP - no solution so far

  • christophe v. Level 1 (50 points)

    I had same problem. Your suggested 'trick' of removing all plugins / extensions worked fine. To note though I had ONLY one extension that was DIVX extension. Many thanks again as it was a real pain to have to login each time.