Previous 1 2 3 4 5 Next 68 Replies Latest reply: Aug 18, 2015 11:23 AM by abiyoung Go to original post Branched to a new discussion.
  • tstrafella Level 1 (0 points)

    I used the above suggestion to go to https://supportprofile.apple.com/ and unregistered my phone and it worked!!!!

  • dmacattack9 Level 1 (0 points)

    Here's how I did it. Go to iTunes under the store tab. Go to view account. Manage devices under iTunes in the cloud. Then remove your old iphone from your account.

  • jakemuscan Level 1 (0 points)

    Go to iTunes under the store tab. Go to view account. Manage devices under iTunes in the cloud. Then remove your old iphone from your account.

     

    Also log in to: https://supportprofile.apple.com/ and remove your old iphone.

  • DustMagnet Level 1 (0 points)

    What I was supposed to do: On old iPhone, BEFORE I transferred my number to a new SIM, I was to go into Messages settings and turn off iMessage.

     

    Since I did NOT do that, and my old iPhone could no longer talk on the network, I instead called Apple Support, asked to be transferred to a support agent to obsentibly purchase a one-time support incident (for $35+taxes) and when I got through (after a while) and the agent asked my if the issue was with my iPhone I said, "Actually, the issue is I want iMessaging to let go of my phone number but my old iPhone is off the network.

     

    She put me on hold for a bit, came back and said, "Ok, we can do that." then asked for my the number and sent me a confirmation code via SMS.  I read it back to her and she deleted my phone number from the iMessage back-end.  Done. (And no $35 fee.)

     

    While I was waiting on hold, I did try the delete-your-contact-entry-on-an-iPhone-then-power-cycle-phone-then-add-entry-ba ck-in and I found that worked on my wife's iPhone 5.  However, that is hardly a scalable solution for everyone who might have your contact details on an iDevice.

     

    So my learning from this is: When you move away from an iPhone, turn of iMessage in Messaging BEFORE you switch your number to a new SIM.

     

    Really there should be an EXPLICIT way to do this from icloud.com or your Apple Support Profile at any time (my iPhone was never registered, so the idea to unregister it from there is not applicable - and yes, I did try registering and unregistering - no dice).

  • NY3Ranger Level 1 (0 points)

    I did that. I turned off imessages before removing the sim card and putting it into an android. That didnt work. My friends iphones still try to imessage me first. Does anyone know if there is a timeout if the device is wiped?

  • hamdicarlo Level 1 (0 points)

    if you have iMessage enabled on the device, you must first sign out/disable your ID that is associated with apple, then swtich off iMessage. once you made that! then do the same for facetime as well, sign out your Apple ID, and then switch off/disable facetime trust me, this will work

  • jennxaa Level 1 (0 points)

    This isnt working. I dont understand what you mean by disabling your ID then switching off imessage then signing out of your apple ID? How can you sign out if it was just diabled....

  • NY3Ranger Level 1 (0 points)

    Ultimately, I had to call At&T and they had to take my new phone imei and other information and updated their system.

  • TDowney2394 Level 1 (0 points)

    Hi,

     

    I have the same problem. Did you have any luck in sorting it?

  • Motoca Level 1 (0 points)

    This helped! Thanks! Although there should be a better way to resolve this issue...

  • auton8 Level 1 (0 points)

    Had the same problem. Reset my apple ID password. Problem solved instantly!

  • daroptical Level 1 (0 points)

    I actually figired this out (havent read the entire thread so apologies if it has already been mentioned)

     

    This actually worked for me:

     

    1) visit https://appleid.apple.com/en_US

    2) sign in with your Apple ID

    3) unregister device which was attached to your phone number

    4) turn off imessage on that Apple device


    That should fix it

  • bjonas97 Level 1 (0 points)

    kurthurst's method worked for me, and i had a iphone 4 verizon and switched to the S4 go try it!

  • Unavail123 Level 1 (0 points)

    This worked for me after trying everything!  I called Verizon,  they dialed Apple from their contacts,  the Apple rep had to go in his system and permanently delete my number from the imessage system,  he did not tell exactly how he did this he just said it was something that had to be done in his system and the system would update in 24-48 hours. Part of the process he sent a texted activation code to my cell,  I had to give him the code and it was fixed after about a2min wait time on hold.   I asked for the direct number to their direct number to their department and this is it 800-275-2273

  • MikeFarbr Level 1 (0 points)

    Uh oh... My sister has the problem in reverse. Longtime samsung user -upgrading from s3 to s4 to s5 - but only trouble with s5 (long story, finally gave up and traded in for 5c). Her phonenumber will not register in imessage. Any similiar experiences and tips? She no longer has the s5, as said, traded in.