Previous 1 2 3 Next 224 Replies Latest reply: Dec 27, 2013 12:47 AM by dongiaconia_ Branched to a new discussion.
Renesisdriver Level 1 Level 1 (0 points)

Why do i keep getting the following on my imac 27" when it does not happen on my ipad or macbook air?


"The Yahoo! IMAP server “” rejected the password for user "


Getting very frustrated with it.  I have tried removing the account and repacing and also changing the password. It is not the password entry that is the problem.  Any solutions?  All software up to date.

iMac (27-inch Mid 2011), iOS 5.1
  • leefromtiverton Level 1 Level 1 (5 points)

    Hi, to all out there, I to am getting this same message it started last night and is frustrating. I have also removed and reinstalled the mail account to find that it's happening again. It isn't the password that is wrong. Is it a network problem? Or do I dare suggest a virus on a apple? Please help because it's maddening to us both.

    Cheers Lee

  • Renesisdriver Level 1 Level 1 (0 points)

    Update, i am now having the exact same problem on my MacBook Air!!!!!!

  • leefromtiverton Level 1 Level 1 (5 points)

    What the heck is going on ??????

  • cakefordinner Level 1 Level 1 (0 points)

    I have several free yahoo accounts and it's only happening with one of them. I even changed the password and I still got the "reject" message...the first time (had to enter it twice into my keychain).


    Did manage to get a new email (from Yahoo letting me know I changed my password), without the "reject" message, so no clue if it will stick.


    Yahoo has been problematic for months...I don't even know how long. And, it's random. I never know which account is going to "time out" when I empty my Deleted emails or get new emails, but it's freakin' annoying as all get out.


    I still manage, eventually, to get my emails, but I wish they'd get their act together. Grrrr! Since they're free accounts, I send from my ISP (never a problem), but incoming is either fine...or it's not. It seems to change, from day to day and/or half hour to half hour.


    Try changing your password on the affected account, and maybe it will work...maybe. We'll see what happens 30 minutes from now, when my Apple Mail checks again. LOL

  • leefromtiverton Level 1 Level 1 (5 points)


    Re: Yahoo mail rejects password but only on iMac

    15-Mar-2012 14:12 (in response to clr99)


    Today took my iMac to the apple store in Exeter,England . We discovered that the main user key chain was sort of tripping over its self with saved passwords. What the iMac tech did was to delete the key chain and reinstall it, that was after we deleted my bt yahoo account and reinstalled it, I told him I had already done that a couple of times. Anyway after the key chain was reinstalled the mail asked for the password to be saved in the chain but then my mails started coming in, hey pesto a result, we logged out & and in a couple of times still good. Once home and set up, all was well for 15 mins or so then back to asking for my password, a complete waste of 3 hrs.

    I have sort of admitted defeat and am now in the process of changing my yahoo account contacts, iTunes, ICloud  etc. to a gmail account bit of a pain but I suppose I can get rid of all those rubbish emails I get.

    Good luck with the quest if I do get any news I will let you know, likewise please.

    Cheers Lee.

    P.s. if you look on the uk forum you will see we are having the same problem here and have quite an extensive discussion running with all sorts of ideas and solutions being tried. We now have apple engineers working on it.

    Like (0) Reply

  • Renesisdriver Level 1 Level 1 (0 points)

    Lee, many thanks. I too spoke to apple yesterday - got support as my MacBook is less than 90 days. We did the password reset thing also.  8hrs later problem was back! And the started working again.  Now I am getting some sort of CalDev message on my iPad. Loathed to changing email address as I have had it 20 years and currently job hunting. But this can not continue. On the funny side I did not realise I was on the US site! I live in Cheltenham area.

    Hope gmail works out.

  • SZobair Level 1 Level 1 (0 points)

    I am also having this issue. I've tried everything I can find online to fix it.

  • cakefordinner Level 1 Level 1 (0 points)

    This is definitely an issue between Apple Mail (which, frankly, bytes anyway) and/or the keychain, but I didn't bother refreshing the keychain...I got another mail app and the problem disappeared. I get ALL my mail, with no problems and I even got Rules to work, which I never could in Apple Mail. Plus, there are a bunch of addons (I haven't tried any) that look pretty neat.


    It's not a cheap solution, but I wasn't willing to wait around until Apple got their act together and fixed it...I'll be old by the time that happens.


    Postbox 3 $29.95 USD ($9.95 USD for upgrade only, if you have the previous version):



    There are plenty of other mail apps, all touted as 10 times better than Apple Mail (mainly because they work and Apple Mail doesn't). Sparrow is another one, although I never tried it, and it's only $9.95 USD:


    Both of these have free downloads (Postbox is a 30 day trial and Sparrow is ad-supported) from the developers, or you can get Sparrow in the Mac App Store. There are others, but I'm so happy with Postbox I didn't look any further.


    N.B. Some odd things have been happening with Apple, IMO, since Steve Jobs died...and it hasn't been for the better. At least, not for customers. Oh, well. At least there are developers out there ready to give us stuff to make our Macs work right. LOL

  • cakefordinner Level 1 Level 1 (0 points)

    Just to qualify my previous response, it may NOT be only Apple may also be Yahoo or a combination of both. At any rate, I've completely stopped using Apple Mail and the problems are gone (it's been 3 days, now) since I started using Postbox.


    NOT a solution, but it's a perfect workaround...if you can afford the $29.95 USD.

  • robertfromperth Level 1 Level 1 (0 points)

    This happened a few months back with Mail... and seemed to go away after deleting the records from my keychain.


    However, it's been back for over a week. Deleted keys from Keychain Access app, and changed password. Removed and re-installed Yahoo account from Mail and still no joy. Thought I'd splash out £6.99 and get Sparrow (another mail client) - very nice app, but has not changed the password situation with Yahoo. For info, I'm getting the same problem with a Sybmbian device, but not with iOS.


    So I'd say the problem largely lies with Yahoo and its IMAP servers. My only solution to date is to use another mail provider.


    Wish there was an easy way of contacting Yahoo to address this.

  • mick571 Level 1 Level 1 (0 points)

    I am having same problems with yahoo mail account "rejected password". Have found that to log out of your yahoo account on their web page, and log back in again, then just delete the "rejected password" message, will bring mail back working. For me it then works until I put the mac to sleep for a while, the the message comes back possibly 4-5 times a day. If I leave the mac running it seems ok. Have tried the keychain stuff, no go.

    Have been onto Yahoo, they say they have a few problems at the moment !!. But - no specific details of the problem.

    Have been directed by yahoo to their help line - dont go there unless you have 1.5 hours to spare, and you understand Indian. I'm from uk and dont understand a word. Very embarising. No use either, wanted to take control of my screen, no chance.

    If anybody out there can help us all - please help!!! I suspect it has come since the latest apple update, anyone else agree?

  • toddgrx Level 1 Level 1 (0 points)

    I experienced same in Mail program on iMac running Mac OS Lion 10.7.3.  My resolution:


    1. enter Spotlight... search "Keychain Access" and select application

    2. once Keychain Access open, be sure to select "login" from Keychains and "all items" from Category

    3. highlight and delete affected keychain... mine was ""

    4. now open Mail program and select preferences

    5. choose Accounts and then pick Account Information

    6. my "Outgoing Mail Server (SMTP)" showed "<my account name here>" was "offline"

    7. I picked "Edit SMTP server list" from dropdown list and entered my password (field was blank) and clicked OK

    8. now <my account name here> did not show "offline" and once I closed preferences, closed program and reopened program, I haven't gotten the "rejected password" message again

  • mick571 Level 1 Level 1 (0 points)

    Thanks for the reply, will try that when it next comes upwith the message.

    In section 7 of your post to enter password - i assume you mean in the advanced tab.

    Thanks again, will be in touch later.

  • mick571 Level 1 Level 1 (0 points)

    Just got the message again, went to edit server list and my password was there.

    What now !! Thanks anyway.

Previous 1 2 3 Next