Previous 1 2 3 Next 30 Replies Latest reply: Oct 21, 2014 11:33 AM by FromtheOrange
Eric D. Level 2 (185 points)

For the last day and half, I've been unable to access my iCloud email through Mail on Lion.  I get the following error:


The server returned the error: The connection to host on port 143 failed.


According to the system status, iCloud Mail did have an issue but apparently they think it's resolved.  Anyone have any idea why I'm still getting an error?  I have no problems accessing iCloud Mail on any other devices or through Safari.

iMac 3.06 GHz 24, Mac OS X (10.7), 4 Gigs RAM
  • Eric D. Level 2 (185 points)

    Still not working today.  Yesterday I got a message asking for me to enter my password for my iCloud mail account but then nothing happened.  Today the error has changed slightly.


    The server returned the error: The connection to the server “” on port 143 timed out.


    The iCloud System Status page says everything is working but it's clearly not.  Anyone else having this issue?

  • thoughtsponge Level 1 (0 points)

    I too have been seeing this problem time and again.  My error is message is as follows:


    The server returned the error: The server “” refused to allow a connection on port 993.


    Have you had any luck fixing the issue?

  • Eric D. Level 2 (185 points)

    I found a suggestion that said to either check or uncheck the Mail, Preferences, Accounts, Advanced, SSL check box.  In my case, it wasn't checked so I checked it which switched the port to 993 and then it started working.  I also read that unchecking it to switch it to port 143 might help too.


    I have no idea what changed but it appears to be working now.

  • thoughtsponge Level 1 (0 points)

    I still seem to be suffering from the error after the change.  Now my error message is as follows:


    The server returned the error: The server “” refused to allow a connection on port 143.


    Any thoughts?

  • Eric D. Level 2 (185 points)

    I'm not sure what your issue might be although "refused" might be the key word in the error.  To me it sounds like you're getting through to the server but it won't accept the connection.  That sounds like a password problem but that's just a guess.  Are you able to get into your mail via Safari?  You might just want to double check to make sure your password is correct in Mail Preferences, Accounts.


    The other option might be to delete your iCloud mail account and re-add it in Mail.  Since it defaults to the correct settings, maybe Apple has changed something that will be fixed if you add it back fresh.  Since the mail is stored on the server, you shouldn't loose anything but you might want to make sure you have a recent backup, just in case.

  • Barricudda Level 1 (0 points)

    That totally worked Eric ! Thanks ! Tried all but failed but deleting readding the account worked like a charm.


    Cheers Mang !



  • Roger Wilmut1 Level 9 (75,119 points)

    thoughtsponge wrote:


    I still seem to be suffering from the error after the change.  Now my error message is as follows:


    The server returned the error: The server “” refused to allow a connection on port 143.

    SSL and port 993 are definitely required, that's why it's refusing the connection in this instance. As suggested above, signing out in System Preferences>iCloud and signing back in again (provided you have Lion 10.7.2 or .3) should set it up correctly.


    If it gets set up correctly and is still failing it may be a server glitch which you would have to wait out.

  • kimmeth Level 1 (0 points)

    I tried deleting and re-adding my email account on my iphone - it DID NOT work. Certainly don't want to try this on my computer now... Not getting anywhere with changing my password online or switching ports.

  • Barricudda Level 1 (0 points)

    You have to do it on the Mail App on your desktop. It does not apply to the iOS5 platform.

  • kimmeth Level 1 (0 points)

    I did. The results remained - it didn't work for me. All devices, changing password, deleteing/re-adding acount, changing port/SSL in the mail app on my workstation, and on the laptop, even logging onto iCloud-online - no email, period. Eventually got support on the phone, answered a bunch of questions, sat on hold, got passed on to a supervisor, sat on hold for another while and they came back saying my email was in migration and I should be back online tomorrow - TOMORROW!


    I promptly lost it. Completely. I "migrated" weeks ago! And if that wasn't migrating what was I doing? Well, apparently although I migrated all my devices after updating software and had done everything right, I hadn't actually been moved onto the new iCloud servers and there was a bottle neck somewhere in the process that should have finished at 3:30 am without my ever being aware. Lots of apologies were extended but nothing could be resolved sooner - frankly I almost lost it again hearing this because the business day was over and I have no idea what was missed because of this. She did however give me her number to call her in the morning if it had not resolved - by the time I finished talking to her exchanging info and cooled off (about 15 minutes later) the problem resolved itself and I am back up.


    & now if you will excuse me I now have an outgoing issue to address (errr!)... I will leave with this clue however - I was told that if you are not having success with any devices but are able to at least log-on at iCloud-online, even if you still can't access email there (contacts/calendars appeared fine, just could get email to load), then its not you. You need to call support... or wait for it to clear on its own.

  • DALH70 Level 1 (0 points)

    hey kimmeth,


    try doing the following:


    - Make sure that you have the latest Software Update

    - Go to KEYCHAIN Access

    - Under Keychain Access / Preferences

    - RESET My Default Keychanges


    Restart "MAIL" and your password should work.

  • AppleNovice Level 1 (0 points)

    This seemed to work for me-- I got me email, but why do I continue to get the "Enter Password for Account iCloud" message.  It just won't stop popping up.

  • danielvasques Level 1 (0 points)

    I am having the same issue, AppleNovice.

    Working on Macbook Pro running Lion (10.7.3)

    Mail just doesn't work perfectly with my icloud account.
    I get my emails almost normally but every now and then I get the popup message asking to type my password.

    I have already deleted my account and made a new one, with no success on this issue.

    I was getting the connection to the server "" on port 993 timed out. So I unchecked the SSL and 993 port changed to 143. So now I get the same message, only from port 143.

    My password is correct since I can log on to icloud and see all my emails there, and both my iOS devices are working correctly with the password.

    The issue is only with mail on my macbook pro. And it's not all the time.

    But it is very annoying, and seems like there is no answer to this issue anywhere

  • AppleNovice Level 1 (0 points)

    I agree.  It's confusing and pervasive.  Apple should have a step-by-step trouble shooting guide by now on this problem.  Mine is working fine, now.  I can't tell you what exactly fixed the problem, I can, however, tell you that this was not the first time my family and I experienced this problem.  Synching multiple devices over one account is complicated and deserving of detailed explanation and settings descriptions. 


    C'mon Apple, provide the detail we need to fix this now and avoid it in the future! 

Previous 1 2 3 Next