Previous 1 2 3 Next 201 Replies Latest reply: Mar 31, 2015 8:32 PM by JobHarrison
Ryan Samoheyl Level 2 (185 points)

I am having issues with my Apple TV 2 dropping from Home Sharing after roughly 5 minutes of usage.  I currently have the latest updates installed for iTunes, Apple TV and my time capsule router.  I've done a hard reset on the router, my modem, turned off home sharing and turned off Wi-Fi sync.  I've also turned off home sharing on the Apple TV, reset all my computers (two MacBooks and a MacBook Pro all running 10.6.8) and then restarted everything.  The system works for roughly five minutes, but then the problem starts up again.  The system used to work fine, but I've done a few things recently that may have started the problem, such as installing the newest version of Apple TV, installed iOS five on my phone and purchased two new iPads.  I feel confident that the Apple TV is the issue, because the same thing occurs with all three of my computers and airplay and mirroring does not work with my iPhone or iPad's.


I've search the forums for other fixes, but haven't come across anything that seems to work.  Does anyone have any other suggestions on how to solve this problem?




  • SoundForSound Level 1 (15 points)

    I'm seeing this behavior as well after 12 hours or so.  Restarting iTunes always fixes the issue.  For some reason after about a day apple tv just will not connect to the computer.  Restart iTunes and it instantly connects.


    Not too sure if my issues started with the new iTunes version or the new apple tv SW.  Either way I hope they fix this soon.

  • Jason Wilhelm Level 1 (15 points)

    Misery loves company right? I just picked up a new Apple TV (s3) and am having the same problems as above. I seem to get closer to 10 minutes or so of streaming a podcast from my macbook(10.7.3) then the connection drops and I get booted to the apple tv menu. Trying to get back in to browse the computer I get the message to start home sharing on the computer. On the macbook front nothing seems to go wrong.


    The only other thing I have noticed is that I am having a problem where I do not have the airplay button showing up in the bottom right of itunes.

  • R2742 Level 1 (0 points)

    I noticed this issue as well after upgrading my Apple TV2 (original) to the new software.  Apple's Apple TV head tech indicatd this is a network issue. I have to either shutdown itunes ( windows XP Pro), disconnect/reconnect home sharing or a combination of the above. I do not sem to have the problem when transmitting from iPhone, or iPad.  Two seperate routers (ATT Uverse , Netgear Dual Channel G and N) have same issue. I did not take the time to try and determine what the "network issue" was. I sent the Apple TV2 back for a refund. Luckily Amazon Prime was more cooperative then Apple.  This was one of two issues I ran into after upgrading to the new Apple TV2 software. May have been coincidence on the dropping out because I only hade the Apple TV2 original for a few weeks...hadn't rung it out yet.  I have plenty other of network Theater Systems/Computer/iPhones/iPads/PlayStations/XBox's/TVs and no other device drops audio nor video like this product.  If its a network blip, they need to work on their Error Recovery Procedures... not to drop out the system completely. It appears from the previous post this is happening with Apple Computers as well.


    I would be curious if this is happening to anyone on the 4.x.x s/w on the original Apple TV2? Unfortunately, once you upgrade you cannot go back to the original s/w level even from restore. The Apple TV2 engineer infrormed as I verified as well on the phone. By the way, he was very friendly and informative.  But said unless there is a lot of feedback on the Dropping of the SSID passwords and this problem... it was less likely to get address. If you are an unsatisfied Apple TV2 user, makes some noise. I was lucky to have Amazon accept my return... Apple would not because I was beyond the time period when I upgraded to the new level of firmware. This is a ridiculous practice if they won't allow me to go back to my original firmware that was shipped with the product and working.


    I have many apple devices, but this is one of the reasons I will not purchase a computer they allow you less and less capability to try and resolve problems on you own, via h/w / battery/ or memory upgrade.


    They do monitor these feedbacks so make some noise if you want the problems addressed.

  • dananutter Level 1 (0 points)

    Blaming it on your network sounds like a copout.  I have a GTV and Roku with and neither has had any problems dropping the network connection.  Likewise it will come back if I go to ITunes then disable and reenable Home Sharing.  At some point I put a static IP on in and it seemed to help though the problem actually got much much worse after the new software installed, even with the static IP. 


    I'm about ready to send this thing back for a refund.  It's worthless if I can't even sit back to relax and watch a movie without interruption.

  • guyjacques Level 1 (0 points)

    Same thing here... everything fine. Network tested, wifi... only atv2 drops home sharing every 5 mins while watching from MacBook Pro iTunes latest version to atv2 latest version.


    Was fine before, problem occured since lastest update.


    Thanks for looking into it Apple... can't watch any movies for more than 5 mins now!!! This apply to any movies, paid from itunes or backup movies into iTunes.



  • Ryan Samoheyl Level 2 (185 points)

    Thank you to those that have posted similar issues to the one I'm experiencing.  I'll be submitting my problem to Apple and I encourage others to do the same.  If anyone else is experiencing similar issues can you please reply to this thread so Apple can see how large the problem is. 



    Does anyone have any other suggestions on how to solve this problem other than those already tried?




  • dananutter Level 1 (0 points)

    It's definitely not a network disconnect because I'm able to ping the ATV even when it's "down".  If you quickly turn off Home Sharing on the ATV and turn it back on it will work again, at least for a while though this is not really a solution.   From all my tinkering, i'm guessing it's something to do with losing it's link to ITunes Store of whatever it authenticates with.  I still think it's ridiculous that I should have to maintain any kind of external connection at all just to stream content from within my own home on the same subnet which is the only reason I bought this box in the first place.


    I'm done wasting time on this and haver already set up an appointment on the Support so I can ask for an RMA. 

  • colin415 Level 1 (0 points)

    I too just bought a new Apple TV (Gen3) and noticed the Home Sharing disconnect problem.


    It MUST be an iTunes bug, because I can watch Netflix streaming content without interruption.


    ONLY when I attempt to view content through Home Sharing does the disconnect from iTunes occur - generally between 5 and 10 minutes after selecting the content. 


    Yes, restarting iTunes or turning Home Sharing OFF and then ON again will resolve the problem, but really, that is unacceptable.  This is NOT a network issue - sorry Apple, finger pointing won't work this time.


    Lately, I've been having far more issues with Apple products than Windows PC products - including the "New" iPad and now the new Apple TV.

  • laisla Level 1 (0 points)

    I would like to share my experience, it might help others. I had ATV 1 and ATV 2 connected via wireless and Airport base stations with no problems or issues. Updated all to the latest versions, including my main computer using OS X Lion. After the last Airport update, both the Utility and the firmware, i received my two new ATV 3s.

    Then the problems started. I found every day, several times, the problem of missing the ATVs in Airplay and not being able to load the libraries. The obnoxious spinning wheel on the ATV and the never ending "loading XXX library" message.

    After reading several posts, resetting airport, itunes, atv, turning on and off home sharing, the problem did not disappear.

    I decided then to change the Share name of my iMac, change the name of the iTunes shared library and choose custom names for both ATV 3s. Reset everything and it seems to be working, while i have not done extensive testing yet.

    It seems that, for some obscure reason, the association between the names of these objects, bonjour, wifi and wireline setting, got corrupted. Seems to me that some ARP or reverse lookup was not completely working.

    Since this was so frustratring, i want to share so others can elaborate as well.

    Good luck.

  • Shihtzustaff Level 1 (10 points)

    I am having the same problem as well. I updated my ATV 2 and the problems started. I can stream stuff from the cloud through iTunes Store but not watch something that is sitting on my computer. It is becoming extremely frustrating.

  • jfmclaughlin Level 1 (0 points)

    it seems that the reliability of apple products is going the way of microsoft. too much time spent on the ipad and not enough time making sure things work as advertised. after their "ios-ified" update this thing has turned into a worthless piece of garbage. if you can't get it right call it a "hobby. im having the same problems, why did things work fine before the update? i can't wait to see what happens after "mountain lion" comes out, i'll pass thank you.

  • R2742 Level 1 (0 points)

    Hello, thank you all for your updates. As my orignianl post/ and the thread started by Ryan Samoheyl indicated the Apple Tech I talked with on the phone did indicate the Feedback is watched and one the best way for the public to influence what its an import item to fix.  I wanted to expand on my post as I see there are a couple other factors that he gavet that may come into play.


    I actually hit two "issues" (both I believe which were after the ATV2 (original) update to the new firmare.

    1.) The Wireless password information is lost.  When you got to see which wireless networks are attached and to select one the pw is goine.  Personally, I find this unacceptable as well and pointed out the iPhone remembers. Even though this net appliance(term?) is not moved. I need to select from several routers with different SSIDs that grew as I expand my network through a large home with limitited ability to hardwire.  Grant it I might not have the best router configuration, and the Apple Tech made some suggestions (but I am not an network whiz and as there are many clients I get nervous about taking out the whole system). Swithing to ATT Uverse seem to make the matter more complicated and less supported because the required there modem/wireless/routuer as one unit. And don't support mulipltle transmitting router.  Long to story short I have the Uververse modem (B/G), conncected to a dual channel Netgear (B/G/N) - one channel B/G, on N.  The N channel goes to an Netgear HD Access Point in my home theater connected to Denon AVR-3311CI network AVR (the importance of that will come in soon).  As in another thread I have. The tech (which I happen to talk with either the Lead service or engineer tech for Apple TV). I have his email to provide additional data... but I was to return my APPLE TV2 (orig) through Amazon Prime, after hearing my situation. I am still quite interested in purchase several APPLE TV2 (new) if the issues are resolved.

    @lasila - as many SSID popped up on my wireless(many not mine). The teck recommended I make sure there is at least a 2 channel separation between mine and any other broadcasting router. I wonder if there is some background auto selection going on based on signal strength (I have some products that won't let me choose my N channel because they thing the G channel will be better because the signal strength is stronger).did


    Personally, I did not try this.  I rendered a linksys/cisco repeater, alowng with the cisco bridge access point useless once playing with changing channels. I still haven't gotten the bridge functional at all again. And of cours you have to pay for their technical support these days. Anyway, each channel I believe he said was 2Ghz appart and you can get interfence, drop/reconnects.


    If you try channel seperation..please let me know any results. Note: I had to restart ATV2 at one point. I was a little upset restart would not allow me to go back to my original firmware. (I work for a large computer co. We usually allow the ability for at least two firmware levels so the customer can revert if something is wrong with the "new"). Let me just say I will not buy another Samsung device (other than monitor)...and a "bad" firmware update that made available on network,and later replace with new level at same name, bricked my expensive Blu-ray player, and they would not warranty the labor(luckily i still feel under parts). Note, even after paying to get it fixed... it had numerous other lock up issues. Anyway, point is end-user should be able to go back to prior level of firmware, so the product is not worse of than you started.


    I do have a ticket open with his work email, so the problem is on the list. Actually, I'm not sure from the note which item (dropped Passwords or Network issue).


    He kind of brush over the netwrok issue because of my setup. Not I have a WINPC(XP) with iTunes. I have an iPhne running the ATV2 remote, and the ATV2, I won't complicate this with the iPad and other devices.  All MUST be set to the same SSID or the wireless router the iTunes computer is connected. (As was hoping since one network, any id would work...not such luck ... found this out with ATT uverse Ipad app.(with the remote as part of its feature, pretty slick once wokring)


    Anyway, he suggessted I brigde my Netgear to ATT Uverser box.  Like I said this is a little ominous and I need to connect to the Bridge Access point which even though is suppose to be "push button" is tricky getting to work on its own.


    3.) Next to make things more interesting I just applied the Airplay upgrade to my Denon AVR-3311CI.  Anyway, who could point me to a thread on this discussion would help. My Denon iPhone Remote App not longer sees the receiver. My iTunes does not see the Denon Airplay as an Airplay device.I'm not sure if because its connected to the supposed transparent Access Point or not. (The Denon Remote app used to be apple to see it using the Netgear Brigde SSID


    I'm hestitant to change to mch as once and it hard to unwrap which variable was the final domino. As I indicated earlier. My lower recording room with that had cisco brigde (with PC/Mac G3, and two printers is has been down endlessly because I got so frustrated with the cisco bridge. Oh course, you have to turn off wireless security... so it takes my whole system out (including I actually telecommute as a s/w engineer) out.  That connectivity I require and use Wireless-N with higher seecurity connection required.


    Anyway, I hope the channel separation works. Note, I believe the key is iTunes with ATV2 new software. Its usually always the home sharing, or iTune s/w I have to "reboot" to get things working.  In a perfect world I would be listening to my iTunes, through my family rooms home stereo, via my Denon Inet raido.... hehehe...what a geek.  Computer Tech Support is not suppose be my "down time" job at home .... heheheple


    Apple comes sooo close to make things easier and the "cool" apps. But its getting more (Wintel/Big Bluish) all the time.  


    One other wrong thread question I wound't mind a pointer to. Is there someone out there that really desribes how to get iTunes to work as a decent media server.  The number of dups, orphans, and asunder I can't seem to clean up with internal iTune feature is abhorent.  And to the point where it is overloading my iPhone with thousands of dups, and half albums...that already overloaded my new iPhone (don't get me started on them not allowing me to upgrade memory).  


    My apologies if some of this sounds like rambling... I am currently on Cancer treatment, with morphine, and high antibiotics with secondary infection. So apparently Incoherency, and cognitive ability imparment is one of the side effects... but when else does a s/w engineer get time to start debuggin his "entertainment" network.

    I will try to keep my posts shorter in future, Any pointers to thread on Denon Airplay, bridging, or iTunes as useable media server (note: music is my hobby as we're talking thousands of songs.. and I an Oldster who likes hard media, so most of its ripped from CDs,DVSs.) The"LPs" haven't been digitized yet.  I have multiple computers...most use the NAS support which is also on the Netgear router. But I would prefer moving to apple if I can get things clean and working properly.


    <soapbox on>

    Note : Sorry Apple... all you cute h/w that seems to limit the user's own options to update (memory,battery) upgrades...and In general with the expection my last conversation with the Apple lead... I refuse to move to it as my work platform.  Seriously, should I have to go to "Genius" bar for a supposedly user friendly device. I know you kept it most proprietary to minimize hacks, piracy, etc. But my experience with "waiting" and then finally getting to a Genius have not been typically helpful. My old 3Gs had a wireless issue, and they didn't even have an in-house system to test it. Hours wasted, and fruitless, try to update the firmware again.  And why not more consideration for your loyal customers. I am ashamed to admit how may Apple products I have purchased, and try to justify to techy friend's why when have the blue, hot spot, etc features are crippled and the "service providers" rape you for additonal service costs...compared to android base market...anyway..sorry... i slipped on my soapbox.


    Maybe I should see if I can go play "Adventure"....(to my the other oldies out there, and yes at least i didn't mention the old mainframe game)

    <soapbox off>

  • dananutter Level 1 (0 points)

    Okay so I set up an appointment with their Support.  I was at work when they called but the tech claims Apple product have problems with WEP (the iPod outside the house, in the glovebox of my car, behind tinted windows,  stays connected just fine).   I really don't know how my wifi was set up though I'm pretty sure it was WPA or WPA2 because at some point I lost the admin password.  So when I got back home I reset the config on my router (Buffalo WHR-HP-G300N) and reconfigured it completely from scratch using WPA2. 


    The good news is that my ATV has been working without interruption ever since.  Hopefully it will stay this way.  At this point the ATV is still on DHCP but I'll probably assign it a static IP later just so I can easily identify it when I need to.

  • askbugsy Level 1 (0 points)



    I just wanted to add my voice to growing frustration with ATV2/Itunes/Home Sharing.

    I was really excited by the upgrades to the apple tv so as you do upgraded both my ATV2's, what a disaster.

    Pre update, i had no problems with home sharing, very rarely if ever had any glitches and when I did they were easily fixed inside of 5-10 mins max.

    Post update, I can't get either ATV2's to see my itunes library, the remote app on my ipad/iphone4, can't see my library, I can if I do the whole rigmarole of switching home sharing Off/On manage to push a video to the ATV2 but as soon as I come out of that video, the connection is gone.


    I would have to agree that it is nothing to do with my network as both ATV2's can see the interner and I can browse through you tube and watch anything with no problems, likewise I can access the store and watch trailers again, with no problems.


    I have tried various suggestions from the forums but nothing works, it is so frustrating.


    I have had no issues with Lion or with any update until now, maybe i have been spoilt, however we all pay a premium for Apple technology and expect things to work without us having to spend days on the forums looking for solutions.



    APPLE, please note, this is not acceptable and not up to the standards that Steve Jobs set as the benchmark of Apples product promises. Apple fans are very loyal and spend a lot of time pointing out to Windows/Microsoft how much better Apple are at making sure updates etc work before launching things, this reputation will be easily lost and take a long time to restore, please get this sorted.

    If you (Apple) do indeed monitor these forum threads then at least acknowledge there is an issue and give us an indication of what your doing about it.


Previous 1 2 3 Next