Previous 1 2 3 4 Next 58 Replies Latest reply: Nov 13, 2013 1:28 PM by gregrgay Go to original post
  • santranyc Level 1 (10 points)

    The manual says "This command is only available for Perl and Python scripts." They've got to be kidding!

     

    I have no idea how to get this program to flag the bad syntax.

     

    Searching for "Syntax" in the Help manual expects me to use Grep. If I was up to speed on grep and Terminal, I'd use that and not bother downloading TextWrangler.

  • santranyc Level 1 (10 points)

    I guess I need a XML validator first before I use TextWrangler?  Not sure who offers a good one, and I'm loathe to go back to Bare Bones for another program, since TextWrangler has been so disappointing.

  • gamcall Level 1 (0 points)

    Yep - if Apple aren't mining the discussions data they're missing out on a big resource.

  • gamcall Level 1 (0 points)

    You simply need to select "XML" from the language pop-up at the bottom left of the window. That will then colour-code the syntactic elements of the language selected, but unfortunately not *validate* it. I actually used ActiveState's Komodo edit, which does on the fly syntax validation. Sorry for the bum steer. In TextWrangler, searching for syntax brings up grep because there's the term "grep syntax"; i.e. the syntax grep uses. I don't think they're expecting you to use grep to validate XML, although, if you were a regex guru, you could. Don't think badly of TextWrangler - it's a great program, as is its big brother, BBEdit.

     

    So, you can get Komodo Edit, or, as I said in my previous post, refer back in the thread where the poster tells you how to use xmllint & vim in Terminal to find syntax errors . I didn't actually use that process as I had some questions of my own about the process & he didn't get back to me about them. As I said also, even after I'd validated the syntax of the library XML, it was the voice memos which were the real culprits for me.

  • Shaun Kennedy1 Level 1 (55 points)

    After reading this... I Iooked back at my library...saw I had three voice memos that were recently imported.  Deleted those buggers and all of the sudden the test screen worked...exited there and the screen saver works...da*n voice memos!!!

    thx

  • topdog417 Level 1 (0 points)

    Mine worked after I did 2 things. Which of the two fixed it I don't know. Updated to Lion and also found 3 voice memos that I deleted. I then went to screen saver. Clicked off of iTunes art work then back on to it. Tested it and it worked.

  • Hywel Thomas Level 1 (10 points)

    Deleted iPhone voice memos from Music and the screensaver kicked back into life.

     

    Cheers!

  • bwberge Level 1 (0 points)

    Can you tell me how you found the phone messages? I have my library on an external harddrive and not sure hoe to get to the right place to see if there are phine messages in itunes.

    thanks!

  • Shaun Kennedy1 Level 1 (55 points)

    I think they were listed as voice memos.....not much else..if your screensaver just stopped they should be at the top of the list if sorted by recently added...

    They were really short duration as well..

  • bwberge Level 1 (0 points)

    Hi Shaun,

    thanks for your input. Can you tell me if i need to actually go into itunes and scroll through my files to see the voice messages?

    Is that how they are listed in itunes?

    Thanks,

    Brian

  • Shaun Kennedy1 Level 1 (55 points)

    Yup. Just load up itunes, sort by recently added, and hopefully they're at the top of the list!

  • gamcall Level 1 (0 points)

    Or - make a smart playlist based on media kind = "voice memo".

  • Mark Thacker Level 1 (0 points)

    YES! The process of deleting my iPhone's voice memos cleared up the screen saver issue.

    I had even renamed some songs that contained valid characters (upside down question mark from Spanish) to no avail. But I found my voice memos were named "Mark Thacker's Memo" or something like that.

     

    Deleted and restarted iTunes holding down the option key (just for fun) and re-chose my existing library.

     

    Launched the screen saver and everythign is fine.

     

    Note tha this is running iTunes 10.7 and MacOS X 10.8.2 on a MacBook Pro.

     

    Thanks for the hint - wasn't looking forward to editing a bunch of XML today!

  • CAMori Level 1 (0 points)

    Wow... been living with this for a while.  Just deleted the voice memos and voila! instantly working again!

     

    Thanks!!!!!

  • kottke Level 1 (0 points)

    Instead of deleting the voice memos I converted them to Apple Lossless. Now they upload to iCloud and the album art screensaver works.