Previous 1 11 12 13 14 15 16 Next 230 Replies Latest reply: Dec 8, 2014 10:08 AM by bradmcconnell Go to original post Branched to a new discussion.
  • Stefan_Diefenbacher Level 1 Level 1

    I've just checked my serial number and will bring my device to the next apple store:



    The statement about third and fourth is wrong, it's fourth and fifth digits!

    See generation-apple-tvs-with-wifi-connectivity-issues/



    My serial applies for a test as my serial corresponds here.

    I've had problems with the device since the purchase.


    Hope this is related to the dropping connections problem here.

  • 082iphone4s Level 1 Level 1

    This ATV is driving me up the wall and is begging for a bashing with a hammer!!


    Had it now for about 6 months, worked fine until the updates came for ATV.


    I do not have and antivirus: so it is nothing to do with the firewall or IP address settings - I don't care what all you so-called experts say!  "Apple came to the same conclusion" - please spare me the bull


    THE ATV DROPS THE WI-FI signal for no reason whatsoever!!


    Tested iTunes for accessing internet while streaming to ATV - iTunes keeps working while ATV fails to get WiFi.


    The only conclusion: Apple has no clue how to fix this issue - do they even read this forum??? I guess not.


    Keep making like Airbus - build a new plane and let the customers find all the faults, then you try and fix them - Oh, I forgot - you don't fix your problems...


    BAD SHOW APPLE!!!!!!!

  • carlos32 Level 1 Level 1

    I nave the same issues, Frustrating!, i bougth this apple tv because i dont want use cords , but the real it's tha the apple tv dont work well.




    Please apple answer and give us a solution.

  • Richard Philips Level 1 Level 1

    To make apple tv work flawlessly simply go to your preferences and set your computer, laptop or desktop to never go to sleep. You can either set this permanently or just when you want to use apple tv. I prefer the latter. Everytime I want to use my apple tv I go to my settings and set the never sleep option and apple tv works fine.

  • Corgifan Level 1 Level 1

    Doesn't always work.  I have three Atvs at my home not updated to 5.2.1 and all work fine.  Same setup at my friend's house, (iMac, airport, ATV) with 5.2.1 updated and both iMac and ATV told to NEVER sleep, still drops signal constantly.  I go over and re-set it during the day and every evening it is gone.  Sometimes connection lasts a few hours sometimes almost a day but always drops off.  Seems software update is the only difference.  I'm going to take one of my ATVs over and see if it will work with older software version.  Very frustrating as I convinced these friends that ATV was great and they absolutely HATE it now!  The serial numbers don't match the recall and models are exactly the same at both houses.  Not sure what else to do. 

  • Stefan_Diefenbacher Level 1 Level 1

    My device was replaced, no more problems since.


  • 082iphone4s Level 1 Level 1

    Got replacement ATV, same problems...


    Was quick enough one day - it sems the ATV is not the problem acording to this new issue.


    When the ATV quit playing a movie, I got up on frustration and saw the Airport Express light is blinking amber...


    Since then, everytime the ATV quits, I saw the Airport Express light go amber.


    Now please, where in the **** is problem really??  Maybe Apple needs to update the Airport Express software/firmware.


    Is there a program out there that can monitor and create a log file on Mac of the Airport Express WiFi activity?

  • agruber Level 1 Level 1

    Hello there, I sense your frustration with this issue and would like to help. Please understand that I'm no expert nor do I claime to be. I can only tell you from my experience how I resolved my issue. You have not given much information out on how you are using Apple TV, how is it set up? Hardwired or primarily using WIFI?

    Are you attempting to "Homeshare" your ITunes account from an existing PC or MAC,?

    What is your Internet connection? Is it DSL or faster? If you have your enrtainment center including your ATV in 1 room where is your internet and router located? Are you using more than 1 router?


  • jnbworks Level 1 Level 1

    I have the same problem. A brand new Apple tv3. It plays a file from the library, if you go to play another video - boom! Down it goes.  Only solution so far is to close itunes and re-open. It then plays one more video.


    Itunes version 11.2.26.

    Apple TV 3, latest fw.

    Laptop - MSI GE70, connected by Wifi to Netgear Wifi with cable broadband router.

    Wifi setup with WPS2 security.

    Itunes 11.2.26 running on  clean install of Windows 8.

    Got fed up of the Windows 8 bugs so I installed a fresh clean install of WIndows 7 Ultimate. Same problem.

    No virus protection or firewall yet as just put clean install of Windows 7 on to test this out.



    I have reset Apple TV to factory settings. No difference.

    Re-installed windows.

    Setting pc to never sleep doesn't fix issue.


    I've tried setting my router firewall off to test and it made no difference - still got this issue. I've switched it back on now!


    I'm at a loss as to what could be going on. Sounds like itunes gets bogged down somehow.


    Apple - please fix this!

  • agcling Level 1 Level 1

    If you are running itunes in Windows 7, which is what I'm using, the Windows firewall setting had caused the same problem to me as described by you. You can try going into Windows Control Panel, Windows Firewall, check if your Bonjour service's checkbox for Public is set, if not, trying setting it and see if it works. I was pretty sure my problem was caused by the PC's firewall because when I disabled the Windows firewall, everything work fine. After which, I narrowed down to this Bonjour service which need to be set for Public.

  • 082iphone4s Level 1 Level 1

    Hi agruber


    Here is my setup: I live in a double storey brick home...

    - ADSL line with Netgear N300 DGN2200v3 modem (upstairs)

    - Time Machine (1TB) Ethernet connection to modem

         Time Machine Generates WiFi signal

    - Airport Express (1st Gen) in kitchen downstairs to extend WiFi

         This setup works perfectly for connection with other devices - MBP, iPhones, SONY TV etc - no problems...

    - Apple TV (3rd Gen) about 5 meters away from AE - WiFi connection near line of sight between AE & ATV

    - Using Airplay from MacBook Pro (13" Early 2011) with USB (USB 3.0 able) WD 1TB HDD (ADSL is too slow for direct streaming, so download to USB drive, then use MBP to do Airplay)


    So Apple stuff only - Time machine -> AirPort Express -> Apple TV, no windows or android to interfere here!!


    The problem is that ATV will work perfectly the one day, the next day it will work for about 15min and then the ATV will give message that iTunes Homesharing is turned off.  Go to settings of ATV and the WiFi connection will be there again.  Continue watching program and it will quit every 2min or so - I get upset and reboot ATV, AE and MBP - or it will not give the error again for the rest of the day.  There is no set sequence of failures to track to one specific event.


    As stated, the one day I was quick enough to see the amber light flashing on the AE - do not know what this indicates (no WiFi, power supply etc) as I have no way of tracking the usage and general "health" of the AE.

    (thanks Apple, for taking this function away with new AirPort Utility)


    It flashes for about 15 sec and turns green again - this only happens when the ATV is busy with Airplay.  Normal connection with iPhone, MBP gives no such problem - EVER!


    The ATV has been replaced, but gives the same problem.  I suspect now that the problem could be with the AE, but it is a passive device - just relaying information....


    I'm contemplating getting the new AE, but forking out the money and still having the same problem is not ideal.

  • ron310 Level 1 Level 1

    I was able to finally get mine working.

    I have a windows 8 PC with iTunes running.

    I have an Apple TV3, and an ipad mini.

    All devices would constantly lose their connection.

    The only way to get it to work was to turn off home sharing on the win8 PC and restart it.


    Here is how I resolved it:


    I went into windows firewall and removed bonjour from the allowed services. I then uninstalled bonjour from add/remove programs.

    I left iTunes (latest version) alone.

    I then downloaded the bonjour print service from apple (I think it was version 2.2, whatever the latest is).

    I installed the bonjour package and turned on the home share.


    It's been 2 days now and it's still fine.


    Hope this helps someone...

  • jimimck Level 1 Level 1

    I had this issue on my ATV2 late last year. Running a PC with windows 7 home.


    I finally got so annoyed, I called the Apple helpline, and was walked through a very simple solution to downgrade the software version on the ATV itself. The staff member acknowledged the issue, said it was something they were aware of, but had no solution at the time (November 2012).


    I was emailed a process to follow, that basically had me down load an old ISPW file for the 5.02 version (these acronyms and version numbers are just off the top of my head, as I'm not at home with the actual details, so apologies if they are not 100% correct).


    Through iTunes, I restored the ATV with the backdated software, and boom, no problem. I just had to remember to never accept the updates.


    All was good until a few weeks ago when I accidentally (stupidly) hit yes on the update request. Problem immediately resurfaced.


    But I thought, no problem, I'll just follow the same process as before (no way i was deleting that email).


    HOWEVER now I have a new issue, in that iTunes won't verify the ISPW file during the restore process. The only change between now and November last year is an updated version of iTunes itself. I've been in touch with Apple again, and they have been trying to sort out a solution for iTunes to accept the ISPW file, as they still say that is the solution to the main issue, but I haven't been able to arrange a time to talk to their PC expert, who needs to troubleshoot the iTunes I have, and find out why it won't verify the file.


    So anyway, when I get home, I'll post the email I received fromApple last year, Andreas it may help some people, as long as your iTunes allows you to restore the ISPW file....

  • Fiat Lux Level 1 Level 1

    Adding my name to the hat... the more the merrier. I'm running an ATV2 along with a Windows 8 PC. I have had issues since earlier this year when I replaced a Windows 7 PC with the Windows 8 model. That alone created a Home Sharing issue, which I have been remedying by toggling TCP/IP v6 on/off. Kind of a pain, but at least I could get things working.


    So that was bad, but things have gotten even worse since the latest ATV update, which I installed last week. Home Sharing is now essentially nonfunctional. I've seen past posts from people who couldn't get more than one song to play from their home library - that's my situation now. I've run through the usual battery of fixes: the TCP/IP fix, powering everything down and up, etc.  I cannot for the life of me get everything to connect for more than five minutes.


    Apple, I hope you're listening. I was an early adopter of both Airport Express and the ATV2, and have been directly responsible for about a dozen other people purchasing the Apple TV device. I have two more coworkers interested in buying, but I've told both to hold off until I can be confident in the product again.

  • ron310 Level 1 Level 1

    I just wanted to update anyone interested:


    It has been a month since i posted what worked for me and its still working.

    I've added another apple TV since then, so now I have 2 running fine.

    I have a windows 8 PC (set to never sleep) with iTunes running


    Here is how I resolved it:


    I went into windows firewall and removed bonjour from the allowed services.

    I then uninstalled bonjour from add/remove programs.

    I left iTunes (latest version) alone.

    I then downloaded the bonjour print service from apple (I think it was version 2.2, whatever the latest is).

    I installed the bonjour package and turned on the home share.


    It's been 34 days now and it's still fine.