1 12 13 14 15 16 Previous Next 228 Replies Latest reply: Jul 9, 2014 12:33 PM by Simon - Peter Go to original post Branched to a new discussion.
  • 210. Re: apple tv keeps dropping home sharing connection.
    TRYING-a-MAC Level 1 Level 1 (0 points)

    I am having similar problems. I thought I had it figured out quickly, I'm finding out it wasn't so easy.

    Here's my hardware:

     

    - MACBOOK i7 2012 OSX (10.9)

    -ATV 1080 WIFI -3rd Gen 2012

    -HP i7 Windows 7

     

    WHEN USING WIFI:

     

    -When I airstream or homeshare iTunes on the PC, it is SEAMLESS. Movies. Music. Quick. FAST.

     

     

    -When I use Macbook w/ WIFI, it BOGGS SLOW. Barely, or does NOT load movies. Choppy music at best. Screen freezes during airplay or mirrored desktop.

     

    I pulled up the Network diagnostics on my Macbook, and basically iTunes is sputtering out the data. Then it crashes. When using WIFI with the Mac/iTunes to the ATV, that is where my problem lies.

     

    SO---

     

    I plug in the ethernet cord to the ATV and BAMMM .. the Macbook streams FLAWLESSLY, everything works great. I look at the Net Diag on the MAC and it's flowing like water, just like the PC does over the WIFI w/ Itunes just fine.

     

    When the ethernet cable is plugged in, I can see both MAC and PC's Homeshared files, and I can go back and forth between them, changing nothing. Seems like everything works great. (so far) (said that before)

     

    When I switch to WIFI, basically only the PC will airstream movies and homeshare with the ATV.


    CRAZY, RIGHT? Why the **** would the PC work faster/more stable? It has to be something with iTunes on the Mac? Or something about Mac OSX? I would blame it all on the iTunes, but the MAC wont desktop mirror (which isn't in iTunes) correctly over WIFI either! So it must be something to do with the OS X. I had Mountain Lion, and that wasn't working at all. Now I am using the most updated version of Maverick to date.

     

    -I am using Windows 7 (seamlessly) on PC

    -on Macbook I'm using Maverick. updated. 10.9

    -iTunes is updated to date on both mac and pc.

    -ATV 3rd Gen is updated current software.

     

    -I have tried all the easy fixes I can think of. Resetting ATV/PC/MAC/router/itunes

    -I have no antivirus running on the MAC.

    -Ironically I have one antivirus running on PC, but that works great.

     

    I have tried using ONLY PC, and ONLY Mac, one at a time, with the other completely powered off. Reset all hardware and software, and still get same result. One time when the PC had been off and Mac had been running in background it was able to load one movie after sitting there for awhile. But I can start up PC and it SNAPS to the movie, or airstream QUICKLY.

     

    AND, when Ethernet is plugged in, the ATV is FAST AND RESPONSIVE and streams/homeshares/mirrors perfectly on both machines at the same time.


    Once again. I think this is somehow an issue with either the i7 Macbook Pro or with OS X. ONLY when using the WIFI. Is there some setting I can change? Or a fix? I am relatively new to Macs, and still could be overlooking something simple.

     

    H-E-L-P Please!

  • 211. Re: apple tv keeps dropping home sharing connection.
    Jim tideman Level 1 Level 1 (0 points)

    I am ****** about the bugs in the apple upgrade. My Apple TV is totally messed up. I think Apple owes me

  • 212. Re: apple tv keeps dropping home sharing connection.
    estebanmx Level 1 Level 1 (0 points)

     

     

    Ok I believe that I solve the problem it looks like the most craziest thing I was reading the Home sharing or how to setup home sharing from the apple web site i cant remember which one it was.it says that the time ZONE is very important and if you don't set the time zone to the correct location you can encounter disconnects it was the last thing I tried but it seems like it actually worked."

     

     

     

    Brilliant!!!  This solved my problem in a few keystrokes!  I like to keep my MacBook on ET, because that is where my employer is.  I live in CT.  Thus, my ATV was on a different time zone.  I can't believe this worked.  Thanks!!

  • 213. Re: apple tv keeps dropping home sharing connection.
    Theboyfromthefens Level 1 Level 1 (0 points)

    After updating Apple TV 3rd Gen at the start of November, we couldn't control it via iPhone Remote app any more - getting message on the app that the Apple TV wasn't on Homesharing (even though it said it was via the Settings screen).

     

    Having tried - and failed to resolve with:

    - wired connection, not wifi

    - fixed IP addresses for Apple TV and iPhones via the router

    - same time zone settings across devices

     

    ...we found what fixed it was (as mentioned on a few threads about this issue), manually updating the DNS server settings on the Apple TV and iPhones, to 8.8.8.8 (Google's free DNS). Seems to be that devices can reliably get an external verification of the Apple ID and connect together.

     

    Hope this helps someone.

  • 214. Re: apple tv keeps dropping home sharing connection.
    Patrick Mckelvey Level 1 Level 1 (15 points)

    This is not a reply, this is entering a discussion.

     

    Monday, December 2, 2013 - It FEELS like Apple is falling apart.

     

    Each new software upgrade, and there are many of them, causes a new problem with something formerly faithful.

     

    Now programming for AppleTV drops for no apparent reason and the message that Homesharing should be turned on,WHEN, IN FACT, IT ALREADY IS.

     

    Simply navigating back to the episode/movie/whatever and Resuming fixes my problem, but it is like having a Cadillac you just bought act like one from the 70s. It is like skating smoothly but suddenly your skate hits a gravel patch in the ice. It is like eating peanuts and suddenly breaking a tooth. Which is understandable once in a while, EXCEPT that it happens ALL THE TIME. Apple needs to get to the CORE of these problems. Seamless software not seemless software...PLEASE!

     

    mokelvey

     

    New AppleTV-involved hard/software (MediaServer iMac 7,1 OS X 10.8.5; iTunes 11.1.2; AppleTV2 6.0.2; AirportExtreme Double NAT 7.6.40)

  • 215. Re: apple tv keeps dropping home sharing connection.
    Alex57Russia Level 1 Level 1 (0 points)

    ....manually updating the DNS server settings on the Apple TV and iPhones, to 8.8.8.8 (Google's free DNS). ...

    Hope this helps someone.

    Yes, it help me. Changed DNS on  ATV3, and just in moment found my Home Sharing library. Black magic.

     

    ATV2 on 6.0.2 + iTunes 11.1.3.8 on win7 x64.

     

    And  before I tried turn off IPV6, run in XP3 mode.

     

    Hope this lasts for some long time.

  • 216. Re: apple tv keeps dropping home sharing connection.
    velocityofmoneyinc Level 1 Level 1 (0 points)

    i really hate this, This is unbelievable. APPLE TV *****. NOthing but pre pay for a black puck so i can pay for everything that is on it.

  • 217. Re: apple tv keeps dropping home sharing connection.
    velocityofmoneyinc Level 1 Level 1 (0 points)

    biggest piece off sh******T this apple tv update crap.     Really didn't want to be spending 5 hours trying to get this to work.       THis will be my last apple product. DONE

  • 218. Re: apple tv keeps dropping home sharing connection.
    lagunabob Level 1 Level 1 (0 points)

    I don't know if this is part of your issue, but lately I've lost home sharing a few times, and it appears that my problem was that my WiFi connection on my iMac that has my iTunes files was losing it's connection to my Airport Extreme Base.

     

    When I lost my sharing just last night, I went to the iMac and woke it and immediately saw the wireless reconnecting as it does when it's first turned on from the menu at the top of the screen. Once it reconnected I was good to go. So in my case, it's not my ATV2, it's my iMac losing it's WiFi connection.

     

    As a little side note, last night I was browsing my movies from that same iTunes library on that same iMac via the "Air Play" app on my iPad an lost connection at one point as well.

     

    I think I will try restarting the Airport....also check for Airport software updates. Hope this is helpful.

  • 219. Re: apple tv keeps dropping home sharing connection.
    colinfromdunstable Level 1 Level 1 (0 points)

    I think there may be an issue when using DNS to connect. ATV2 gives the failure to connect message until the IP address allocation procedure has completed, which maybe the reason yours works at the second attempt. (I had these symptoms).

     

    I just changed mine to Manual and gave it the IP address my router has actually reserved for it anyway, and no more problems.

     

    WinXP Pro / iTunes latest / ATV2 latest/ wired connection to BT HomeHub3.

  • 220. Re: apple tv keeps dropping home sharing connection.
    Alex57Russia Level 1 Level 1 (0 points)

    Tried you advice too (manual IP for ATV2 + DHCP constant IP on router), no luck. After reboot I've lost my home sharing again.

    -----------

    Currently i've downgraded iTunes back to 10.7 on my NAS, and set timer to sleep no "never" on ATV.

    That's "working" for quite a long time.

  • 221. Re: apple tv keeps dropping home sharing connection.
    JtR1888 Level 1 Level 1 (0 points)

    Ive solved it, I sold the Apple TV & bought A WD TV Play - awesome bit of kit - YES !!

  • 222. Re: apple tv keeps dropping home sharing connection.
    herbie226 Level 1 Level 1 (0 points)

    worked like a charm! thank you.

     

    basically to summarize my issue, when I was in the same room with the atv I had no issues. when I went into a room away from the atv my pandora stream kept stopping. distance should not matter since all my device were within the range of my wifi. the wifi signals were very strong on all the devices. I cant understand why distance would matter if I'm within the wifi signal but for whatever reason it does. for me this has been a pretty consistent issue for all os upgrades. this was the only thing thats seems to have worked so far.

     

    apple needs to correct this issue... it will prevent me from recommending anyone else to buy an atv.

  • 223. Re: apple tv keeps dropping home sharing connection.
    amazingcomputer Level 1 Level 1 (0 points)

    Jim tideman wrote:

     

    I am ****** about the bugs in the apple upgrade. My Apple TV is totally messed up. I think Apple owes me

     

    me too

  • 224. Re: apple tv keeps dropping home sharing connection.
    dsmith2387 Level 1 Level 1 (0 points)

    Was having this exact issue and it was driving me nuts after the 6.0.1 update.  What I did that seemed to fix it was

     

    1.  On the Mac I use for home sharing, i turned off home sharing

    2.  Ran this command in terminal "sudo systemsetup -setkernelbootarchitecture i386".  This sets the Mac to boot in 32-bit mode.  Reboot the computer and it will come up in 32bit mode

    3.  Launch iTunes and reenable home sharing

    4.  Run this command to get back to 64bit mode "sudo systemsetup -setkernelbootarchitecture x86_64" and reboot

     

    After doing this everything is working perfect on all 3 Apple TV devices in my house