Previous 1 2 Next 20 Replies Latest reply: Jul 31, 2012 3:23 PM by Federer Rules
SaqrRaafat Level 1 (0 points)

after updating safari it keeps freezing on youtube


I tried to reset safari , re-install it , remove all extentions but i still have the sae issue


I also tried to re- install flash player click to flash


but no change



any idea guys

MacBook Pro, Mac OS X (10.7.3)
  • Carolyn Samit Level 10 (103,360 points)

    Hi ...


    Try this...


    Quit Safari.


    Open System Preferences > Flash Player then select the Storage tab. Click: Delete All


    Now uninstall the Flash plugin then reinstall new >  Troubleshoot Flash Player | Mac OS


    Make sure and uninstall first.


    Now launch Safari  From your Safari menu bar click Safari > Empty Cache


    Now try a video.


    BTW... if you have the ClickToFlash extension installed in Safari > Preferences > Extensions, that can prevent Flash based video from streaming. It can also be installed as a plugin in /Library/Internet-Plug-Ins.


    And check to see if Safari is running in 32 bit mode. Right or control click the Safari icon in your Applications folder then click Get Info. If the box next to:  Open in 32 bit mode  is selected, deselect, quit then relaunch Safari.

  • SaqrRaafat Level 1 (0 points)

    Thank you Carolyn


    I tried your steps but still i have the same issue


    everything freezes in safari whenever i lunch video in youtube


    It was working well this is happened after last 2 safari updates

  • Carolyn Samit Level 10 (103,360 points)



    Quit Safari.


    Click the Finder icon in your Dock.


    Now from the Finder menu bar top of your screen click Go > Go to Folder


    Type this exactly as you see it here:    ~/Library/Caches/


    Click Go


    Move the Cache.db file to the Trash.


    Relaunch Safari, try a video.

  • Linc Davis Level 10 (192,275 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    The purpose of this exercise is to determine whether the problem is localized to your user account. Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem(s)?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    Note: If you’ve activated “Find My Mac” or FileVault in Mac OS X 10.7 or later, then you can’t enable the Guest account. Create a new account in which to test, and delete it, including its home folder, after testing.

  • SaqrRaafat Level 1 (0 points)

    i tired it no change

  • SaqrRaafat Level 1 (0 points)

    it works but how can i fix it in my main account !!!



    what was the problem you think and how do I solve it


    in the new guest account youtube was working well


    after deleting the account and backed to my main one the problem backed again

  • Linc Davis Level 10 (192,275 points)

    Please read this whole message before doing anything.


    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.


    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.


    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.


    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.


    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then either copy or drag it. The headings “Step 1” and so on are not part of the commands.


    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Terminal in the page that opens.


    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” (without the quotes) and press return. You should then get a new line ending in a dollar sign.


    Step 1


    Copy or drag — do not type — the line below into the Terminal window, then press return:


    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'


    Post the lines of output (if any) that appear below what you just entered (the text, please, not a screenshot.)


    Step 2


    Repeat with this line:


    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'


    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning.


    Step 3


    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'


    Step 4


    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null


    Important: If you synchronize with a MobileMe account, your email address may appear in the output of the above command. If so, anonymize it before posting.


    Step 5


    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null


    Remember, steps 1-5 are all drag-and-drop or copy-and-paste, whichever you prefer — no typing, except your password. Also remember to post the output.


    You can then quit Terminal.

  • ejotto Level 1 (0 points)

    i'm having the same issue and this didn't do anything to help my browser.

  • SaqrRaafat Level 1 (0 points)

    I finalllllly solve it



    i did Carolyn Samit after making the guest user test by Linc Davis


    then I made reset for safari


    now it is working well

    thank you guys

  • ejotto Level 1 (0 points)

    figured it out. apparently i was a part of some new youtube trial? click on this link:

    all you have to do is click "leave trial" and my youtube is working fine now!

  • DMahony Level 1 (0 points)

    @ ejotto:


    yours is the one and only solution. Thanks a lot!


    HTML5 Trial was somehow overriding FlashPlayer creating conflict.


    Spread the word!!!


  • Shabab28 Level 1 (0 points)

    Thanks mate this was really helpful!! it worked like a charm. I don't understand how youtube automatically add people to their trial without asking for your consent not to mention all the tracking they're doing in conjunction with google to spy on you... really it's time for a alternative to youtube that will respect users privacy...sgh...

  • erash Level 1 (5 points)

    thank you so worked like a charm. I was thinking it's my internet connection which is slow...later with firefox i found out, that safari is the only one with the problem. Now it's working great. Thank you again mate.

  • Steve Hayes1 Level 1 (105 points)

    Yep, like to add my thanks to everyone. In the end it was the getting out of youtube trial that helped me. Disappointed that youtube didn't (to my knowledge) inform us of this or even issue any kind of info (again, to my knowledge). Thanks ejotto

Previous 1 2 Next