Previous 1 2 3 4 5 6 Next 171 Replies Latest reply: Sep 7, 2014 6:11 PM by George Hulseman Go to original post
  • ayito21 Level 1 Level 1

    Chatlanian, EJKitchen, it's not your logitech devices. I have a regular apple mouse and a regular apple Keyboard and exactly the same issue. thunberbolt 27inch, and Macbook Pro 13inch with i7, 8GB ram, etc.


    This has to be a software problem, not a hardware issue.

  • t-leish Level 1 Level 1

    I purchased a brand new MacBook Pro and Thunderbolt display 2 months ago and have been fighting with the USB Apple keyboard ever since.


    USB Setup: MacBook Pro > Thunderbolt > USB Apple Keyboard


    After waking up my sleeping MBP and plugging the TB DIsplay in, the keyboard wouldn't work.  Sometimes I could get it to work by re-seeding the MBP plug 2 or 3 times, but not always.  At that point I might have to reboot once or twice to get the USB keyboard to work.


    Sometimes I'd just give up and plug the apple keyboard directly into the laptop whre it worked immediately.  I tried other tricks such as switching the USB ports on the back of the TB monitor, etc., but no luck


    USB Power?:
    Finally on a hunch I wondered if the USB keyboard might not be getting enough power from the TB USB ports, so I purchased a "powered" USB Hub (Tripp Lite).


    Last week I got the USB hub and while my keyboard was not working through the TBP, I unplugged the USB keyboard from the TB, plugged in the USB Hub, and plugged the keyboard into the USB hub.  The keyboard worked immedately. 


    USB Setup: MacBook Pro > Thunderbolt > Powered USB Hub > USB Apple Keyboard


    I was skeptical that it might be that simple, perhaps the MBP recognized a new USB device and it somehow (temporarily) reset something.  However, after the weekend of the MBP being asleep and plugging in the TB to my MBP this morning, the keyboard is still working as expected.  Crossing my fingers that this has solved the issue.


    If this does solve the problem permanently, it's disappointing that such expensive hardware can't do USB power management properly where a $30 piece of hardware can.  Also, my desktop is not as clean anymore with the USB hub (which is part of the reason for buying the TB), but keyboard now works.

  • Gorbet Level 1 Level 1

    I got very excited about this post, because one of the things I was doing when it seemed to work "intermittently" last time I posted was trying out a powered USB hub for the first time, and plugged the UR into the powered hub.  So I returned for some more detailed testing (but in the end, it doesn't seem to have solved the problem for me...)


    CMM = Logitech USB Cordless Mouseman

    PMX = Logitech Performance MX mouse

    UR = Logitech Unifying receiver (for PMX, not for CMM)

    TPH = Targus powered USB hub

    TBD = Thunderbolt display

    TBC = Thunderbolt cable

    MBA = MacBook Air


    Here's what I did, in sequence


    CMM in (plugged into the TBD)

    UR in

    TBD power cable plugged into MBA

    TBC in

    --> CMM not working


    TBC out

    UR out

    TBC in

    --> display not recognized


    restart MBA

    --> CMM works


    TPH in (but without external power)

    UR in TPH

    --> PMX works, CMM works (note: UR plugged in AFTER TBD connected to MBA -- this has always worked)


    TBC out

    TBC in

    --> neither PMX or CMM work (note: external hub still unpowered)


    TBC out

    TPH external power connected

    TBC in

    --> display not recognized


    restart MBA

    --> CMM & PMX work (note: booted with UR in -- this works all the time anyways)


    TBC out

    TBC in

    --> CMM & PMX work!  (hot-swapped with UR in, and it works...this rarely happens)


    TBC out

    TBC in

    --> neither CMM nor PMX work   :-(


    TBC out

    TBC in

    --> display not recognized

  • t-leish Level 1 Level 1

    The TBD itself has always worked for me, just not the USB via TBD.  Sounds like a slightly different problem.

  • BrownChile Level 1 Level 1

    Just getting in on this discussion which happens to be the same issue I have.


    My setup is a TBD, MacbookPro 13", and Logitech Performance Mouse plugged into the laptop (not TBD). However, I do have the logitech charger plugged into the TBD.  I've had this, my iPhone charger, and an external USB hard drive plugged in the TBD for a couple of months now with no issues. 


    The only thing that I can think of that caused all my USB ports to stop working was when I removed the hard drive and plugged in a Samsung Galaxy Tab 2 tablet for use in Android development.  So I'm not certain if it's a logitech versus other device (Samsung tablet in this case), or whether it's the TBD firmware causing the issue.


    Needless to say, I shut everything down and rebooted my laptop while still plugged into the TBD.  Everything seems to be working fine now.  I've decided to plug my galaxy tablet into the wall instead.  I was quite happy with my 2 months of uninterrupted USB issues, so I'm willing to sacrifice a direct connection with my tablet at this time for hopefully a longer than 2-month stretch with no USB issues.  Not sure if all of this helps or not, but there it is.

  • FullBleed Level 1 Level 1

    For me, the source of my problem is either directly/indirectly linked to the Unifying Receiver.

    For a week, I've taken the UR my and Performance MX out of the equation and am just using a Magic Mouse. I haven't had any of the aforementioned problems since then, but as soon as I plug it in, on the next hotswap connection of my MBP to the Thunderbolt display, the problem returns (desktop extends to ACD, but all peripherals are dead until I restart).

    I can't stand the ergonomics of the Magic Mouse, so until this is resolved I may pick up and use a decent wired Logitech mouse.

  • Gorbet Level 1 Level 1



    Yup, that sounds consistent with @Chatlanian's observation about Android devices plugged into the TBD UBS hub.



  • Chatlanian Level 1 Level 1

    Totally with you there @FullBleed, Magic Mouse needs to take shape of something that is comfortable to work with, rather then something that looks cool sitting on the table. That is why Rob and I and plenty of others use Logitec mice - they are nice to hold and click with, and can be charged quick with a mini USB cord, thus one can still work with it while it is charging.



    It seems that TB+MBP combo does not like to:

    1. Go to sleep with one combination of USB devices plugged in to the display then and wakeup attached to a display that has different set of USB devices.

    2. Go to sleep without being plugged in to TB and then wakeup while plugged in to TB that has other devices plugged in to it.

    3. Boot when attached to a TB that has non apple devices plugged in to it.


    Now I am with 2 TB (one at the office and one at work) - same problem.


    In any event. I hope that Apple gets to read this thread and do something about the TB. After all we pay $,$$$ for it.

  • svgstephen Level 1 Level 1

    *** Attention Rob ***


    Thank you for posting on my setup ( /)


    So i did a quick scan of this thread and let me fill you in of what i found:


    I have definately had 2 issues with my MBA mid 2011 and Thunderbolt display (which is annoying considering how much the thing costs!)


    Issue 1 - intermittently issues with the mouse and the IR receiver. Doesnt happen that often but sometimes the mouse just goes and then freezes all the ports its so annoying. there is no specific pattern but yes i will then plug it into the MBA and its working again, sometimes i need to reboot and put it back in the thunderbolt display and its all fine and dandy. Def still happens.


    Issue 2 - EVEN MORE ANNOYING - when i do use the MBA, close the lid , plug it in to the display sometimes i get nothing and cant get it out of sleep mode i then unplug and the MBA wont even get out of sleep mode at all i have to hold the power button and then do it this way. I do notice the USB IR receiver is plugged into the monitor.


    These are the only 2 issues i have with this setup.

  • BusinessHelper Level 1 Level 1

    I'm having the same issues. I just purchased the new MBA a couple of weeks ago after it's release. I also got the 27" TB display. I have an external Firewire Drive for Time Machine Backups, an Apple USB Keyboard (also new) and a mobee Magic Mouse charger plugged into the TB. This setup stays in my office and I take the MBA home every night. For the last week, I've consistently had the Keyboard problems every morning when I connect the MBA back to the TB display.


    I've also had Time Machine Errors with the Firewire Drive. When I try to eject the disk after the error it never wants to eject and I end up just unplugging it and getting the warning. When I plug it back in, all is good.


    The keyboard seems trickier adn this morning after plugging it in and out several times, I connected it directly to the MBA and after several seconds it worked. Then I plugged it back into the TB display and it continue to work.


    This evening, I'll try unplugging the display and see if the problem persists in the morning. I'll also try disconnecting the mobee.

  • Ixa12 Level 1 Level 1

    I very much believe that all these issues have to do with Lion. I had no problem whatsoever using MacBook Pro or Air with my Thunderbolt until a few months back. After some of the upgrades, not sure which version now all USB stop working.  First unplugging would help but not anymore.  I tried the fixes suggested by other posters but nothing works. I have now to plug both the mouse and the keyboard directly into the Macs. I just recently got my new retina MacBook pro and have same issue with it.  I guess one can only hope that Mountain Lion will fix it

  • Jeff Tomascak Level 1 Level 1

    I had same problem this morning  (Retina MBP 15" 768GB flash 16GB memory 2x Thunderbolt Display ) none of the usb ports on either monitor were providing power.  I unplugged each monitor from the wall socket and plugged it back in and all USB ports are back working.  weird.

  • myc52002 Level 1 Level 1

    Same exact problem for me as well started this week after no issues for the last month - New MBPr / TB, apple keyboard.  The only other items I have is a USB flash drive and HP printer plugged into the TB display. 

  • mwilliford Level 1 Level 1

    I have a brand new MBP Retina, connected to a brand new Thunderbolt display.  I'm very new to mac, but I'll provide another datapoint here as I'm experiencing a similar issue. 


    My config:


    TB display has connected:

    -  USB Apple keyboad

    -  USB Disk Drive, typical USB/SATA conversion

    -  Logitech USB Headset

    -  Ethernet to my local switch



    If the system (MBPr) goes to sleep (while I sleep), in the morning my disk is umounted, network is down, and my keyboard doesn't work.  So, basically, all accessories on the TB Display become unavailable to the system.  I reboot fixed it for now, but I bet this problem continues to occur for me.  Since everything is new, I'll look for a support # to call, just to let them know this problem is wide-spread. 



  • michalfrombrno Level 1 Level 1

    I have the same problem. My configuration: MBA 2011, TB Display, Logitech Unifying receiver with Logitech Solar Keyboard for Mac.


    Upgrading to Mountain Lion didn't help.

Previous 1 2 3 4 5 6 Next