Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: one or more items can't be changed because they are in use

I am trying to copy over 1TB of data from a internal hard drive (in a hard drive dock) to a new internal hard drive when I attempt to copy the data I get the message in the topic title.


I was originally trying to do this transfer on Snow leopard and when this problem surfaced decided this was a good time to upgrade to lion and blow away the old system with all the rubbish and start a fresh but as you can tell I am still getting the same error even after formatting the hard drive before installing lion and not doing anything with the system except attempting to transfer the data.


I have copied larger amounts of data than this previously so have no idea what is going wrong.

Posted on

Reply

Page content loaded

Nov 30, 2012 5:45 PM in response to Grant Bennet-Alder In response to Grant Bennet-Alder

Thanks for the quick reply. I was afraid that's what I would have to do... I should have researched the TC more before buying it. Not being able to migrate my existing backups in is a significant drawback.

Nov 30, 2012 5:45 PM

Reply Helpful

Jul 22, 2014 8:15 AM in response to henin In response to henin

Thanks henin,


I had this here file, which was greyed out ...

User uploaded file

... and when I tried to copy it I got this crappy message even though I had just plugged in the harddisk and with only Finder running.

User uploaded file


I followed your instructions, though I found it was easier for me to skip the "cd" step, so what I did was:


  1. Launch Terminal, located in Applications/Utilties.
  2. Write "xattr -d com.apple.FinderInfo " - without the quotation mark, but remember the last space (just copy/paste the text).
  3. Drag and drop the offending file to the Terminal window and press Return.


When you drag the file to the Terminal window it automatically writes the full path for you (hence no need for "cd"), and if your file has spaces in the name it puts the appropriate escape signs in, so you don't have to do this yourself. Just repeat step 2 and 3 for any files.


This was much quicker than having to write every name (I had more files with very long names), however, I probably wouldn't like to do this for thousands of files, he he.


Hope this helps someone. Cheers, FlashGirl 🙂

Jul 22, 2014 8:15 AM

Reply Helpful

Feb 17, 2015 1:59 AM in response to Linc Davis In response to Linc Davis

Well if you have a unique name for the disk (say "Installers" or something), open up Terminal and type this in:


lsof | grep Installers


This will show all the open files. On my system I get this:


hotel:~ tom$ lsof | grep Installers

Finder 915 tom 12r DIR 1,6 102 760504 /Volumes/4TB/4TB/Installers/_CCC Archives/2015-02-05 (February 05) 11-22-07/Mac/Internet/FileZilla.app/Contents/_CodeSignature


Shows me the Finder has something open in some redundant backup of a deleted file from Carbon Copy Cloner (_CCC Archives). Trouble is it still gives me this after deleting the whole _CCC folder and emptying trash.... (OS 10.9)

Feb 17, 2015 1:59 AM

Reply Helpful
User profile for user: macnewcomer22

Question: one or more items can't be changed because they are in use