3 Replies Latest reply: May 3, 2012 2:50 PM by c.jones586
c.jones586 Level 1 Level 1 (0 points)

I have iPhoto v9.1.5 that came pre-installed on my iMac. However, although there have been newer versions available on the App Store (currently up to v9.2.3) there have never been any updates available in "Software Update".

 

Weirder still, when I go to the App Store, iPhoto is one of the apps showing as available to update. But when I click to update, the App Store sometimes tells me I "must log-in with the account used to purchase the application", and sometimes that "only apps purchased from the App Store can be updated". I've tried both the accounts I have with the App Store, but same result each time.

 

I had a very disappointing experience with Apple Customer Support, speaking to several people in different departments - none of whom could explain why I couldn't update iPhoto, nor offering any kind of fix. Not what you expect from Apple!

 

Does anyone have any clue how I can fix this? v9.1.5 ***** on so many levels - but then maybe v9.2.3 is just as bad and I should just trash it and use something else anyway..... Any advice will be considered!


iPhoto '11, Mac OS X (10.7.3)